This site uses cookies to offer you a better browsing experience. Find out more about how to manage cookies, or dismiss this message and continue to use cookies.

Can't Unlock Maps

Just was given a Nuvi 200 as a gift. Downloaded latest firmware and map updates.

When I turn the unit on, it initializes, loads maps, gives the Warning screen, and then gives a screen "Can't Unlock Maps". I click Ok and it goes to the "Where to/View Map screen. If I go into the maps, it appears I'm viewing them OK - but I don't know if they should be any different than they are as I've never seen another unit in operation. Why am I getting the "Can't Unlock Maps" screen??

Keith

Comments

  • what Map updates did you download ?
  • I'm assuming it was an update to the maps that were included in the unit (Canada/Northern US). I downloaded MapInstall from the Garmin site. When run it ID'd my unit and I could choose what map segments to put on it. Loaded the main unit with eastern Canada and New England states. Put Newfoundand, The rest of Canada (west of Ont) and the rest of the Norther US states on an SD card. I am able to view all these areas (both those installed to the unit and those on the SD card) in detail on the unit.

    I also have MapSource (have an Etrex Legend) but don't think I tried to install maps from that - but might have. How would I know?

    Keith
  • What version of Map Source are you using? And what versions of CITY NAVIGATOR?
  • MapSource Ver 6.13.7 (Clicked "Check for Updates" and it went through the motions of downloading and installing Ver 6.14.XX however when the program relaunched, it still indicated 6.13.7)

    Nuvi 200 Settings/Map/Map Info says "City navigator North America NT 2009"
    then under that:
    "[1] ALBERTA, SASKATCHEWAN, MANITOBA, BRITI" (rest off the screen)
    "[2] ONTARIO, NEW BRUNSWICK - P.E.I. - NOVA SC" (rest off screen)

    Thanks for your replies

    Keith
  • Anybody got any idea why I'm getting the "Can't Unlock Maps" screen? How can I get rid of it? Is there anyway I can reset this to factory defaults/maps and then start over with updating firmware and maps? If so, will that get rid of the message?

    Keith
  • Your best bet would be call garmin and talk to Tech support 1-800-800-1020
  • Usually one of three reasons:
    1. The GPS unit is missing the unlock code;
    2. Locked supplemental maps have been downloaded to the GPS; or;
    3. Locked supplemental maps have been downloaded onto the SD card.

    Go to "www.My Garmin.com" and under "FAQs" do a search for "Can't Unlock Maps". There is a complete how-to to get rid of the message.
  • Thank you jhwjrma

    I found the link. Almost worked! I noted that the GMAPPROM.UNL file had my Product Code in it rather than my Unlock Code. Put the right code in however still get the Can't Unlock maps error. Removed SD card and error still there - so problem is with the unit;not the card. Removed the supplemental maps image and got an error saying there were no maps. Reinstalled the CDN maps with Mapinstall. Still getting the error. Frustrating. Will try Garmin support later today.

    Keith
  • SergZak 340 Points
    Be sure the unlock code you entered in GMAPPROM.UNL does not contain any dashes or spaces.
  • Thanks to everyone that replied. Finally got it fixed! After searching the forums and countless websites, I eventually gave up and took ordertwo's advice and called Garmin support. Was expecting to spend hours on hold but got through to a tech almost immediately. Great service!

    My problem was that apparently the unit originally came with 2008 maps. Somehow during the auto-upgrade it appears the transfer may have been interrupted and restarted or something (supposition only). Anyway, the 2009 maps were installed as supplemental ones with the 2008s staying as the main ones. Unlock code was fine for the 2009s but was overwritten for the 2008s. The original maps were what was giving the error and I could still use the maps because the 2009s were unlocked.

    As per direction of "James" at Garmin, I deleted both the gmapprom.img and gmapsupp.img files from the unit. Reinstalled all maps with Mapinstall (these were named as gmapsupp.img); renamed the gmapsupp file to gmapprom and voila! No errors and I have more space free on the unit!

    Thought I should post the fix in the event someone else experiences the same problem. Thanks again for all your help.

    Keith
  • zoloft 0 Points
    Very helpfull;
    Thanks !
  • zoloft 0 Points
    unfortunatly..STILL not work
  • I tried everything to get rid of the "Can't Unlock Maps" (Nuvi 1410) message and finally decided on desperate measures and gues what - IT WORKED.

    Here is how I did it.
    1.Uninstall ALL Garmin programs from PC
    2.Delete all files in "MAP" folder on GPS Unit then unplug unit from PC
    3.Run regedit on PC and remove all references to "Garmin or Mapsource" - Make backup of registry first. MAKE SURE TO DELETE CONTAINING FOLDER AS WELL IN REGISTRY IF IT ONLY RELATES TO GARMIN.
    4.Restart PC
    5.Plug GPS Unit in and it should show as new hardware.
    6.Re-install Maps
    and VOILA all should be well.

    WARNING - BE CAREFUL IF YOU ARE NOT USED TO USING REGEDIT
  • howardc64 80 Points
    edited November 2018
    fixed my Cannot unlock map problem today. Issue was GPS's previous owner used it outside of country and have a left over gmapsupp.img file under a MAP directory (previous owner probably put a out of country map in here) I just mounted the GPS onto my mac, opened up the folder and started looking for old files and found this one. Once removed, no longer any boot error messages.
Sign In or Register to comment.
↑ Top