This site uses cookies to offer you a better browsing experience. Find out more about how to manage cookies, or dismiss this message and continue to use cookies.

SD card not readable / XP won't mount unit

kpence73 0 Points
edited November -1 in NAVIGON Forum
I have tried to connect my new 8100 to a Windows XP and a Mac and neither one will read the unit. XP finds the hardware, but won't install the drivers right and tells me my new hardware will not work properly. Navigon support told me to call Microsoft. Then I tried to read the card in a card reader on my Mac and it tells me the card is not readable.

Does anyone have any idea what is going on?


  • Tim 1484 Points
    What are you trying to add to the device?
  • Nothing right now, just got it today and I was trying to set up Fresh, but Fresh tells me there is no device connected, so I tried to access the SD card directly, but no go. Sometimes I can see the unit as letter E: but it tells me there is no "disk" in the drive.

    I have a HP printer that acts as my card reader and it tells me that the card is unreadable.

    Sometimes XP will say "NAVIGON" found, then I get a cannot install hardware error.

    The issue now is, how do I backup or update if the card is not readable. I have a 8100 so there isn't an update available for it yet on the NAVIGON site unless the Mac OS/Other 1.2 update works on the 8100 as well.

    UPDATE: Tried to get it to work with Vista and had the same luck. It fails to install the USB Mass Storage Device.

    2nd UPDATE: I took it to work and connected it to my XP laptop. This time it worked. I still don't know why my printer/card reader wouldn't read the card on my Mac. Sometimes the Mac would say, "This drive is not readable on this computer" and other times the printer would just give a card error. When I took it to work, I discovered the card is a 4GB one and I am thinking that maybe the printer/card reader doesn't support cards that big? Is that a possibility? I went ahead and copied the card to a folder on my laptop, then reformatted the drive as FAT32, which is what it said it already was, then copied the contents back. I am hoping that reformatting it will make it readable by my Mac

    3rd UPDATE: It was the SD card. It is a SDHC and my printer's card reader isn't compatible with SDHC. I got a new reader and it worked fine.
Sign In or Register to comment.
↑ Top