This site uses cookies to offer you a better browsing experience. Find out more about how to manage cookies, or dismiss this message and continue to use cookies.

Trouble connecting Tomtom One XL to PC

llcooljunr 0 Points
edited November -1 in TomTom Car Forum
Anyone have trouble connecting their One XL to Tomtom Home? I've tried connecting 2 One XL's to my laptop and I follow all the directions, and I've still ended up with the screen with a red X on it that won't go away. I've got Bestbuy's Service Plan on it, so I've returned it for a third one. I'm scared to plug this one in for the fact that I might get that red X again. Anyone know what I'm doing or what I'm doing wrong?

Comments

  • Tim 1481 Points
    So it works fine until you connect to TomTom HOME? Are you on a Mac or PC?
  • I'm on a PC. Everything is fine till I connect it. The first one I had I immediately connected it to my computer as soon as I got home to see if there were any new updates. The second one I took on a 2 week road trip, with no problems, but as soon as I took it home to check for updates again it did the same thing. This third one I got was actually different. Upon turning it on, it asked for the code on the card that it came with before I could actually use it. I'm still shaky on whether I want to try and connect this my PC. All other products I've tried connecting through my USB 2.0 slot have connected fine, so I'm not sure what's wrong.
  • Tim 1481 Points
    I've had a similar thing happen to my ONE XL, so I know what you are describing. Basically what was happening was the wrong, or perhaps corrupt version of the application was getting installed. I'm not sure, why, but deleting the application that was downloaded by home, then re-downloading the application (perhaps after they had fixed it) stopped the problem from happening.

    You could try just not running the application update, but letting other things (like QuickFix, etc) update.
  • Alrite cool, thanks for the help. I'll try deleting those applications downloaded by home and try to redownload them again. Now I just need to man up to connect the One XL to the computer again...hehe
  • Tim 1481 Points
    Yea, from the times it happened to me it wasn't the process of connecting to HOME itself that caused the fault, but rather the application update that wrecked it.
  • Hi everyone, I'm a newbie and saw this post and wonder if my experiences can help.

    I bought a Tom Tom One XL through Best Buy and run it on my Powerbook G4 using Mac OS X 10.3.9

    It worked perfectly out the box.

    My troubles started when I downloaded Tom Tom Home from the original CD and then connected and downloaded the updates from the Tom Tom website.

    I could not restart my One XL just getting the red X screen described earlier.

    I contacted Tom Tom support by phone. I was told there was a flaw in the CD Home program and should download it from the Tom Tom website.

    Once done I was then told to delete the tom tom program on the xl. This we could not do due to the unit saying insufficient memory.

    I was then told to download a special removal tool from the website which supposedly would strip out the old corrupted programme so the new program could be installed.

    Unfortunately, there was not room for that download to work. I was given a special reference code and told to go back to Best Buy and get an exchange unit. This I did and took home my exchange unit which also worked perfectly out the box!

    Remembering my fiest experience I did not download Home from the CD but went to the website and got it from there. I connected up the XL and with heart beating started the upgrade.

    When I tried to restart, yes you have guessed it I got the dreaded red X!!!

    Once again I rang up Tom Tom support. This time I got a guy who you just knew knew what he was talking about! He was smooth, calm and sounded the way an air traffic controller speaks.

    I explained my experiences and the actions I had taken he confirmed that I had done nothing wrong and the fault was a software fault. Once again through Tom Tom Home I was instructed to download the removal tool. Download the updated XL program. Delete tje old XL program and install the updated one.

    Everything worked flawlessly and I have since downloaded updates without problems.

    Basically, if you are having probs I would speak to Tom Tom support directly.

    If you can't you need to ensure you have the latest version of Home installed on your computer.

    Download the removal tool and latest Tom Tom One XL program.

    Use the removal tool then install the new program and restart hopefully all will work well and this helps you.
  • it seems we have the same experience, with the red x I had to buy a new one because of a time crunch for a business trip, now the new one has done the same thing, as soon as it is connected to the site, it says update, then after updating cannot write to disk,because of past failure to load to disk, then this dreadful red x
    I have called customer care to no avail.
    any ideas anybody?

    Cheers Alan.
  • dhn 336 Points
    What new model are you talking about? What do you mean by failure to load the disk??
  • Thank you for your reply.
    It was updating as it requested, then a failure notice came on, due to earlier failure, could not write to hard drive, it seems like its working and writing to the hard drive on the tomtomxl, but on step #2 cannot write to disk, step #3 due to earlier failure cannot complete.
    I did buy a used tomtom yesterday, it was working very well, I tried to update it, the same thing again, now I have two red Xs
    I am afraid to go near my pc.

    Please any ideas?

    Thank you.
  • dhn 336 Points
    Not without specific answers to my questions, I'm afraid.

    What model did you buy which is now not working?
  • thank you for your reply.
    the new one is a tomtomxl when i say new, it had not been used, an unwanted gift.

    thank you.
  • dhn 336 Points
    All I can suggest is the following:

    For the new device..........

    1. connect to the computer and make an Explorer, not Home, backup. If not sure how, see here:
    http://www.tomtomforums.com/t17864-how-backup-contents-your-unit-computer-how-restore.html

    2. Delete all the loose files in the root of the unit, NO folders or their contents.

    3. Connect to Home 2 and install the application offered. It should be 9.045 for that model. Disconnect properly from Home using the Device Disconnect icon.
  • Good morning, thank you so very much, I have the one up and running, the original one I purchased 2 years ago, is running, but the buttons are not working correctly, everything lights up, for example, you press the p button, the x and the l flash, and ideas.

    Thank you so much.

    Cheers Alan.
Sign In or Register to comment.
↑ Top