This site uses cookies to offer you a better browsing experience. Find out more about how to manage cookies, or dismiss this message and continue to use cookies.

Problem with MyGuide 4200 (White Screen)

hashte 0 Points
Hello people!

I have a big problem with a Windows CE 5.0 - based MyGuide 4200 PNA. Some 2 days ago I was just copying some files via ActiveSync on it when, suddenly, the screen (of the 4200) turned white. The transfer freezed. I switched the PNA off and again on (with the switch at the backside, not with the usual stand-by button) and the screen was still white + the Windows on my computer was saying in a bubble "USB device not recognized". Furthermore, after some seconds after turning on the device I get some vertical, thin colored stripes on the screen. If I tap on the screen, I hear the tapping sounds, so the device seems to work at its heart.

I tried all the possible ways to (hard)reset the device, but none of them worked. The device has no reset button (like one of those where you have to use a pin or needle to reset it). It may be a problem with something corrupted on the device, including the video driver. I also mention that the battery was low when I was doing the transfer, and maybe went totally empty when all happened.

It seems that MyGuide company doesn't exist anymore, also the support telephone number here in Holland is not existing anymore.
About my problem, I found only this on their old support site:

1) Does anybody know how to hard-reset the device (besides using the on-off switch at the back)?
2) Is it possible to reinstall Windows CE on my PNA?

Thank you very much! I hope that somebody can help me here.


  • Boyd 2027 Points
    No familiarity with that model. But Windows CE based units typically have some special filename which will automatically launch if present on a memory card. This technique is generally present so that the manufacturer can restore software by inserting a card even if the USB interface doesn't work.

    This probably doesn't help much, but might point you in some kind of direction. The file is "CELauncher.exe" on the HP iPAQ and is "tocopy.exe" on some of the Magellan series. No idea what it would be for you.

    We don't get into very many advanced tech discussions like this around here unfortunately. I suggest you visit the "AIO" forum at That's where people who hack Windows CE units hang out, and maybe one of them can help you.
  • hashte 0 Points
    Thanks a lot buddy! I already posted this problem on gpspassion yesterday, but not any response till now.
    Your information is very good, I was also thinking that it should be something like this. But Google is not generous with good results on this topic:(
    If you have any more ideas, please post them here!
Sign In or Register to comment.
↑ Top