The 'Mark Viewed' options have been temporarily disabled due to a performance issue.

TomTom 730 Touch Screen doesn't work

moorpheus 0 Points
edited November -1 in TomTom Car Forum
I guess I'm the only one who has had this problem because multiple searches with different descriptions found nothing.

It turns on, but I cannot access because no touch screen. I've hard rebooted to no avail. I can't use Tomtom Home, because the touchscreen doesn't work to say yes, connect to computer.

Times like this make me yearn for my old Magellan that had external controls too. Hmmm. Maybe I can find it for this trip today.

Any fix suggestions?

Comments

  • dhn 191 Points
    Under warranty, perhaps? If so call support at 866-486-6866.

    You can try applying pressure all over the screen when you see the 'yes' button on screen. Maybe it has been miscalibrated somehow.

    Other than a pin reset (again), don't know what to suggest.

    You are using the proper reset hole on the bottom and making sure you are applying enough pressure (paperclip) in the hole?

    Does the touchscreen work when the unit is not connected to the pc?
  • On another site, I read some advice to take a paper (I used the edge of the plastic iPhone cover I used to protect screen) and and run it under the edges to dislodge any possible dirt that could've gotten under the edging.

    I didn't have a clue that edgine was a softish plastic.

    The screen protector has some light adhesive. Now I'm betting that some of it melted and ran down under the edging.

    Glad the fix was something easy!

    Thanks for responding!
  • dhn 191 Points
    Ah! Additional information (screen protector)...

    Yes, I've suggested the cleaning of the bezel and removal of the protector on another site as well. The usual symptoms of the screen protector shrinkage and dirt is that the screen acts as if a 'ghost' is touching the icons at random. Not just no response at all.

    Glad it's sorted.
  • Kewl, it could've been your message!

    What I did was run the sharp plastic under the edging(edging = bezel?) and voila! It worked. Then I did it a few more times to be sure it was truly cleaned out. I saw nothing removed, but the proof is that it started working.

    I figured it was worth a try -- and it worked. So, it might not be a solution for everyone, but I hope this is easily found through search!

    Thanks VERY much. Sure raised my growling spirit to a big smile!
Sign In or Register to comment.
↑ Top