Roadmate 1470 Firmware 2.04 posted
  • gatorguy
    Posts: 7,244
    http://magellan.cachefly.net/softwareupgrades/web/Magellan_RoadMate_1470_2_04_Rel2.zip

    Be sure to look at the ReadMe pdf file before attempting installation.
  • niks1
    Posts: 79
    Apparently, update ver. 2.04 is no longer available at the Magellan site, as was reported on other GPS forums earlier today. Thus, ver. 1.15 is the only choice, which may ruin your GPS.
    Full address for the 2.04 is
    http://magellan.cachefly.net/softwareupgrades/web/Magellan_RoadMate_1470_2_04_Rel2.zip
  • gatorguy
    Posts: 7,244
    Thanks for posting. I didn't notice that my link address was truncated. I had downloaded that file earlier to see if there was a list of changes. There wasn't.
  • Marc
    Posts: 1,241
    So anybody try this release?
  • PND4ME
    Posts: 652
    Marc said:

    So anybody try this release?



    Yes, I did and noticed a number of issues addressed but the update have cause some new issues, this is the reason why they took it down. They are getting it down and it is getting much better. The old saying hold truth, what you don't know can't hurt you. lol
  • Any more news for the firmware update for the 1470 I have one with 1.12 but it has "ISSUES"
  • PND4ME
    Posts: 652

    Any more news for the firmware update for the 1470 I have one with 1.12 but it has "ISSUES"



    Again, I'm testing newer SW 2.06 but I can't tell you when Magellan will replease the SW. Most issues have been address and that's all I can say. Sorry
  • Thank You I did update with 1.15 and it went well
  • Marc
    Posts: 1,241
    Too late, but I would advise against 1.15. It has bricked many roadmates. I hope yours holds out.
  • PND4ME
    Posts: 652
    Marc said:

    Too late, but I would advise against 1.15. It has bricked many roadmates. I hope yours holds out.



    It really depends on the unit and if the battery is in good condition and if you updated the unit properly. I don't think everyone that updated their unit to V 1.15 has bricked their unit. So possibly something was not done correctly.
    We are up to 2.05 already for the 1470 for testing purposes so I think it should be fine if you have not disconnected the unit to soon from the computer while the unit is loading and or your battery is charged fully so it can load the software after you disconnected the USB.

    Good luck
  • bz101
    Posts: 10
    I installed 2.04 on my 1470 about a week ago. Gave it a shot.

    SO MUCH BETTER!

    Searching for streets beginning N, E, S, W in Manhattan was a nightmare before. Now it works great.

    I don't know since I don't have screenshots from before but I think they updated the 3-D perspective too.

    QWERTY keyboard is a nice add.

    I haven't seen any reboots (but I didn't before either so that's no different).

    System powers on and off much better now as well.

    I've been using it for about a week (going about 1,000 miles between Boston and NYC a few times with about a dozen unique destination points) and haven't run into one problem.

    But install at your own risk. 😃
  • canuck
    Posts: 40
    I updated to 1.15 before this notice came out. I did not have problems initially. Does the problem happen right away? If so then maybe I had lined up without knowing it.
  • Marc
    Posts: 1,241
    For a thorough discussion go here:
    http://tinyurl.com/1-15-disc

    I think the most telling post is from the guy who trashed four GPS by updating them, one at a time. Returning them to the store for a new one. I don't believe these are "isolated incidents" as Magellan claims. Only time will tell how long yours remains stable. Hopefully until the 2.0x version comes out.
  • Yep...I upgraded to 1.15 and both my 1440's were locked on the splash screen within a week. The refurbs had ver 2.04 on them which doesn't appear anywhere for a 1440, so not sure about it. Is this the same 2.04 that some are saying was released for the 1470?
  • the lack of a reset button is puzzling. It should work like the old jumper on a pc to wipe and reset the CMOS. Oh, well...Something to play with after warranty goes out.
  • elvisfan
    Posts: 145
    I upgraded to 1.15. The installation went fine. The next day it bricked. Magellan sent me a New unit. This has version 1.12. It has been stable but it recalculates slower then 1.10 that I had on the old unit. You win some and you lose some.
    Can someone please check version 2.04 for me? Route to 22nd street in Lombard Il. One of the problems I have right now is that. The valid address comes up 18w600-21w299 but you can not input the number. The only option is 0. When you press the 0 until you can enter other numbers, it says it is not a valid address. I am still hoping they fix that.
  • Good news Elvis fan 18w601 22nd st is there on my 1470 with 2.04 738 miles from where I am sitting My 1470 came with 1.12 I went to 1.15 then was scared to leave that on there and went to 2.04. Am waiting on the 2.06 that is in the works. Any other request ??? By the way an address like 18w601 22nd street is a mailmans nightmare too many numbers for customers to get wrong when they are filling out letters no wonder magellan is having a hard time with it.
    magellan 2200t has it correct
    magellan 5310 has it correct
    Garmin 255w has it correct
    and now 1470 has it correct
  • elvisfan
    Posts: 145
    thank you, I am still afraid after 1.15. I am going away and I do not want to be without the GPS.
  • I have installed the new update 2.04 this morning and it curred the bug that prevented me from using my 1475 for the last 2 months (rebooting continously) lets hope that this end all my problems.
  • elvisfan
    Posts: 145
    One other question. Can you click on current location then save it. Where it actually works? Previously, you save it then if you tried to route there, it would tell you there was no address.
  • elvisfan
    Posts: 145
    I'm afraid that if I upgrade to 2.04 and it crashes my unit, then Magellan will not replace it because it was not a supported upgrade. Call me paranoid.
  • If you click on current location then save it, it does work.. I dont want to come off like I know everything because I learn something about the GPS and how to update the firmware all the time. I think there are more then a few people that dont have a fully charged battery dont set the gps auto power to never turn off and other things that mess up their units. That said updating magellans is always a scary deal. I think your best bet would be to wait until a supported update comes out since yor unit was replaced already.. But me I like the gamble ??!!

    FORGET ABOVE 2.05 posted
  • elvisfan
    Posts: 145
    The web sight is now showing 2.05. So I updated. They now have 2 screens of one touch icons. But you can't assign any of the ones on the 2nd page. I assign one and it goes to page 1 and updates the icon there. There are only 6 icons on page 1 and no matter which icon I try to update it only changes the one on page 1. Interesting.
  • Worked for me I had page one filled and put one on page two just to try it????
  • elvisfan
    Posts: 145
    You have 2.04? Page 1 has 6 incons scattered all over the page. That is it. page 2 has more icons, but when I assign, the only one that changes is one of the icons on page 1.
  • bcwang
    Posts: 10
    I've got 2.05 and for me, trying to add icons only changes the first one on page 2. The only way I succesfully add icons easily is to add something in the address book and check the "add to onetouch" checkbox. I hope they take care of this soon as onetouch in 1.15 worked great.
↑ Top

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!