This site uses cookies to offer you a better browsing experience. Find out more about how to manage cookies, or dismiss this message and continue to use cookies.

Garmin 1350T Touch screen sensitivity issue

Hi, I recently purchased my first GPS, it's a Garmin Nuvi 1350T. After turning it on and learning how to use it I noticed that I would have to press on the same letter a couple times before it worked. It seems as though the touch screen isn't sensitive enough. Is there some way to correct this? Is this normal? Thanks guys.

Comments

  • Boyd 1954 Points
    I have a new 1350t, and actually feel that the screen is better than the 3 other nuvi's I've owned. There are two things which don't seem to respond on the first click on mine, but I'm pretty sure these are software issues and not the screen itself.

    One of them is scrolling through the custom vehicles. I have to tap a couple times often. Guessing this is due to the "eye candy" animation of things like the walking feet, which make the processor too busy to check for keypresses.

    The other is tapping the automotive/pedestrian icon at the top of the main menu page. For one thing, it's very small and also close to the edge (why does Garmin recess their screens?).

    There is a utility program to calibrate the Nuvi screen. Haven't done this on my 1350 and am not quite sure of what the "secret salute" is. It may involve holding down a corner of the screen during startup.

    I'm sure somebody else will post. If not, do a search for nuvi diagnostic menu.
  • Marc 201 Points
    If the calibrate screen startup sequence is the same as on the 7x5- here is what you do. With your Nuvi off, put a finger on the approximate middle of the screen and keep it there. Slide the power switch to the on position and immediately back to the lock position. At first it looks like a normal startup, but in 30 seconds to a minute you will see the calibration screen where it shows little crosses and says press here. I use an eraser tip to insure my presses are centered.
  • SergZak 240 Points
    Here are the steps to calibrate the screen (firmware version 2.70):

    1. Make sure the unit is turned off.
    2. Press and hold the top left corner of the touchscreen.
    3. Power the unit on and leave the finger on the screen.
    4. Continue to hold for 30-45 seconds and the press dot option will appear.

    Different in that you press & hold the top left corner of the screen rather than the center and simply power on the unit (no slide to "lock" position since the 1xxx units don't have a "lock" position)
  • Boyd 1954 Points
    Excellent - thanks for the info.
  • Thanks guys. I found that if I touch the screen with my finger and finger nail at the same time it's more accurate. I'll try calibrating it and see if that makes any difference. It was a difficult decision for me to decide which Garmin to get. Did I get a good GPS? how does it compare to the other models (255w, 285wt, 765T, etc). I just want to make sure that my money was well spent. I appreciate your help
  • Boyd 1954 Points
    To compare models, check the box next to them and click the compare button here:

    https://buy.garmin.com/shop/shop.do?cID=134

    This thread covers your question pretty well too: http://forums.gpsreview.net/discussion/16657/x/p1/
  • SLR2009

    How do you like your 1350?
  • I also had the same problem... Unit not responding, on the first touch, around the lower right hand 25% of the screen. I recal'ed the unit as stated and all seems to be operating correctly. Thanks
  • I had a similar problem on my 1390LMT, kept touching the black dot and chasing it around the screen, but it would never finish it’s calibration.
    These were some of the things I tried (some of which seemed not to help and some that did eventually)
    1, Tried a hard reset numerous times. Did this by turning on the power and holding the power button on. Did not help.
    2. Used the Webupdater program to do a forced re-install of the of the latest software version. Webupdater program is available from the Garmin website. Did not help
    3. Connected the Garmin to my computer and charged fully overnight. (may have helped).
    4. Did a hard reset again. (may have helped). But white screen with black dot still appears.
    5. Turned off the Garmin and turned back on (holding the screen in the top left hand corner to enter the calibration mode). White screen with black dot appeared as usual.
    6. This time I kept pressing the dot as it moved around the screen. However this time it completed the calibration rather than going on forever. Not quite sure why this sequence of events cured it, but maybe because if the battery is low – screen calibration doesn’t complete properly.
  • FCTC 0 Points
    Marc,
    Just letting you know that your sequence worked perfectly on a Nuvi Garmin Series 7, which had a totally unresponsive screen. I was ready to buy a new GPS.

    Here I was playing this silly game and came out a winner.

    Thanks and much appreciate to all you guys who contribute these obscure 'features.'

    FCTC

  • wkunert 86 Points
    I have found that using the eraser on a wooden pencil works best for me on my 1450. It also prevents scratching the screen.
Sign In or Register to comment.
↑ Top