Garmin 1490T - won't power up after 3 weeks
  • UCJT
    Posts: 3
    I received a 1490T for Xmas (purchased at Costco). After receiving it, I updated the firmware and downloaded the most current map. I additionally added some Custom Data (red light cameras, etc). It had worked fine but for a problem that others seemed to have - every other day or so, the unit would automatically power down and then restart itself - all taking place over the course of 45 seconds.

    Today - after about 6 hours of use - fully charged via AC power - it shut down and has not restarted since. It is getting power as the light on the charger indicated so. I also plugged it into my computer via USB to see if it would help, and that did nothing.

    Suggestions? Is this just a bad unit? Costco has a liberal return policy, but I am hesitant exchanging it for another one - only to experience the same issue in a month. Should I get another unit? If so - a Garmin or another company's unit?

    Thanks for your input - first free standing GPS unit I've owned.
  • Rick_E
    Posts: 29
    You might try a master reset, however it may clear your user data. Also see my post in this thread about how to properly disconnect your unit from the computer. http://forums.gpsreview.net/discussion/16955/x/p1/

    Someone else may have better information.

    To perform a Master Reset on the nuvi 200, 205, 465, 500, 600, 700, 705, 1200,1300,1400 or 1600 series device:

    Note: A master reset will erase all waypoints or favorites and will restore your unit to the default factory settings. If you would like to back up your favorites you can find instructions to do so here.


    Start with the unit OFF and unplugged from power
    Touch and hold the lower right corner of the screen with an index finger or the eraser end of a pencil
    Continue touching and holding the lower right hand corner of the screen then power the unit ON
    Release the power button when the device powers ON
    You will see a new message: Do you really want to erase all user data?
    Remove your finger from the touchscreen when this message displays
    Touch Yes
    The device will automatically reset. Follow the on screen prompts then place your device in an area with a clear view of the sky until it acquires satellites.
  • UCJT
    Posts: 3
    It worked - and I didn't have to do a reset! Thank you for your help!
  • Rick_E
    Posts: 29
    That's great! 😀
  • Kev_A
    Posts: 1
    Worked for me too, thanks.
    You have to hold the power button and touch screen for quite a while - mine took about 20 to 30 seconds to start. Also did not reset anything, just went back to normal working.

    Kev.
  • Wow Rick, Thank You Thank You

    it worked a treat. Gave over an hour trawling the internet for this problem to be resolved. I thought i'd be sending my Nuvi 1490T back for an expensive repair job as it's two years old and outa warranty.

    Had to sign up here to show my appreciation and again say Thank you for your very precise instructions in dealing with this problem

    Regards

    Pat 😀
  • jp928
    Posts: 8
    Havent used for a while. hangs at the Garmin logo forever. Have tried all the reset methods - from OFF, hold down a corner of the screen and start it - still hangs at logo. Holding left top corner and starting gives a ping from the computer when connected (msg is cant load drivers). Holding any of the other 3 corners and starting produces nothing at all, just the logo.
    My Webupdater says my last download is the latest, and that was put on the unit some time ago.
    Any suggestions please?

    thanks
    jp
↑ Top

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!