This site uses cookies to offer you a better browsing experience. Find out more about how to manage cookies, or dismiss this message and continue to use cookies.

Big problems with 2 of my Roadmate 6000T units

guintato 0 Points
edited November -1 in Magellan Vehicle Forum
I purchased two 6000T units for my wife and me at the beginning of October. All was well with these units until two weeks ago. One morning, after having used these units daily for over a month, I turned my unit on to discover that my address book was empty and all of my custom settings were gone. No problem, I figured -- I had a backup on an SD card. I tried to restore from the SD card, but the part way through the restore the unit responded "This may result in a system failure".

With that, I decided to backup my wife's unit and restore the info from there. Upon backing up her unit to her SD card, this unit also responded "This may result in a system failure" and with that all of her data was also gone!

Yes, I'm certain that this occurred while doing a *backup* -- not a restore. Just to be certain, I tried storing a new address in the unit and doing another backup. The same result -- system failure and all data gone.

Trying to restore from an older backup resulted in the same problem. With that, now both units had lost all of their custom settings and addresses.

I then discovered that if I entered a new address into either unit, and then did a full power-down/power-up reboot, the new address was gone. These units no longer store any data. What's worse is that the TMC subscription code gets wiped out with just putting the unit to sleep! What a pain it is to try to reenter that code every time you go to use the unit! However, map information remained intact.

With that, I went onto magellan's site and found the system upgrade to version 1.16. I performed that on both units and the process went through without a problem. However, it did not fix our problems. Custom data is lost whenever the unit is powered down.

I submitted a support request through their website two weeks ago -- no response. On Wed 12/13 I called support, and explained everything to the person on the phone. He then put me on hold for over five minutes, came back and told me that his supervisor would call me back shortly.

I didn't receive a call back that day, so the next day (Thu 12/14). I called again and told the same story to another support person. He told me that the issue had been escalated to 2nd level support and that it may take 48 hours to get a call back. I received no call back on Friday, but was unable to try calling them again.

Now, the unit is getting worse. The touchscreen is faulty, as if the calibration is off. It clicks when I touch it, but does not respond to any commands. I tried going into the "Touchscreen Test" in Diagnostics (which really appears to be a screen calibration utility) and all goes fine until the end of the test when it says that calibration settings have been measured and asks you to touch the screen to save. The unit does not respond to this.

I am really disappointed since overall I've been happy with the features and price of this unit. However, if this unit isn't going to work right, then it's not much of a bargain. I chose Magellan because of brand recognition and assumed that since they had been making GPS units for years that I'd get a reliable product and good customer service.

I'm going to let Magellan know that I've posted this here and I'll keep everyone updated as to Magellan's response.

- Tony

Comments

  • Tim 1480 Points
    Just out of curiosity, have you noticed anything weird with the battery in either device?
  • The batteries appear to be working okay. They do recharge and I think they've only fully run down in one of the units. I don't run into any problems when switching to battery power from DC power.

    I recall that on the occasion when the battery did run down, I kept getting the persistent message about the battery being low, which required a reboot since the message wouldn't go away even after the battery was charged. However, that was back when I first bought the units and didn't have any problems right after that.
  • Same Prob with my 6000t. :evil:
  • Have not seen any of these problems with my 6000T. However I sent a request about the Micrphone Sensativity back in Nov and have not heard anything from Magellan. The one time I did call I got a helpful but distorted Indian Rep which after 20 minutes I was able to piece together enough info to fix a POI problem. Magellan needs to step up to the plate and get things done or you can equate Magellan with other third rate GPS Units.....

    Bill.......
  • Same Prob with my 6000t. :evil:
    Frustrating, isn't it?

    After having logged the issue twice via the website along with two calls into support and not receiving any response, I decided to try calling one last time before escalating further.

    Unfortunately, I had to explain the problem all over again, and jump through all the hoops (i.e., "Yes, I've already tried the 1.21 upgrade and it didn't help.", etc.). After 20 minutes, I was finally given a return authorization so I could ship my two units back for repair.

    Once I get them back, I will be reluctant to try backing up my units to an SD card again. In my 12 years in working in IT, I've never heard of losing data when doing a backup... that is, until now! I hope the root cause of this issue is found and corrected.
  • On my third call into Magellan, I finally got a woman who once again made me tell her the whole story, but after hearing it and sensing my intense frustration, she finally gave me a return authorization number for my two units. I shipped them to Magellan and approximately two weeks later they shipped me two new units.

    Unfortunately, no explanation was given as to the problem. Also, since the new units had new serial numbers, I wasn't able to continue my TMC trial subscription. The units were shipped unboxed, so there was no TMC coupons with them. I didn't feel like dealing with support again, so I just purchased a one year subscription.

    I'm weary of trying to back up my data again for fear of running into the same problem again, so I guess I'll just keep my saved entries to a minimum so I won't be upset if they're ever lost.
Sign In or Register to comment.
↑ Top