This site uses cookies to offer you a better browsing experience. Find out more about how to manage cookies, or dismiss this message and continue to use cookies.

Firmware update v2.90 for GTMxx Type 3 (nuvi 37xx)

This apparently applies to the GTM 35 which ships with the nuvi 37xx series.
Direct link not yet available but get you can easily get it via WebUpdater or myDashboard.

Changes from version 2.80 to version 2.90:
Improve preference for premium traffic service.
Fixed lockup that could result in grey traffic icon being displayed on PND.

Changes from version 2.60 to version 2.80:
Fix issue with lifetime subscriptions expiring.

Comments

  • t923347 432 Points
    It may be worth noting that this is not a device firmware update so Webupdater reports you are using the latest firmware. You need to then request to see other updates that are available and the GTM 35 update will appear on that list.
  • SergZak 340 Points
    edited September 2010
    On my end, the GTM 35 is NOT updating. The file is in the correct location \.SystemRemoteSW\006B090100.GCD but the nuvi diagnostic page still says v2.80. No indication from the nuvi that any update is being performed. I've tried power-cycling the unit along with the GTM but no update.

    Anyone else get it to actually update?

    Checking out 006B090100.GCD (which is indeed being downloaded to the nuvi going by the date/time stamp) with a hex editor reveals "Software Version 2.80" at address 73F1 and NOT 2.90 so it seems that maybe Garmin somehow botched this update up. Downloading either via WebUpdater or myDashboard makes no difference.

    EDIT: After "updating", the next time WebUpdater is run, it lists the same v2.90 GTM 35 update is available.
  • Boyd 1985 Points
    You kind of lost me here... but could this be another issue with the infamous 3790 USB disk cache?
  • SergZak 340 Points
    edited September 2010
    I doubt it. I'm using XP here and XP does not have the cache issue...and to verify further, I tried simply unplugging without safe removal with the same result. The file size after transfer to the nuvi is 36.1 KB (36,972 bytes).

    BTW, the v2.80 I mentioned in the GCD file above refers to the version contained within the GCD update file. The version already on the GTM is 2.80. If the update file incorrectly states that it is 2.80 as well, no update will ever take place.
  • Yeah, this update isn't working for me either.
  • SergZak 340 Points
    I have a feeling this update file is the same v2.80 version that's already flashed on the GTM 35. Poking around in the .GCD file reveals at least one other instance of a very clear "2.80" on top of the other instance mentioned above.

    EDIT: I also tried my homebrewed "update checking" SD Card which lets me check for updates on all my units from that single SD card....the update was downloaded to the card directly into the proper folder (no nuvi involved) and is the same non-functional update file that was downloaded directly to the 3790.
  • Not working here as well.
  • same here and it's the day after.
  • I called Garmin. The rep's solution is to send a new cable. :shock:

    Also, they don't seem to believe information in public forums is evidence of a problem existing. So if those of you having problems could send support tickets and call them, I'd appreciate it.

    I fail to see how sending out replacement GTM cables is going to resolve having an old 2.80 file hosted on a webserver.
  • SergZak 340 Points
    edited September 2010
    That's just plain silly. Don't send your cable in as there is likely nothing wrong with it. Suggesting the cable is defective and nothing is wrong with the update (such as the wrong file on the server) seems to me like total nonsense. Frankly, I really don't understand this type of logic when it comes to Garmin's support.

    There are also reports of the same thing happening with 1xxxT units...there is an update for the GTM unit but the update never installs and WebUpdater shows the same update again and again...

    Does this mean that all of those units have a defective GTM cable unit as well? :roll:
  • I called again, and someone at Garmin reproduced the issue. He asked his software team, and they said this would be dealt with in a new update in the future.

    But supposedly having a new cable sent to me would fix the problem.

    I also tried to cancel my replacement RMA cable order, but the Garmin rep I just spoke to couldn't even find the order. So maybe it was never placed.
  • SergZak 340 Points
    Update:

    WebUpdater is no longer transferring the erroneous file over and reports a "Transfer error".

    myDashboard is still transferring a file over but I really can't tell for sure if it's the same file (don't have access to my GTM at this time). Going by the file size in bytes & scanning through it with the hex editor, it appears to be the same erroneous file.
  • SergZak 340 Points
    Update:

    I redownloaded again via WebUpdater (Friday Oct 1) and scanned (hex editor) the new file and it very well appears to be correct since where I previously saw various "2.80" instances, those now show as "2.90". I cannot 100% verify the update is correct since I don't have access to my GTM 35 at the moment to actually flash the update. According to another forum member elsewhere, the update is now correct so we'll leave it as being "fixed" on Garmin's end (wrong file on webserver).

    So, do NOT send your GTM cable back to Garmin for replacement...the wrong update file was posted as I suspected.
  • t923347 432 Points
    After the new download , that Sergzak notes, I have connected the traffic receiver in my car and the Nuvi is updated. The update no longer appears in Webupdater.

    Original problem appears to be solved.
  • The update does, as of this post, appear in Webupdater. And it now works. :D
  • Can anyone report that it actually improves the GTM 35, which in my parallel tests is/was less sensitive than the GTM 25? However we do suffer from pathetically weak FM traffic signals in the UK. "Improve preference for premium traffic service" is not a must-have for me, though I wish I knew what they mean by "Fixed lockup that could result in grey traffic icon being displayed" - maybe that's what I've been diagnosing as inferior sensitivity.
  • wbwjr 0 Points
    It definitely improved my reception after updating this morning. I live in the Wash., DC area and it would hardly work at all before the update.
Sign In or Register to comment.
↑ Top