This site uses cookies to offer you a better browsing experience. Find out more about how to manage cookies, or dismiss this message and continue to use cookies.

Droid X and Navigon issues - loading and website access

bevelsport 0 Points
edited November -1 in NAVIGON Forum
Last Friday I purchased the Navigon app for my Droid X for 29 euros. My CC company held payment because they were concerned about fraud. I cleared the payment and the transaction looked like it was complete. Unfortunately, the app never downloaded. I then cancelled the transaction. I re-purchased the app (at a new, higher price of 44 euros).

It downloaded. When I tried to execute the app, it says it can't find a network. I have no issues with any other apps on the phone.

I have tried to contact Navigon thru Google but have not gotten any response. I have not been able to go the the Navigon website. Both IE and Google Chrome say they can't connect. I have spoke with my IP and they can reach the Navigon site without issues.

Has anyone oth there experienced anything like this and found a solution?
George

Comments

  • I solved my own access problem. My wireless router (and older Linxus) was not Vista compatible. That is why I was unable to download. A new D-Link router cured it.
Sign In or Register to comment.
↑ Top