This site uses cookies to offer you a better browsing experience. Find out more about how to manage cookies, or dismiss this message and continue to use cookies.

Navigon On iPhone 4 With 4.2.1 Issue

pappasbike 91 Points
edited November -1 in Smartphone Navigation
I'm not certain if I had used the app since the new iOS software was released but today I noticed that while using it for navigation the screen would go dark for a second but then return to normal. This continued to occur through out my trip. After watching it do this for a while I realized it was happening every 50 seconds, I was actually able to time it several times and while it might not have been exact it was approximately every 50 seconds whether in navigation mode or just on the main screen with no destination set.

I also realized the screen didn't actually go black, it darkened but I could just make out the screen through it. This only lasts a second or less but is very regular. I closed the app, rebooted the phone but it still happens so I'm thinking it may have to do with the new phone software.

Comments

  • I don't have that issue on my 3GS with OS 4
  • It may be just on the iPhone 4s or maybe just my phone. But since the occurrence is so regular I'm going to assume it's software related. Whether it's Apple's software or Navigon's I don't know.
  • Yeah, I am not sure. I have the same OS as you but do not have any issues.

    I do have problems with Magellan, though! Losing GPS/freezing software!
  • I think I have an idea what's going on. I have my phone set to autolock after one minute of inactivity so naturally at about 50 seconds the screen dims before going out completely. Then I guess the Navigon app kicks in to wake it up again. Somehow whatever mechanism that's supposed to keep the screen on during navigation is not working correctly. It only dims for less than a second so it doesn't really have a big impact but it is annoying.

    I could delete the app then restore it from iTunes to see if fixes it but I'd rather wait to see if any other iphone 4 users are seeing this. If so I'll just wait for Navigon to correct this.
  • Well, I just checked reviews of the app on iTunes. Should have done that first. Others are having the same problem and not just iPhone 4. All the ones having the issue are using the 4.2.1 software. So hopefully Navigon will address this.
  • Well, I just checked reviews of the app on iTunes. Should have done that first. Others are having the same problem and not just iPhone 4. All the ones having the issue are using the 4.2.1 software. So hopefully Navigon will address this.
    I have that software and it works fine. Maybe you have some power saving feature on?
  • No, I contacted them by Twitter and they know about it. They said it's been fixed in the next update that's soon to be released.
  • I figured out why my 3GS is working, and I stand here with egg on my face!

    I thought I had updated the OS, but I was still on the old version. So it works with the old OS version but not the new OS version. So it looks like Navigon forgot to change something.

    My apologies for my ignorance!

    Followup: even with the proper software versions installed, I never saw this issue on my iPhone 3GS.
Sign In or Register to comment.
↑ Top