This site uses cookies to offer you a better browsing experience. Find out more about how to manage cookies, or dismiss this message and continue to use cookies.

Latest Version of Home for Macintosh Produces Error Message

charlie 39 191 Points
edited November -1 in TomTom Car Forum
I'm posting this here because I have an XL 330S, but I assume the problem may not be isolated to the XL series.

After upgrading to the latest version of TomTom Home (2.8.0.1019) on the Macintosh, which is labeled as critical, I began getting the following error when doing things like checking for device updates:
We're sorry, but HOME can't complete that task. Please try again later, or contact customer support. For problems with items that are stored on your device, we advise you to remove and re-install the item.
To make a long story short, the problem was with the map that is stored on the computer from downloading the latest map guarantee (2 1/3 years ago). In my case, this is the same map as is on the GPS, but it is not complaining about the map on the GPS. If this happens, there are several things that can be done:

1. Accept the message whenever it appears and go on with what you were doing since at least most functions of Home appear to work correctly in spite of it saying that it can't complete the task.

2. If you have a backup of the previous version of TomTom Home, replace the updated version in the Applications folder with the backup version. This will return behavior to what it was before the update, without the error messages.

3. Remove the map folder (e.g., USA___Canada) from your Documents->TomTom->HOME->Download->complete->map folder. You may want to save this someplace so that you can put it back when TomTom releases an update to Home that works correctly.

Comments

  • dhn 336 Points
    Thanks for the post. It is another example of sloppy coding in the Home version. Happens on both a pc and Mac. Doesn't matter the model you have.
  • charlie 39 191 Points
    This appears to have been fixed with the latest version of TomTom Home (2.8.1.1109).
  • Hi, This is the most helpful site I've found. I'm totally new to using a GPS so please bear with me.

    When I try to use the Home software it doesn't work, except to install updates. I can't navigate with my GPS, I can't enter a route, I can't use my keyboard, etc. The only thing I can do is read the owners manual.

    Is this normal? The reason I ask is because I looked at the TomTom website and though I do have some trouble finding my model, there is a page that shows GSP models that don't work with Home yet. But after browsing this website for my model it seems it should work fine?

    FWIW, I installed Home software as asked when I plugged in my GPS to my Mac first time, and choose to update the map right away, not knowing better. Any time it said there were updates that looked appropriate I installed them.

    Maybe this was not the thing to do yet?

    (Confused!)
    Thank you in advance.
  • Re-hi,
    Now when I plug in my 335 to my Mac the GPS doesn't even ask me if I want to connect to my computer. It goes straight to view of route planning. It used to ask me. The Home software is loaded but it says "no device".

    Preferences are checked for automatically start Home when I connect my devise and check for updates, but it doesn't do either.

    Should I uninstall the Home software, after I back-up the map that's on the GPS?

    I fear I'm going to be talking to technical support for many hours to come. ARGH! Why don't things just work the way they are supposed to?!?

    Like we all have time for this. Sorry for the rant. Sort of.

    :oops:
  • dhn 336 Points
    Reset the unit by holding the power button for about 10 seconds till you hear the drum roll sound. (I don't think that model has a dedicated reset hole on the bottom). Then connect to the Mac. Turn on the unit. Is it recognized now?
  • Hi, Yes resetting the GSP worked, as the Home software now recognizes the GPS but none of the features/icons in the Home software work right yet. For instance I am often able to click on "plan a route" but once I choose a destination, the software freezes up and my only option is to click "done" outside the devise screen, closing that part of the application.

    "Operate my Devise" is totally messed up, the screen view often turns upside down, or shows double portions with only a small part of the GPS screen. When I click on any of the buttons (for lack of a better word) inside the devise screen, for instance to search for a POI, nothing happens.

    I also tried to add a POI with the Home mapping software and also Google but neither worked. The first steps work, and it asks me what I want to do with the "destination" (I think that's the word it uses), I choose to save or show on map, (never to "Navigate to"), but when I go back to find them later in "Search POI's" I can't find them.

    The only Icons that work on the Home screen are the one that shows what's installed on my devise, and the manual.

    I think I've given up as my 14 day trial is just about over.

    Thanks for your help,
    IM
  • Hi,

    As you can see in my previous post things are not working well. Though I did manage to add a couple POI's with Google. But many other things about this GPS are buggy. The latest was that I planned a route but then I can not view it in text, as images, demo, etc. I could before.

    I was hoping I could exchange this for another model but what I would like, I can't afford, even if Amazon will let me return this unit. My options are to see if I can exchange this for a new 335 unit, try to fix it myself, or call technical support.

    What would you suggest? I don't want to spend many more hours to this GPS if it's going to be a waste of time and tech support for TomTom doesn't sound very impressive from reader comments on here and the like. So that option feels like a last resort. But I'll do so if you say so, 'cause you certainly know more than they do!

    Unfortunately I did not back up everything before I started to use it. (It is now). But one thing that did seem to work OK was installing the latest map and other updates. I had no errors, etc. whatsoever and it seemed to work like a charm. Of course I can't go back to the original map because I don't have it.

    Map version I have now is: 870.3406 The software tells me that is the latest is that correct?

    Home Software is 9.151

    Should I do reset to factory settings?
    Should I uninstall Home software and reinstall?
    Or should I simply try to exchange for another?
    Any suggestions at all?

    If I can fix this GPS , I would like to uninstall most of the voices, as I have 12 and that seems to cause problems too, or am I wrong? Which would you suggest I keep? I would like a voice that tells me the street names.


    Thank you for your patience with a brand new GPS user. (I'm sure some of the problems are operator error, but definitely not the Home software bug. And I assume the software is something I really need to be able to use.) But one should never assume!

    IM
  • dhn 336 Points
    You have the latest map for that unit. And the latest application.

    If uninstalling the application and reinstalling doesn't solve your issues and neither does resetting the device, I don't know what else to suggest.
  • Thank you, dhn.

    I will try to reinstall the application software and see if that doesn't solve it, as resetting didn't fix it.

    At least I'll know I did everything I could!

    IM
Sign In or Register to comment.
↑ Top