This site uses cookies to offer you a better browsing experience. Find out more about how to manage cookies, or dismiss this message and continue to use cookies.

magellan explorist 310

Lumix TS2 0 Points
edited November -1 in Magellan Handheld Forum
i'm new here but not to magellan. i had a 400 explorist for 3 years that i liked very much, it came with the Canadian topo map disc v.100e. the only problem i had with it was that the zoom in button was fussy and i sometimes would have to hold it or press it 5 to 10 times to get it to work, bit of an inconvience but not a major problem. i blew it up by hooking a car adapter to it that wasn't made for it. it was a generic one that worked for all my electronics but i guess not the gps.
i plan to buy a explorist 310 when it comes out at the end of the month because my old 400 never lost contact with the sats that i can think of even in deep cover, the truck or my basement apartment away from any windows. once it had lock it wouldn't let go!
my question is the topo maps i have, i can load them into widows 7 using the backdated windows program (going back to XP) but it won't come up. loaded it three times and nothing. i then downloaded the new mapsend lite 2.00 and took the sd card out of the 400 which i installed detailed maps for all of Canada. they installed in the lite 2.00 no problem. will i now be able to install them into the 310? (the 510, 610 and 710 should be the same for downloading) i know they might be a bit outdated but where i travel there has been no changes in 30 years.
hate to have to buy a new topo when the old one is fine.

BTW i was looking at the Garmin Dakota 20 but it's $100 more and seems to have some issues staying locked. it's also a touchscreen and my hands tend to get dirty fishing and hiking, you can see the problem. it's on the outside looking in at the moment.

Comments

  • going to answer this one myself. you can load your detailed maps from an SD card in your explorist 100, 200, 300, 400, 500, 500LE, 600 into mapsend lite 2.00. from there it goes nowhere, the maps are locked. my 400 is dead so i couldn't load through it into Vantage point (not sure if it would work anyway).
    i tried direct from the folders i created in windows, no go. just thought i would let everyone know (most people probably already did).
Sign In or Register to comment.
↑ Top