This site uses cookies to offer you a better browsing experience. Find out more about how to manage cookies, or dismiss this message and continue to use cookies.

MotoExtras Toolbox Loading but not showing any content?

skeogh 0 Points
edited November -1 in Motorola MotoNav
I purchased the 565t and my first impressions are great. One problem I am seeing when I installed the MotoExtras Toolbox. I am connected to the Update Server but I get the Motorola logo and "Loading" on the screen - no downloadable content is every displayed.

I have the Q1 maps and would like to update to the Q4 is possible and also update the firmware.

I am in Toronto and not sure whether that is a problem?

Does anyone have any ideas? Is the MotoExtras Update Server down? I have been trying for the 24 hours.

Thanks much.

Comments

  • Spyder63 331 Points
    Another Canadian user had problems just a day or two ago when attempting to purchase Euro maps. He solved it by going in to his registration profile and changing his "invoice address" (not sure if that was just his regular address) but changed it to a US address and then he could see maps and purchase. Bottom line is perhaps change your country of residence to the USA and see what happens to get your downloads to appear.

    Also, FWIW, there may have also been some Moto server problems a couple days ago for US users. Hard to say if all aspects were fixed, but some I noticed were.
  • moondog151 41 Points
    Once you follow Spyders recommendation and are able to log in sucessfully to the toolbox, you`ll have 3 firmware updates awaiting for you to install. Should you want to update the Q1 2009 maps, to the Q4 2009 maps, you`ll have to purchase those seperately FYI...........
    Be sure tho, to have a fully charged battery before attempting to download the firmware, as each update, requires a restart of your unit before you can proceed to the next one..........
    Also, I HIGHLY recommend, doing a complete backup of your system before attempting to install the very first update, for that "just in case" scenario.......
  • skeogh 0 Points
    That did the trick. I changed the Invoice Address to a valid US address and it worked like a charm. I am beginning the firmware update process now.

    Thanks for you help!

    BTW, spent time with Motorola help desk and they had no idea...
  • Spyder63 331 Points
    Good to know that worked! We have come to expect very little help from Motorola CS, so we all hang out here and collectively grope our way through! :lol: Something like the old saying, "God helps those who...." and I don't think that has anything to do with eating at the buffet at the Golden Corral! :wink: :lol:
Sign In or Register to comment.
↑ Top