WebUpdater won't recognize my Nuvi

I tried to update my software today but WebUpdater did not recognize my NUVI 1450LMT. What's wrong?

Comments

  • Possibly nothing. Webupdater seems a bit flaky and can work/not work depending on the setup. Which update (s) are you after as there are other ways that don't use webupdater?
  • Firmware I guess. Really not sure. Just want Nuvi to be up-to-date for a road trip to Florida on Saturday. Want to be sure Alabama has gas after the tornadoes.
  • Not sure you're nuvi will help you with the gas :?

    Be aware that there are some issues with the latest firmware so unless your 1450 is playing up it's probably not worth updating. You have lifetime maps so if you want to update those (and note that if you do your firmware will be updated too) you need to go to your myGarmin, log in and update your maps from there as Webupdater doesn't update your maps.
  • Possibly nothing. Webupdater seems a bit flaky and can work/not work depending on the setup. Which update (s) are you after as there are other ways that don't use webupdater?
    I don't think it's webupdater that "flaky" as much as it's the 1xxx series of Nuvi. I have a 3xx, 7xx, 1xxx. and 39xx and the only one that webupdater refuses to recognize is the 1xxx.

    I found the solution was to use MyDashboard since although you can't tell what's being updated, it does find the Nuvi where Webupdater doesn't.
  • Ah ... you could be right :)
  • WebUpdater never recognised my 3790 since it was new, and I've tried all the tricks that Garmin and others have suggested. It was slightly unexpected when, updating my Europe maps today, it updated the firmware first. Usually I have to resort to MyDashboard, but that doesn't do the voices ... British English Daniel is stuck on 2.0, but British English Emily is 2.3 and it keeps switching to her - and I find her much more difficult to hear.

    JunctionView arrived safe and well in today's update, too. Still waiting to see if the revised 4.10 firmware now works properly ... I look forward to having the longer-lasting JunctionView as in my new 2450.
  • That's normal, if you update maps Garmin 'insists' you update your FW first, which is fine if there are no bugs in the latest issue :?
  • For a little cheap insurance... find the file named gupdate.gcd on the Nuvi (should be in the hidden .system folder on new models) and copy it to your computer before doing any updates. This is the installer for the firmware that is currently on your device.

    After updating firmware, if you decide you want to go back to the previous version, just copy the old gupdate.gcd file back to the Nuvi. When the unit starts back up, your old firmware will be reinstalled.
  • :evil: Nuvi 260W (v3.0; City Navigator North America NT 2008) ) device isn't detected on either a Mac (10/4/11) or PC (Windows XP) even after downloading system-specific webUpdaters, Garmin Communicator Plugins, and USBdrivers, or via MyGarmin account.

    Tried several USB cables (non-Garmin) and all work on other devices and apparently with Nuvi as evidenced by the Nuvi charging and switching to battery when disconnected.

    Nuvi 260W does have an SD card slot, but seems to offer no advantage opver the NPIC5EE24 internal memory card.

    MyGarmin MyDashboard says map updates but no conectee, no downloadee. Anybody have any solutions?

    Maybe instead of saying this is not a problem or blaming our computers, why doesn't Garmin just make a software workaround. They can be in denial but if so, rest assured, I and no one in my family will ever purchase another Garmin product again.

    help.
  • Think you may have answered your own problem ... third party cables sometimes don't work so why not try a proper Garmin cable :roll: :wink:

    However, first ensure you don't connect via a USB hub, but direct to a USB port on the PC, as hubs have been known to cause problems. Second, try all the USB ports. If you still cannot see your nuvi as a drive on your PC then using a Garmin cable is the next step.
  • Look in your folder garmin on nuvi,there is garmindevices.xml.
    If you have error on the end of garmindevices.xml,webupdater wont recognize nuvi.
    For nuvi 13xx and 14xx is here the latest FW:

    http://www.garmin.com/software/nuvi13xxand14xxseries_GCDFile__530.gcd

    After download,rename to gupdate.gcd and put in hiden folder .System.
    After next startup of your nuvi,nuvi is upgrade and after that webupdater recognize nuvi.

    p.s. if you have win 7 install and run webupdater as Administrator
  • Hello, just wanted to thank you for your advice on how to get my Nuvi 1450LMT to update maps. It seems to be working at this time.
Sign In or Register to comment.
↑ Top