This site uses cookies to offer you a better browsing experience. Find out more about how to manage cookies, or dismiss this message and continue to use cookies.

Custom Gas Station Signs for POI

blueTOOTH 0 Points
edited November -1 in Motorola MotoNav
I made some custom gas station signs for the Motonav. Just add to your data.zip and enjoy. Will show most major stations...more to come as they have to be coded for individual POI categories...it takes time :D

https://docs.google.com/leaf?id=0B5zpi5jfqWIyMTdiMzM1NGItOTYzYy00OWMwLThlNTUtOGUzYjJiMDEzMmNi&hl=en_US
«1

Comments

  • blueTOOTH 0 Points
    Ok...anyone know why googledocs is not working? or another source to upload from? I understand why the site owner does not want people to link files...but, it really is a pain for those who play by the rules.
  • I was able to download it with no problems.

    Where exactly does it go in the data.zip file?
  • blueTOOTH 0 Points
    Well...I can't access it...but if it's working for others:lol:

    Here's another link:
    https://docs.google.com/leaf?id=0B5zpi5jfqWIyNzQwYjcwMTYtNDVkOS00OWRmLWE4NDQtZmI1MTU5MmZmOGMx&sort=name&layout=list&num=50

    The items in the DL are set up in the correct folders as they appear in the data.zip. You can add them manually or just right click on the ui_motorola_pnd folder and "add to archive", browse for your data.zip, and add. see the readme.txt
  • Spyder63 231 Points
    I got it from the 2nd link. Did not try the first one. Branding works a-OK. I added it to TLs v8.1a data file and there is some screen space conflict in the slide-in POI listing window. The brand graphic needs to be moved down so it does not overlap the text. Somewhat minor in the scheme of it all. Brand logos are fine on main navigation screens.
  • blueTOOTH 0 Points
    New poi adds 300+ gas station signs
    30 fast food signs....yes, I added Hooters!

    Readme included

    link:
    https://docs.google.com/leaf?id=0B5zpi5jfqWIyZGQyNmE1MjgtMDNhNS00YWRjLWE1MWEtN2VkODBhOGMyMGEz&sort=name&layout=list&num=50

    Note: If you have gas stations and food poi active you may have it display as distant .bmp if the gas station has fast food inside. Example: a BP station with a McDonalds inside...the icons can't display because they are on top of each other.
  • Spyder63 231 Points
    I've updated and still only see gas station branded POIs. Both food and fuel are set to display. Anyone else successful at seeing fast food?

    @Bluetooth - the Texaco icon seems to have a base line at the bottom of the upright pole.
  • blueTOOTH 0 Points
    @ Spyder
    Yes, you're right the sign is one pixel off...I'll adjust and post an update.

    I checked the intersection down the road and Wendy's, Arby's, Mc Donalds, KFC, Cracker Barrel, Taco Bell all show up. Please post if others cannot see.
  • I got it from the 2nd link. Did not try the first one. Branding works a-OK. I added it to TLs v8.1a data file and there is some screen space conflict in the slide-in POI listing window. The brand graphic needs to be moved down so it does not overlap the text. Somewhat minor in the scheme of it all. Brand logos are fine on main navigation screens.
    Hey Spyder -

    I tried to add the pois but was unsuccessful. It ended up changing the entire skin. When I just pulled out the branding files and added them to my zip, nothing changed. How did you do it with 8.1a and get it to work?
  • New poi adds 300+ gas station signs
    30 fast food signs....yes, I added Hooters!

    Readme included

    link:
    https://docs.google.com/leaf?id=0B5zpi5jfqWIyZGQyNmE1MjgtMDNhNS00YWRjLWE1MWEtN2VkODBhOGMyMGEz&sort=name&layout=list&num=50

    Note: If you have gas stations and food poi active you may have it display as distant .bmp if the gas station has fast food inside. Example: a BP station with a McDonalds inside...the icons can't display because they are on top of each other.
    I love the idea of this, BT. It's one of the things I cherished about my Navigon! As you can see from my earlier post, I'm struggling with it a bit with getting it to work without reverting my skin to an earlier mod. Hope Spyder can shed some light on what he did to make it go with my 8.1a! Thanks for all the work! Heck, by the time everyone gets done tweaking this thing, it will be the uber Nav!
  • Spyder63 231 Points

    Hey Spyder -

    I tried to add the pois but was unsuccessful. It ended up changing the entire skin. When I just pulled out the branding files and added them to my zip, nothing changed. How did you do it with 8.1a and get it to work?
    I just followed BTs instructions - listed below. I added the folder ui_motorola_pnd (archived it) to a "virgin" version of v8.1a. Renamed it data.zip and copied it over to the TN765. Also need to do a soft Reset either with the button or 8-10 second hold on power button) I did try archiving directly to the data.zip on the PNA and it did not work.

    I will try it all over again as I still do not have the fast food icons working.



    INSTALL INSTRUCTIONS (with some additional notes by Spyder if you are using ThunderLizard's latest skin TL Sky Data v8.1a)

    The overall process will Add the ui_motorola_pnd folder to your data.zip

    If you are using winzip...
    simply right click on this folder (ui_motorola_pnd).
    select "Add to archive"
    Browse (to the skin on your HD - mine is named TL Sky Data v8.1a)
    select your data.zip (TL Sky Data v8.1a)
    and add it.

    Rename your TL Sky Data v8.1a to Data.zip

    Put it back on your PNA and make sure to have Gas Stations(poi)
    and or food on/displayed on map.

    Contains 300+ gas station signs
    and 30 fast food signs
  • Spyder63 231 Points
    @BT - I just examined all the files in my Data.zip from the brand update and they all appear to be in the proper folders and syntax is correct. I'm stumped. No fast food for me. I do still have gas. :wink:
  • blueTOOTH 0 Points
    TL 8.1a with updated (fixed the texaco) poi added ...(I tested and fast food working)

    https://docs.google.com/leaf?id=0B5zpi5jfqWIyOWRiOTU4MzAtMTIzMi00NWFmLTk4NTktYTk1MmE2ODU3ZWEy&sort=name&layout=list&num=50

    Hope it works...I'm leaving on vacation :lol: :lol: :lol:
  • blueTOOTH 0 Points
    Here are the revised files so that you can add to your own skin:

    Poi_6_11_adds.rar

    https://docs.google.com/leaf?id=0B5zpi5jfqWIyNzdkNmZiZDQtY2NjNy00YTg0LTg5MDYtZGQwY2FiZDZiNDAy&sort=name&layout=list&num=50
  • Spyder63 231 Points


    Hope it works...I'm leaving on vacation :lol: :lol: :lol:
    We'll give it a try. Hope you have a good vacation wherever your travels take you. :D
  • Spyder63 231 Points
    TL 8.1a with updated (fixed the texaco) poi added ...(I tested and fast food working)
    I have downloaded and installed this version as posted by BT and I still do not see any fast food icons. :cry: :cry:

    Possibly I am missing a critical file??? Anyone having success with this?
  • blueTOOTH 0 Points
    I know that the poi are working.

    Let me give a little more insight.
    The poi require a display area around the space where the restaurant is located. If muliple restaurants (or any poi) are located too close together. The icons will not display, or only display when you are really close to them. What you will get is a cluster of the distant.bmp to signify that too many active poi are too close together to display.
    Test:
    Find a location that you know a stand alone restaurant (ex. Mc Donalds) is located. (remember...I only have 30 in the database...the rest will show up with the standard generic icon). Only have food poi on. Take some sim drives and see if you can spot some.

    I tested the tl_8.1a.zip that I put up and it displays the fast food icons. Let me know how it goes.
  • RAMRODSR 41 Points
    SPYDER WROTE:
    I have downloaded and installed this version as posted by BT and I still do not see any fast food icons.

    Possibly I am missing a critical file??? Anyone having success with this?
    Spyder, and anyone not able to get the Fast Food icons to work.
    I believe the problem you are having is related to the Brand.icons not copying and replacing the old one. Check the date on the file.

    Try opening ui_motorola_pnd/icons_na/vantage/poi in the copy of the Data.zip you are using. Delete the Brand.icons file then replace it with the one you got from blueTOOTH's download. Replace the Data.zip to your motonav folder disconnect and reboot you should now have the Fast Food icons. You will still see alot of knives and forks also as there are only 30 of the icons at this time. They will show up in your nearby pois in the dashboard also as the gas icons did.

    Good Luck , Let me know if this works for you.

    Ramrod 8) :)
  • Spyder63 231 Points
    Thanks, but I checked and the file Brands.icons in my current Data.zip is exactly the same date, time, and size as the one sent by BT. (My Modified date is Friday, ‎June ‎10, ‎2011, ‏‎10:02:45 AM - 20.0 KB (20,548 bytes)) I did copy over his modified version of TLs v8.1a DATA file, which is the one I examined. I will recopy the file, but just don't have time at the moment. Later this evening.

    In looking at the Brands.icons file I do not see any references to any Fast Foods files. Should I ??

    I do see all the new fast food locations in a different file called Fast_Foods.icons in a different location: ui_motorola_pnd/icons/poi/Fast_Foods.icons. (Also see file called Petrol_station.icons in there)

    Gas stations still work A-OK.
  • RAMRODSR 41 Points
    @ Spyder,

    Got home late, mine did not work until I deleted the brand.icons and installed the new file. For some reason it did not work doing the copy and replace or merge the files. I still have a few icons that don't work for example (Starbucks, Sonic, Taco Bell, Wendys) However Applebees, Arbys, KFC, McDonalds, Dairy Queen, IHOP, Waffle House, Olive Garden and some others do. Just another one of those mind bogglers for now, I'm sure we will probably be able to get it worked out though.

    No references to the fast food is correct in the brand.icons
    and the other seems it is as it should be also. I had studied the files also to see why the food icons were not working in the beginning. I had also tried the TL8.1a version blueTOOTH released and it did not work for me.

    Ramrod :?
  • RAMRODSR 41 Points
    I did get Wendys on a simulated trip. It just didnt pick up the one I passed by in town.
    image

    Ramrod
  • Spyder63 231 Points
    Another one of the Great Mysteries of the Universe.

    Here is the process I did:

    1. Using WinRar I opened the DATA.zip file on my PND which revealed all included files.

    2. I deleted the file Brands.icons.

    3. I re-downloaded BTs file poi_6_11_adds.rar

    4. Using WinRar I opened that zipped file and from within WinRar I copied Brands.icon to the DATA.zip file on my PND.

    5. re-archiving was done automatically by WinRar.

    Still no fast food icons. :cry: :cry:

    Perhaps I am not understanding the process you (RR) used??
  • RAMRODSR 41 Points
    I use 7zip file manager. After I unziped the moto_poi_adds.rar/poi_adds/ui_motorola_pnd I tried as You did and I had no Fast Food pois working. No Sucess.

    This seems like a long process but it worked for me. I believe you will only need to use this process for the Brand.icons file.

    So I moved the ui_motorola_pnd file to my desktop. I then opened the ui_motorola_pnd file/common and copied all of the files ( joking_A /Joking_A.spr /joking_B /Joking_B.spr/ joking_C /Joking_C.spr/ joking_D /Joking_D.spr /joking_E /Joking_E.spr /joking_F1 /Joking_F1.spr and pasted them to the same location to my Data.zip copy (DATA_RR6.9) I am using on my desktop. NOT ON MY PND

    I did the same with the files icons/poi/ and copied Fast_Food.icons /Petrol_station.icons files and pasted them to my data.zip

    THIS IS THE FIX:
    I opened the files icons_na/vantage/poi/ and copied Brand.icons file. I then opened the same files in my DATA.zip and deleted the Brand.icons file from the zip and then pasted the new Brand.icons file in its place.

    I then copied the Data.zip to my Motonav folder on Gps and everything worked.

    I have also tried TL's 8.1a.zip and it now works. Nothing extra to do, I just loaded the one that blueTOOTH posted and it now works, since I removed and replaced the Brand.icons in my data.zip ?
    :shock: Weird Happenings, it did not work before.

    Great Mysteries of the Universe, continuing episodes to follow I am sure.




    Ramrod :D
  • Spyder63 231 Points
    Thanks. I got too busy with the rest of my life today so will give it a try on Wed.

    I will really be PO'd if Camel gets this working before I do! :wink: :lol:
  • blueTOOTH 0 Points
    @spyder

    (I'm back for 2 days before I leave again)

    (back up your save folder) Try deleting your save folder and installing the tl data.zip. It may be something in the saved settings that is keeping you from seeing the Food poi.

    @ramrod
    You said it missed a wendy's on your sim trip. This can be for 2 reasons. Sometimes the poi are categorized in multiple ways. Example: There are wendy's that are listed as restaurants_american and will appear in this category. But, the wendy's down the street can also appear listed as restaurants_fast_food. There are multiple categories they can appear in and the fast_food.icons file has to contain coding for all the categories that might be listed (so that every one will display). I may have missed a couple. But, most will display. This is true for gas stations also, as some are listed as convienence_stores. Poi files / and how they are coded is sometimes messy.

    The other reason is that poi files often contain errors. Poi will appear on the wrong side of the street, or blocks from their correct location. Navteq poi are the best for US, but do contain errors.
  • RAMRODSR 41 Points
    @ blueTooth,

    All is ok with me. It missed a Wendy's that I was driving by. On the simulated trip it found a Wendy's as in my photo post. I have gone into the fast food icons and added restaurant.other, Restaurant.american, ect. to some of the items as I thought they might be listed in a different category. Anyway, I have mine working.

    I hope you had a good time on your trip :)

    Ramrod
  • Spyder63 231 Points
    Well, guys, I tried both suggested methods - (BTs and RRs) and I still do not see any fast food icons. :evil: Maybe this is a sign I need to watch what and where I eat from now on??? :wink:

    Certainly would like to hear from others that may have tried to add the Fast Food icon files and successes or failures.

    As I have often said, "just because I only think I am paranoid, doesn't mean they really aren't out to get me"!

    I am starting to wonder if this is a result of my TN765 being an early production model?? Unfortunately I am just not ready to activate my newer unit to experiment.
  • blueTOOTH 0 Points
    @spyder
    I don't think it has anything to do with production model. The updates are uniform and we are using the same data.zip's. 2 options I have are: Delete the vantage/poi brand.icons file (will remove all moto branded icons) and try again. Or, check the save folder for poi_visiblities.txt file. This shows how your poi are listed and what is active. This file changes (saves) on each exit. Check and make sure you see food locations are active.
  • Spyder63 231 Points
    Here are a few Fast Food entries I see in my poi_visiblities.txt file. There are more than 30 fast food restaurants in this particular group. (Some keyboard characters are not being recognized by this forum -> )

    RestaurantFast_FoodMcdonald's||1333|2|1333|1333
    RestaurantFast_FoodKfc||1333|2|1333|1333
    RestaurantFast_FoodBurger King||1333|2|1333|1333
    RestaurantFast_FoodDairy Queen||1333|2|1333|1333
    RestaurantFast_FoodA&w||1333|2|1333|1333
    RestaurantFast_FoodMr Sub||1333|2|1333|1333
    RestaurantFast_FoodWendy's||1333|2|1333|1333

    In another large group further down the list some I see are

    RestaurantFast_FoodHardee's||1333|2|1333|1333
    RestaurantFast_FoodSonic||1333|2|1333|1333
    RestaurantFast_FoodMcalister's Deli||1333|2|1333|1333
    RestaurantFast_FoodWhataburger||1333|2|1333|1333
    RestaurantFast_FoodFirehouse Subs||1333|2|1333|1333
    RestaurantFast_FoodCaptain D's||1333|2|1333|1333
    RestaurantFast_FoodGreat American Cookie||1333|2|1333|1333
    RestaurantFast_FoodCharley's||1333|2|1333|1333
    RestaurantFast_FoodBack Yard Burgers||1333|2|1333|1333

    On the other hand - and what do you make of this? - I deleted the vantage/poi brand.icons file from the DATA.zip on the PND. I did not replace it with a new one. Rebooted (reset) the PND and I still see gas station icons, and as expected still no fast food. With the poi brands.icons file gone why do I still see gas station icons? I double checked the DATA.zip and vantage/poi brand.icons file is not there.
    :?: :?: :?:

    There must be a better way to have fun...... :roll: Gotta go zzzzzzzzzzzzzzz.
  • blueTOOTH 0 Points
    Well, that explains it. :idea:

    First: The vantage/poi brand.icons file controls the moto custom poi. Not mine which are located icons/poi. So deleting it just removes the custom poi markers that came with the moto. (vantage for tn765t)

    Second: The items you listed from the poi_visibilities.txt are different poi categories than what I have for the Q409 Navteq maps. This may be due to your earlier purchase/production. I was under the impression, we were all using the same maps/updates from motoextras. Very interesting.

    If I look at my poi_visibilities.txt example I only find one listing for "Hardee's"
    RestaurantOtherHardee's||1333|2|1333|1333

    Because the food icons are coded to match this poi category...they don't appear on your pna. Can you turn on all your poi and post your poi_visibilities.txt? I can add the coding.
  • Spyder63 231 Points
    Alright then....I had this feeling that early model had something to do with it and that was based on an earlier problem we had. I do see various categories all over that file. I am using Navteq Q4 2009 maps. Also have all other available Moto updates done Only other thing I can think of is at some point I did put the Brands.zip file on the PND from Primo to see what would happen. Nothing did unless it affected the visibilities file.

    I will just email my poi.visibilities to you and not post the whole file here if that is OK?
  • blueTOOTH 0 Points
    @Spyder
    I'm not sure if it is a production issue (or if you playing with SW did something.) But, I tend toward the production issue, because if you used the TL data.zip that I posted and deleted your save folder....the system should have the same poi categories as mine.

    Just e-mail it and I'll check the categories.
  • daddyro 0 Points
    1st Post.

    I used tl8.1a and archived BT POI to the DATA.zip and all works flawless. Fast food and petro are showing up great.
  • Ok. I think I've got it. Will check it out later. Thanks, SR, et al, for the step-by-steps. I must be a little slow on the uptake, but I could not get it working to save my life! Gotta lot of heavy stuff happening right now and I'm not on top of my game! :shock:
  • I use RR 6.9 skin with some minor changes, but also see gas stations only even hard reset my unit.

    image
  • Well, I think I've answered my own question - I see no gas stations except Texaco (which was already in there), and no fast food...but I have not done the hard reset yet. Will try that and see what I get. :shock:
  • blueTOOTH 0 Points
    For those that don't see Fast food signs. The problems are with how your POI are coded/catagories. There appears to be 2 different Navteq poi sets on the Motonav's. (Take a look at the previous posts).

    Check your poi_visibilities.txt in the save folder.
    Use find to locate Hardee's

    On my moto it will be:
    RestaurantOtherHardee's||1333|2|1333|1333
    On Spyder's moto it will be:
    RestaurantFast_FoodHardee's||1333|2|1333|1333

    The coding for these are located in the poi/brand.icons file. The icons are currently coded based upon the poi_visibilities.txt from my moto....If your poi_visibilities.txt looks like Spyder's, the icons will not appear.

    @Thunder-Try the data.zip I modified (back up save folder and delete it) I think you are doing it wrong. You should not see any gas stations from the origional vantage icon set.
  • I feel like a dumba$$! :( I can't seem to get this to work to save my life. Followed the steps, did the hard reset, you name it...nothing!

    *DOH!* I just looked back and saw that BT already did what i was asking to do: post my latest TL 8.1a with the POI's added! Thanks BT! I'll load it pronto!
  • blueTOOTH 0 Points
    New data.zip (TL8.1a) with poi (fast food with coding for older moto's)

    If you can't see fast food icons with other data.zip...try this one. This is untested....and I won't be able to edit this post...so let me know if this works for those that didn't see them before.

    When testing....(make sure to activate restaraunts/food) take sim trips to locations where you know that mcdonalds, wendys, kfc, arbys.....are located. Note: This only contains 30 icons, so the majority of restaraunts will still be the origional generic one. (coding is based upon Spyders moto) so I hope everyone will now see the icons. Good luck! :lol:

    https://docs.google.com/leaf?id=0B5zpi5jfqWIyOTdiNGYxYTEtZGIyOS00YTQ5LTg0OWYtZDdkYmUxY2ExNzAz&sort=name&layout=list&num=50
  • Spyder63 231 Points
    Guess you didn't get my email. The one you sent me (TL Data 8.1a_poi.zip) unfortunately did not change anything for my Moto. It will be nice to see if it works for TL or anyone having the same problem as I am. I will try again.

    A BIG THANKS for all your efforts.
  • Spyder63 231 Points
    I am very happy to report that blueTOOTH sent me a new(er) version of TL Data 8.1a with included gas station and fast food branded icons and it works for me!!! :D

    I just had to copy the file to my TN765t, renamed it Data.zip and disconnected from my PC. I did not even have to do a reset of any type. When the PND restarted they were there in all their corporate glory!

    Many, many thanks to blueTOOTH for his dilligence, persistence, and expertise in making this happen - for all Motonav users.

    :D :D :D
  • Wow! You just never know what little electronic idiosyncrasies you're going to run into with production models! I saw one branded gas station with the old BT TL 8.1a Zip. Not exactly what I was expecting, but hey, better than nothing!

    But I just downloaded the modified version BT did for Spyder and *BAM!* they're all over the place! Before, they didn't even show up in the search box on the right...now they do! (wahoo!!).

    So, add my THANKS!!!! to the list, BT. Great job! This thing is getting better everyday! Now all we need is an *ahem* map update! :shock:
  • blueTOOTH 0 Points
    New TL8.1a data.zip (should work for everyone)

    https://docs.google.com/leaf?id=0B5zpi5jfqWIyZjg2ODI1MGYtOTJlOS00MDBhLWI2YjgtYjE4YmJlNTE1ZGJi&sort=name&layout=list&num=50

    New poi adds for your own data.zip
    https://docs.google.com/leaf?id=0B5zpi5jfqWIyMjA1N2RlMTQtMzhmNi00OTFhLThjMDEtMmUzZmVkYjkzNDM5&sort=name&layout=list&num=50


    I've deleted previous uploads to avoid confusion....sorry can't edit.
    I hope this works for everyone :D :!:
  • Spyder63 231 Points
    Maybe we should call this version TL8.1b data.zip for "branded" version??
  • blueTOOTH 0 Points
    or, B could be for "even better" "because" it works!
  • Spyder63 231 Points
    Sounds "Better" to me!!!! Was it because some eating establishments are classified into 3 different categories and different production versions got different categories? I was looking at poi1 and poi2 fast_food side by side.
  • blueTOOTH 0 Points
    @spyder:

    The moto's differ in category and how poi are listed.

    Examples:
    (My Moto)
    [eating_and_drinking.Restaurant.Other.Hardee_s]

    (Your Moto)
    [Restaurant.Fast_Food.Hardee_s]

    Not only is it in the category "Fast_Food", but it requires removing the "eating_and_drinking" category which is required on my moto.
  • I love the branded icons! Except I've got one "bone ta pick"...there's no icon for the dad-gum Bojangles! 'Round these parts, Bojangles Chicken is a regular fixture!! Dagummit!! :lol:
    (but SUUUUURE...you had that yankee-chicken, KFC, didncha?? I see how it is! Dissin' a poor "southern boy" like myself thata way...mean ol' yankee...)


    Ok, I just saw where you DID include the Waffle House...(ah'm feelin' a little bit better now, y'all...)
  • Spyder63 231 Points
    Ah, TL, who peed in your grits this mornin'? :lol: :lol:

    Us Yanks didn't get our Starbucks and we aren't moaning. :roll: :lol: ..... and we won that war, remember? :roll: We should get first dibs!

    I saw a Waffle House once....too many pickups with gun racks and drippin' a lot of oil on the parking lot so I passed it by.
    :lol: :lol:
  • blueTOOTH 0 Points
    It's in the next update
    image

    along with all the other "chew spitten" "dixie loven" favorites including the king of heart surgery "Stuckey's"
  • Spyder63 231 Points
    BT, you are going to open up the flood gates.....

    Anybody ever hear of Skyline Chili??? Not real "fast food", but my personal favorite! :roll: :D My Garmin proximity alerts when I am within 5 miles of one, which is not very often as they are mainly in OH, IN, KY, and FL.
Sign In or Register to comment.
↑ Top