This site uses cookies to offer you a better browsing experience. Find out more about how to manage cookies, or dismiss this message and continue to use cookies.

Steps to unbrick your Magellan Maestro 3100.

joester 0 Points
edited July 2014 in Magellan Vehicle Forum
Steps to unbrick your Magellan Maestro 3100.
This instruction assumes you have a copy of the 2.18 update file from Magellan, a copy of WinZip, a FULLY CHARGED or AC powered Magellan Maestro 3100, and an SD card. I used a 32MB card. I read a lot of material on the internet and I figured I had nothing to lose but a bricked GPS unit. I would like to give credit where credit is due, and the best information I found was the instructions odoug posted regarding which files go where in the GPS unit.

I encourage you to read this entire instruction prior to attempting to update or restore your Magellan Maestro 3100. If you do not understand something or if something isn't quite explained, please post your questions. The information contained in this instruction combined with the downloaded and unzipped 2.18 EXE file from Magellan containes all the data you need. I spent about 5 hours on this, but most of that time was spent making multiple attempts at restoring my GPS, sometimes making me restart the entire process. I think the average person can accomplish this in about 1.5 hours.

**************************************

1. Open WinZip, then open the 2.18.exe update file downloaded from the Magellan website as linked above. This is a 900MB file, so it can take a while.
2. Extract the files to a directory you can easily find. I made a "Maestro" folder in "My Documents". This will give you a whole bunch of files in sub folders named Copy_Group XX that you will use later, but assuming your 3100 is as bricked as mine was, you have work to do before you get to that point. If you can plug the USB cord in and your computer recognizes the GPS, then skip to step 9.

***NOTE***
If you have backup files from a failed update attempt, create another folder in the Maestro folder labeled BACKUP and copy the entire contents of the SD card into the BACKUP folder. You will need them later.

3. In the Copy_Group_9 folder there are two files. These files are the operating system for the GPS. Copy them to a BLANK SD card. In the Copy_Group _10 folder is the boot instructions for the GPS. Copy them to the same SD card. In the Copy_Group_11 folder is the USB instruction for the GPS. Copy it to the SD card.
4. Put the SD card in the GPS and hold the reset button in until the venus0 menu appears (5 or so seconds). To navigate within this menu, press the reset button once to advance to the next selection in the menu. To activate a specific command, hold the power button in for about 1 second, then release.
5. Using the reset button, navigate to the "Update WinCe" line. I might have the spelling a bit off there, but you should be able to find it. As I recall, it was the first line of the main menu.
6. Hold the power button in for a second, then release. You should see a sub menu that has several options. One is "Update WinCE using SD/MMC" or something along those lines. Again, you should be able to find it. Again hold the power button in for a second, then the update begins. Let it finish completely. You will be instructed to reboot the system. Hold the power button in until the GPS shuts down. Mine still would not boot after this. Don't panic.
7. Again, enter the venus0 menu and navigate to the "update Uboot" line and select it with the power button. Bear with me on this as it was late and I had tried many things to restore the GPS, but I recall there being another sub-menu with a similar "update using SD/MMC" option. Select it and the Uboot is updated. Again you are instructed to reboot. At this point my power button worked, but the GPS would boot with a white screen and then freeze at the "don't hit a tree and sue us" screen.
8. Plug in the USB cord. If the computer recognizes the GPS, GREAT! if not, reset the GPS with the reset button while the USB is plugged in. As I recall, my PC would recognize the GPS at this point, and there were 4 empty folders in the TFAT drive. These are the folders that you will copy the data from the unzipped EXE file into.

9. Copy all the files into their respective folders following the instructions provided by odoug. I slightly modified them to apply them to this process:

_________________________________________________________
A. Create USBTRANS file in SYS folder on unit (or copy the backup that was made on the SD card if you have one)
B. Copy contents of COPY_GROUP 1, 11, 13, 17 to SYS/USBTRANS
C. Copy contents of COPY_GROUP 2, 3, 5, 7, 8 to MAP
D. Copy contents of COPY_GROUP 4, 6, 12, 14, 15 to APP
(NOTE: in order to copy over group 14, you will need to copy the contents of TNShell_Bitmap\Venus2 to the same folder on the unit, that way the folder isn't just replaced)
E. Copy contents of COPY_GROUP 9 and 10 to SD card
F. Copy contents of COPY_GROUP 16 to USR

DON'T FORGET to put in the UNIT_ID.DAT file back in the USBTRANS folder if you haven't already. If you were lucky enough to have backup files from a previous update attempt, then the UNIT_ID file that was on the SD card should be used.

_________________________________________________________
Assuming you do not have a valid UNIT_ID.dat file, you will need to create one. Open notepad. Copy and paste the following into the notepad window:

Model name=CrossoverGPS
Model number=385840
ID=719
Serial number=XXXXXXXXXXXXX
Code Flash size(MB)=32
Nand Flash size(MB)=0
Program RAM size(MB)=27
SD Card Serial number=
Power status=AC
OS version=R10
SH version=2.11
Navigator version=2.16
MP3 Player version=
Picture Viewer version=
TNCommander version=0.01
Keyboard version=0.08
Region=1
Firmware version=2.18
Hardware version=0

Replace ONLY the 13 characters in the Serial Number line with your serial number, found on the bottom of your GPS, then save the file in the My Documents/Maestro folder you created naming it UNIT_ID.dat then close notepad.
10. Copy the UNIT_ID.dat file into the SYS/USBTRANS folder.
11. You can unplug the USB and it should reboot. Again, mine was still a bit hosed, but it was trying at this point, and I found out that there is enough information in the GPS for the update EXE file to attempt to update the GPS. Mine would not install the update because the ID file I had was hosed and had wrong information in it. Mainly mine had an incorrect model number. I found that I could replace the UNIT _ID file and the GPS would re-hose it every time it rebooted. I got around this by starting the update file and while it was extracting and unzipping files I did another copy and paste of the UNIT_ID.dat file into the TFAT/SYS/USBTRANS folder, and onto the SD card in the USBTRANS folder there. When the update file was ready to install, I started it and it found and updated the GPS.

VIOLA! Unbricked my 3100 thanks to instructions above and some additional assistance from odoug

Joe

Comments

  • dhn 328 Points
    Joe, I've taken the liberty of splitting off your post and making a sticky out of it. I know others will appreciate the hard work and effort you've put in to arrive at a solution.

    [dhn -- moderator]
  • joester 0 Points
    First off, I'm honored but I must relay kudos to those who have "gone before me" and on who's findings I based my efforts.
    It was a matter of pride for me, having bricked mine messing with it after a successful update installation.

    Second, I found there are two hidden menus, some abilities not listed in any instructions I have seen, and the small hole in the lower right corner appears to be a microphone (I removed the back out of curiosity).
    I will follow up with more as I figure out how things work.

    Also, I have developed the habit of using the "Safely Remove Hardware" icon on the PC near the clock to stop communications before unplugging the USB cord. I had a few "Delayed Write" errors that sent me backwards a few steps that could have been avoided. I would advise anyone connecting their GPS to their PC to do the same.

    Joe
  • Teckie 0 Points
    Didn't just brick it, I did a Shaq shoot'n and 1's :evil:. Went into a small fit like sombody stole something from me :twisted: . But, ah-ha.....followed your detailed (did I mention detailed) instructions to the letter and "TADA" my 3100 was resuscitated like a one squeez heimlich maneuver. And yes I did a little dance :lol:. Thank you so much Joe. You am da man.
  • joester 0 Points
    Congratulations!

    Glad to hear someone could navigate the myriad of complexities to transform their former paperweight to a functioning technological wonder!

    Joe
Sign In or Register to comment.
↑ Top