This site uses cookies to offer you a better browsing experience. Find out more about how to manage cookies, or dismiss this message and continue to use cookies.

RoadMate 2136T-LM -------- updates ???

trx680 0 Points
edited November -1 in Magellan Vehicle Forum
Just registered the new gps and I'm checking to see if there are any updates. Even though this is new I thought there would be some updates somewhere here in the USA.
When I attempted to update CONTENT MANAGER is showing version 2.240.
The SOFTWARE UPDATE and MAP UPDATE are showing nothing.


Am I doing something wrong or is there no free updates?


thanks !!!!!!!

Comments

  • It happens to me too. Does anyone has a solution?
  • I have contacted tech supp. and spent over two hours to fix. The process is the same. The tech asked me to wait for whole five minutes before clicking ok on the page of naming my device. After that I had to be patient and kept trying to register my GPS until Content Manager said registration successful. However I still waiting for two 40 minutes download for software and map updates. It made me feel Magellan put out a product which is not ready to be used.
  • glennc 0 Points
    I have purchased this unit and returned the first and am returning the second. I have read that updating to the latest software/maps cause some of these units to malfunction. Mine is one, poi and response time turns into minutes and then reboots. I have only gotten one successful poi. Spent an hour on tech support and this is an apparent known issue that they are working to fix. Also the LM update newest is just a year old. Good luck with your purchase, I must say that I love the display and rerouting and simple to use interface. Just a year old update that can freeze the unit and they haven't released a fix in over a year is disconcerting.
    Glenn
  • Ok, I love GPS' and I bought this one from store in Houston. It was a brand new unit and it worked fine. I updated it in Oct. 2012 and it was slow, laggy and the points of interest did not work. So Magellan was kind enough to send me a new unit with the latest software installed. It STILL was slow and lagged badly. Again the points of interest did not work. So I posted on the Facebook page for Magellan about my issue.

    The Tech said to Connect my unit to my laptop or PC and close the Magellan content manager. Then open up the My computer and look for the Magellan drive. Mine was Drive: F

    Then right click on the drive symbol, click on properties and then select defrag hard drive. Which I did. It took about 30 minutes.

    I rebooted the unit and Wham!! it works like it should!! Points of interest, no lag and quick turn by turn nav. Woo Hoo!

    I hope this helps allot of people!!
  • andrewdickinson 1 Point
    edited August 2014

    Ok, I love GPS' and I bought this one from store in Houston. It was a brand new unit and it worked fine. I updated it in Oct. 2012 and it was slow, laggy and the points of interest did not work. So Magellan was kind enough to send me a new unit with the latest software installed. It STILL was slow and lagged badly. Again the points of interest did not work. So I posted on the Facebook page for Magellan about my issue.

    The Tech said to Connect my unit to my laptop or PC and close the Magellan content manager. Then open up the My computer and look for the Magellan drive. Mine was Drive: F

    Then right click on the drive symbol, click on properties and then select defrag hard drive. Which I did. It took about 30 minutes.

    I rebooted the unit and Wham!! it works like it should!! Points of interest, no lag and quick turn by turn nav. Woo Hoo!

    I hope this helps allot of people!!

    I registered and signed up for an account here just to reply (and thank you).

    This comment solved all my problems with my 2136T. Since Day 1, trying to type an address in has taken (no joke) anywhere from 3-5 minutes of waiting between letters while the unit laboured after typing one letter! Now that I've defragmented the unit, it works almost instantly.

    Thank you thank you thank you for this tip!

    (..and sorry for reviving a dead thread, but I was going to purchase a new unit because I was so unhappy with this one. Frankly, I opted to navigate using my phone over the Magellan because of the speed.)
  • Tim 1465 Points

    and sorry for reviving a dead thread

    Glad it was able to help you out!
  • rickylai said:

    I have contacted tech supp. and spent over two hours to fix. The process is the same. The tech asked me to wait for whole five minutes before clicking ok on the page of naming my device. After that I had to be patient and kept trying to register my GPS until Content Manager said registration successful. However I still waiting for two 40 minutes download for software and map updates. It made me feel Magellan put out a product which is not ready to be used.

  • suncoastwes 0 Points
    edited October 2014
    SLOWNESS SOLUTION! I loved it until I did the version 4.93 upgrade from original version! Then I hated it. Now I love it again after I fixed it. The company support was no help. He offered me a discount if I bought a new GPS. Here's what's happening. A new install is all nice and tight on the hard drive with no fragmentation. The files can be accessed quickly. After the upgrade the new install left the hard drive terribly fragmented. Per the support tech he said run a defrag with a computer. I did that and OK for a day and then soon it was slow again. It even rebooted when asked to search and never completed a search. I noticed the hard drive as still quite defragmented and it said the files could not be moved. A fragmented hard drive will be slow as it has to jump all over the place trying to retrieve files. So being a computer tech I knew the solution to that. Here's the solution! Create a folder on a computer and copy all the files off the Magellan Roadmate hard drive into the directory. You might also consider doing this with the original files BEFORE upgrading to 4.93. Now format the hard drive on the Magellan GPS. Yes formatting is a scary proposition but hey it was useless anyway so I had nothing to lose as it didn't work right anyway. Now copy the original files back onto the GPS hard drive. I seen a sys directory was created on the gps hard drive. I over wrote it as I wanted the sys directory from my backup files. Now disconnect the GPS and walla it's normal again. You can verify the nice tight files by doing a defrag analysis and it will show a complete clean install with no defragmented files. I posted this as I have had many people help me. Now it's my turn to help you. This may work on any GPS with the same problem. Also if you know someone with the same model you can copy their files and load them into your same newly formatted gps. You will just have to edit their saved address list after loading it on and rebooting. I still have my file backup of the new ver 4.93. If you lost your files I can email them to you. Email me to get them. It is 1.64GB. wesm1@tampabay.rr.com
Sign In or Register to comment.
↑ Top