Nuvi 1490 LMT Startup Problem

Good morning everyone. This is my first post, and hope some of you might be able to help. Pardon the long text to follow, as I want to give you as much info as I can about my issue...

Bought a Nuvi 1490LMT (Lifetime Maps & Traffic model) over 2 years ago now. Worked without issue until recently.

When I start it up running off of battery, the Garmin Screen shows up, then the next splash screen (Stock its Garmin again, but I changed it to show "Subaru") where it says "loading maps" at the bottom. At this point, the screen goes black as the unit shuts itself off.

Trying to hook it up to the computer via USB, it will show the Garmin Start screen, then show the indicator bar at the bottom where it will show the green progress bar. However, the green bar does not advance at all, and the boot cycle starts over.
Meaning, the Garmin page will show again, then the progress bar etc...
It will continue to do this without any change until I unplug it. It will then ask me if I want to Power Off or Stay On.
I choose Power off, and it does just that. If I choose Stay On, it will go back to its first problem.

Running it off of AC (via supplied Garmin Car Power Cord) makes no difference and will just shut off after "Loading Maps"

I've tried the Reset Feature by holding my finger on the lower right side while powering the unit up. Selected "yes" to erase all data, but it doesn't seem to work as the Subaru Splash Screen still shows up upon restarting.

I've tried the battery pull for 7 minutes, but that doesn't seem to do the trick either as the Subaru Splash Screen still shows up.

I'm currently disconnected the battery for about 30 minutes now in hopes that my 7 minute count was a bit off.

If this doesn't work, I haven't found any further information as to what to do, or what the problem might be. Contacting Garmin, all they said was since its not under warranty anymore, to send it back with $120 and they'll send me another one.

Rather than do that and have this problem happen again, I'd like to get to the bottom of this problem.

I appreciate any and all help you might be able to provide. I know it was a long read, and if you've stayed with me this far, maybe you can give me some insight as to what the issue is with this thing.

Thanks in advance, have a great day!!

Comments

  • sussamb 291 Points
    Slightly confused by you saying you've 'pulled the battery' as normally the battery is inaccessible?

    However I suspect you have a corrupt file somewhere, may even be your splash screen, see this thread about nuvi stuck in a loop
  • I took apart the faceplate and front of the unit, exposing the battery. Unplugged it for about 30 minutes and reconnected.

    **Update-
    After unplugging the battery, and doing the touchscreen reset, it now has a black 1st screen (no Garmin) and the Subaru screen is also gone. It does still shut off after being stuck on the "loading maps" screen, but at least it changed a bit.

    I will look into the corrupt file, although the splash screen has been on the unit for almost a year and a half, so I don't know what would have changed..
    Either way, if it will hook up to the computer and be recognized, I will look into that step.

    Thanks for the help. Keep em coming if you have any other thoughts!
  • PostPosted: Wed Nov 28, 2012 2:41 pm Post subject:
    I took apart the faceplate and front of the unit, exposing the battery. Unplugged it for about 30 minutes and reconnected.

    I have been using my 1490T for about 15 months now with no issues at all. Just curious where you found the info to take apart the 1490 to disconnect the battery to resolve problems with the unit. On other Nuvi models yes but not on the 1490.
  • NewPower99.com has videos for battery replacement for many Nuvi's, including the 1490.
  • class3 10 Points
    It sounds like you have a corrupted file or files. This exact same thing happened to my 255W. I didn't do anything to it other than change the battery one time. Afterwards it would shut down after "Loading maps" or continually reboot if on vehicle or USB power.

    I had written it off and moved on to a 3xxx series nuvi. But this start-up problem seems to happen often to people, so your post prompted me to look into fixing it tonight. I was successful but it took numerous steps and a lot of research. In my case, I had 6 corrupted files and eventually had to resort to formatting the device and doing a full backup. Luckily I had a backup of my unit from when it was new. If you don't have such a backup, it might be much more difficult for you to restore your nuvi.

    But perhaps you don't have corrupted files and you just need to reflash your software. If so, you might want to first try what this user did here: http://www.poi-factory.com/node/31902

    You can download the 6.20 GCD for your 1490 here: http://www.garmin.com/software/nuvi13xxand14xxseries_GCDFile__620.gcd

    Warning: this involves flashing software to your device so there is always a risk you can brick your device.

    Basically:
    - Download the GCD from Garmin
    - Download the RGN tool from turboccc
    - Download Garmin eTrek update and extract Updater.exe
    - Drag and drop the GCD into the RGN tool and create a RGN file
    - Drag and drop the RGN file onto Updater.exe
    - Select USB mode in Updater.exe
    - Make sure your nuvi is turrned off and disconnected from your PC
    - Press and hold the upper left screen corner. Don't let go.
    - Connect the nuvi to your PC. It will start to boot up on its own.
    - Watch Updater.exe carefully to see when it detects the nuvi. This will happen within a few seconds. As soon as it detects it, the box next to "USB Device" will change to shows your nuvi. Immediately click OK to start flashing the software. You have a small window of time to do this.
    - Once the update process starts, you can let go of the screen.
    - The nuvi screen will say "Software Loading..." for some time.
    - Once it's done, eject the nuvi safetly from your PC.
    - Unplug the USB cable and start it up.
    - Hopefully your problem is now fixed. If not, chances are you have corrupted files. To fix this, you will have to load a cure firmware that allows you to access the nuvi as a drive in Windows. From there you will have to try to back up the files.
  • jp928 0 Points
    cure software ?
    Mine is almost the same - garmin logo, nothing further. If I am quick when its starting and recognized on USB, I can get the software load to run, but no further progress, not visible on the PC at all.

    ??

    tks
    jp
Sign In or Register to comment.
↑ Top