Garmin Express - Confusing Status - Map failed to update
  • daviwph
    Posts: 24
    I have a 265W and I update my lifetime maps about every 9 months or so. Garmin.com asks to update some piece of PC software every time but that's never been a problem. The update to Express has been the biggest jump.

    After clicking on updates, it listed a firmware update, and the map. The firmware update went OK although it seemed to take forever for Express to re-connect to the 265W again. Accessing as a mass storage device was OK.

    I clicked on the green US & Canada check box and clicked on continue. All I had for 6 hours was this screen:
    image

    Interestingly, it asked to "Please connect your device to continue" and "Updates in progress" at the same time.

    Since this was taking longer than normal, I restarted everything and ran the update. It ran from 9PM one day to 3PM the next before I gave up again. Still no map update.

    I'm using the same computer and cable as all the other successful map updates on this GPS and this is the first failure. I would have helped if Express provided more progress information.

    Has anyone had success with Express and a 265W?
  • t923347
    Posts: 2,582
    As has been reported here a number of times, in a number of threads, there are some major issues with Garmin Express software and the 2013.40 map update. You should not use Garmin Express but instead use Garmin's MapUpdater software. It can be downloaded from:

    PC Version

    http://download.garmin.com/lmu/GarminMapUpdater.exe


    MAC version

    http://download.garmin.com/lmu/GarminMapUpdater.dmg
  • daviwph
    Posts: 24
    Thank you for the link. I downloaded GarminMapUpdater.exe and ran it. I was surprised at the accumulation of Garmin drivers/software in my download folder that I have collected over the years. As GarminMapUpdater was "checking the server for updates" Express popped up again. I stopped it at the service level so I could continue. GarminMapUpdater took me back to www.garmin.com/mapupdates for a product ID where upon things appeared to lock up again. After a reboot, it turns out that GarminMapUpdater wasn't installed (and that's OK with me) but I found GarminWebUpdater in the start menu and clicked on that by mistake. GarminWebUpdater updated itself and proceeded to completely update my unit just like the good old days.

    For a company that makes products that are intended to keep people from getting lost, they need to address the circuitous route one has to take to keep these fine units updated.

    Thanks to GPSReview for getting me out of the ditch. I have arrived at my destination!
  • sussamb
    Posts: 4,343
    Garmin Express does things in the background, so best to unistall it IMO until they get the bugs ironed out :wink:
  • kenp
    Posts: 376
    t, thank you for the link! I knew that if I came here I'd find the solution within seconds.

    When I installed Express it would not find my device and my account didn't show the new map I was entitled to. Mapupdater found everything.

    Like a fool, I didn't come here first, but followed Express's instructions to install Garmin's USB drivers. Are there any problems with that? Mapudater found my device, and an external USB drive seems to still be working,

    While uninstalling Express, I saw that there's a Garmin webupdater. Is that something I should keep, or is it part of Express?

    Thanks

    Ken
  • SergZak
    Posts: 2,778
    kenp said:

    Like a fool, I didn't come here first, but followed Express's instructions to install Garmin's USB drivers. Are there any problems with that? Mapudater found my device, and an external USB drive seems to still be working


    Your nuvi does NOT use Garmin's USB drivers. The nuvi is treated like a standard removable USB Mass Storage device. No extra drivers are needed. You can safely uninstall these drivers if you feel the need to...but they don't take a ton of space so leaving them won't hurt anything nor take a chunk out of your drive space.

    While uninstalling Express, I saw that there's a Garmin webupdater. Is that something I should keep, or is it part of Express?

    WebUpdater downloads & installs GPS unit firmware (system software), voices, and other non map-related updates. WebUpdater does NOT install maps nor check for map updates.
  • speedlever
    Posts: 235
    FWIW, I used GarminExpress to load my 1690 with the 2013.40 update and then copied over the large JCV file.

    I had no problem with GE. I would have used mapupdater, but I didn't have the current version and didn't find it until after GE completed the update.

    Win7/64 home premium PC.
  • Thanks for the Garmin MapUpdater link. The new Garmin Express is not updating my Garmin Asus A50 phone to 2013.40 Australia correctly, but the MapUpdtaer worked fine. Thanks again!
  • comsnark
    Posts: 48
    Yes. . I also thank you for the link.

    I gave Express to finish it's task; and it failed. :shock:

    Why was I not surprised?
    I also found no options to alter WHERE files were downloaded.

    Is GarminMapUpdater no longer supported? I looked around for it on the garmin website, but other than the weblink noted here, I did not find it.
  • t923347
    Posts: 2,582
    AFAIK MapUpdater is still supported by Garmin as their Tech Support people were telling folks that had problems with Garmin Express to use MapUpdater instead. :roll:
  • kshallen
    Posts: 2
    Glad I found this site. Just got a Nuvi50LM and GE is just plain flakey. Sometime it sees the device, but then is useless. MapUpdater did the trick, but nice to see you all have figured out what works and doesn't. Thanks. I wasted a bunch of time but at least I know it wasn't. I dead get the Blue Screen of Death at one point and I have never had that on this Win7Pro64b machine.

    Their out of box experience designers really screwed the pooch. As someone you used to work on new user flows, Garmin provides all kinds of wrong turn opportunities for new users. Telling me to install USB drivers and such, asking you to install Garmin Communicator and providing multiple option, and allowing you to vector off into product comparisons, volume of privacy info, etc, before your done bringing the device up and get lost.

    Finally, the device would see the computer, but explorer didn;t see the device. Decided to uninstall all, and found BOTH 32 and 64 bit version installed of Communicator, plus the USB drivers, and the GE app.

    Just hideous human interface engineering IMO.
  • sussamb
    Posts: 4,343
    Is there a question in here or are you all sorted now :?
  • kshallen
    Posts: 2
    I got the garmin to do what i need with the map updater tool.

    I just won't use GE unless there is a reason (?) to, I just can't get it to work. I suspect it is a corrupt install and the uninstall didn't get everything out. I suppose I could do the regedit thing, but would rather not bother if map updater is sufficient.

    I am going to put 8GB into it so I can add more maps, so the question I has is can I do what I need with map updater tool. The 2GB is full out of box.

    I want to put detailed off road maps/topo in for Calif and Nevada for 4x4 trips to deserted mining sites. If anyone know what maps can help there that would be helpful. We cover hundreds of miles in middle of nowhere.

    Thanks
  • raygolost
    Posts: 3
    Thank you for the link to Garmin Map Updater. It is or was working better than Garmin Express. It looked like it was downloading the map then I got a message that windows said it stopped working and it killed it. I went to find it in the list of installed programs but I can not find it to restart it. I even went into the control panel>programs and do not see it listed. Were did it go?

    really lost here, Garmin Express will not download the map updates for my Nuvi 2555 and now I lost Map updater.


    Help please.

    Running Windows 7 home premium with SP1 and all updates installed.
  • t923347
    Posts: 2,582
    The Garmin Mapupdater program file you downloaded is probably in the folder that you use as the default download location for any file you download from the internet. In any event, you can always just download and run the program again from the Garmin website. With any luck when you run the program again it will start where it failed on your first try.
  • raygolost
    Posts: 3
    OK I figured that first part out.
    When I started it again it told me the map was current and I could stop there or ignore that and start over. I ended it then went to my 2555 and checked the map version on it and it was still at 2013.10. So I was back were I started, again.
    I ran map updater again and after oh 90 minutes or so I got the same message from windows that map updater had stopped working and it would be ended and Microsoft would let me know if there was a solution to the problem (there never is you know).

    I am back to the beginning of having a brand new $180 piece of crap. Sorry but I am very frustrated and I just need to vent to someone.
  • t923347
    Posts: 2,582
    I suggest that you delete the original downloaded program file and then download the Garmin Mapupdater from the Garmin Website again. Now run the newly downloaded program.

    If you continue to run into this problem, try disabling your Virus Protection program as some of those can cause issues and run the updater program again.

    There are many thousands of us that use Mapupdater with no problems on all kinds of Garmin devices with no problems at all. Believe it or not there are people that use Garmin Express with no problems. It is often the user's computer or it's operating system that is the root of these issues, not the software. :wink:
  • raygolost
    Posts: 3
    No I will not disable my antivirus software while connected to the internet. As far as my OS being the problem I had a hard drive issue and had to do a TOTAL reinstall of my windows 7 OS.

    I guess it goes back to the store first chance I get.
  • t923347
    Posts: 2,582
    Suit yourself, all we can do is try to help. ⁉
  • locopsu
    Posts: 1
    tried the link as I am also a mac user and have had problems getting updates for my NUVI 1470. Link loads and asks if I want to update the 2013.41 version, I click yes and it then skips a few places to say error, previous versions not installed.

    I called Garmin and they said they would send a link to a program with instructions on how to fix problem. So far no email. Any suggestions.

    I want to update maps and change the countries I have loaded, Italy was not loaded and we travelled from Switzerland to Italy and it was lucky I had a Navigator along to read map.
  • Hi have Nuvi 50 GPS and Garmin ask to do an update and down load Garmin Express witch I did to update the life maps. Now i can't use it, it wont let me in the place to put an address it sayes theres no detailed maps to do it but when i go back to update. It tells me that update is already done, also i can go in to my recently found address but this new update threw express deleted my detailed maps. Can some one tell me how i can fix this mess garmin as done to my gps :evil:
  • sussamb
    Posts: 4,343
    Try running MapUpdater and see what happens http://download.garmin.com/lmu/GarminMapUpdater.exe
  • sussamb
    Posts: 4,343
    Should add before you do that check Settings>Map>Map Info and see what's listed there. If a map is listed is it selected?
  • I'm running windows Vista. Garmin Map Updater is not seeing my Garmin. It is being recognize by my PC because when I connect it, there is a AutoPlay pop up. On the Garmin itself there is a picture of connection to a PC. Please let me know what I am doing wrong.
    Greatly Appreciated.
    Marta
  • sussamb
    Posts: 4,343
    Does it show in Explorer?

    Have you installed the Communicator Plug in ... http://www8.garmin.com/products/communicator/

    Does it recognise your GPS?

    Caveat: I've never used Vista :wink:
  • t923347
    Posts: 2,582
    It could also be helpful to know what model "Garmin" you are using.
  • I am using Garmin nuvi 50ml. To answer your previous question: no, the Garmin communicator plug in does not seem to recognize the device either. It just keeps spinning in both IE and Chrome.
  • popej
    Posts: 701
    Does your PC see nuvi as removable drive, like for example a pendrive?
    If yes, then can you find file \Garmin\GarminDevice.xml ?
  • Yes it can. Yes I see that file ans it seems to be empty. Oh Oh :shock:
  • popej
    Posts: 701
    Probably your nuvi internal memory is full. You have to delete something and then restart nuvi and try again.

    You can for example delete some unused languages from directory \Voice.
  • sussamb
    Posts: 4,343
    Almost certainly popej is correct. Delete some files and then reboot the nuvi. GarminDevice.xml file should be around 27kb in size, and it's what identifies your nuvi to Updater.
  • Thank you so much that did it!!! Although I have to say that some sort of an error/warning message would have been helpful especially since I didn't add anything.
    Anyway, thanks soooo much for your help!!!!😀 😀
    Marta
  • sussamb
    Posts: 4,343
    Well it wouldn't normally be full so something must have been added :?

    Anyway, good to know it's now working 😃
  • MichaelO
    Posts: 1
    Just confirming that multiple problems with Garmin Express exist for my 910XT model, too. I've uninstalled it.
↑ Top

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!