This site uses cookies to offer you a better browsing experience. Find out more about how to manage cookies, or dismiss this message and continue to use cookies.

Tomtom shows blue dot/circle with a red X

oscarwshbrn 0 Points
edited November -1 in TomTom Car Forum
A week or so ago I used my Tomtom to navigate from Tennessee to Ohio (about a 4 1/2 hour drive)...it seemed to work just fine the entire trip, but the next day I went to use it and now it goes straight to a screen that shows a picture of the GPS unit and next to it is a blinking blue dot with a red X inside it. I have tried plugging it in thinking that maybe the battery was just too low to start it up at all. I've also reset it a few times and it doesn't help. I have done some googling and found no one else with the same problem. PLEASE HELP!!!

Comments

  • dhn 336 Points
    What model tomtom do you have?
  • Tomtom XL 350tm...we've had it for close to 2 years and never had any trouble with it til now...tried connecting it to the computer and it shows it connected on the Tomtom itself but the computer doesn't show it connected so I can't update it or anything either...
  • dhn 336 Points
    Try resetting the unit. If the unit does not have a dedicated reset hole, hold the power button about 20 seconds till you hear the drum sounds.
  • Well, we made the circle change colors...it was a blue circle with a red X on a white background...now it's a red circle with a white X on a blue background...like I said in my original post, it has been reset atleast half a dozen times now and it doesn't help...when you turn it on there's just the Tomtom drum start up thing, and then it goes straight to a picture of the GPS on the left side and a red circle with a white X through it blinking...somebody please help me fix this! we just recently moved and don't know our way around town at all, so we keep having to borrow other people's GPS or use mapquest (so frustrating and unreliable)...
  • dhn 336 Points
    1. Make an Explorer, not Home backup. See here:
    http://www.tomtomforums.com/t17864-how-backup-contents-your-unit-computer-how-restore.html

    2. Use Explorer to delete all the loose files in the root of the unit, NO folders or their contents.

    3. Connect to Home and install the application offered.

    4. Disconnect properly from Home using the DEvice Disconnect icon.

    5. Restart the unit.

    Any better?
Sign In or Register to comment.
↑ Top