This site uses cookies to offer you a better browsing experience. Find out more about how to manage cookies, or dismiss this message and continue to use cookies.

IE 11 and other updated web browsers.

I pluged my 2595 in and went to MyGarmin to update the code. Dashboard came up and said communicator wasn't installed. I tried to install it several times but it kept coming up rhat it wasn't installed. Searching the internet it appears other browsers that have been updated lately are also failing. To get it to work I had to back out IE11 and run on IE10. Just a heads up for those that keep yheir systems updated.

Comments

Sign In or Register to comment.
↑ Top