This site uses cookies to offer you a better browsing experience. Find out more about how to manage cookies, or dismiss this message and continue to use cookies.

End of the line for Basecamp on Windows XP?

Just noticed this post on Garmin's forums from one of the Basecamp developers. If correct, users of Windows XP will not be able to upgrade beyond Basecamp 4.2.

https://forums.garmin.com/showthread.php?66500-Unable-to-install-Basecamp
FALAGAR
Desktop App Developer

BaseCamp 4.2 requires .NET 3.5 and runs on XP. 4.3 will probably require 4.5 and will therefore not run on XP anymore.

(XP is now more than 12 years old, official support from Microsoft will end next April. That means no more security fixes. Updating is highly recommended.)

Comments

  • SergZak 340 Points
    IMO, the best Windows OS. That's probably why it's lasted so long. We still use it on all the PC's at work and we still use Windows 95 on our main CNC router. I don't see us upgrading anytime soon either.
Sign In or Register to comment.
↑ Top