This site uses cookies to offer you a better browsing experience. Find out more about how to manage cookies, or dismiss this message and continue to use cookies.

OSM map downloaded & installed. Does not show up on eTrex20. How to fix?

I have downloaded and installed a gmapsupp.img file (185MB) on a brand-new Micro SD card with a directory named Garmin added to it and installed on a brand-new eTrex20. But the map does not display. The map directory shows only the two default maps. Any suggestions would be greatly appreciated.

Comments

  • sussamb 798 Points
    edited June 2014
    Which OSM map? Is the card formatted FAT32? When you connect your Etrex to your PC do both the Etrex and card show in Windows Explorer?

    I assume the map file is in the Garmin folder?
  • sussamb 798 Points
    Another thought, have you tried renaming the map file? gmapsupp.img should work but you never know.

    Other thing is to ensure you know whether Windows Explorer is set to display file extensions. If it's not and you've named the file gmapsupp.img then it will actually be gmapsupp.img.img which won't work.
  • Hi. Thanks for the reply. It’s a custom OSM map. The card is formatted to FAT32. (I checked.) I have a Mac. Once the eGTrex is plugged in, the Mac shows that a Garmin GPS is attached and that it has a SD card inside with a garmin file attached as well. It also shows the gmapsupp.img file (185 MB) on the card.

    I renamed the file to gmapssupp1.img, disconnected and restarted and still no map.

    By the way, this is the second time I’ve downloaded an OSM map file, installed it and it didn’t display. (The first was 225 MB.)
  • sussamb 798 Points
    Well I've never had an issue with OSM maps on my Etrex 20. Where are you getting the maps from?
  • sussamb 798 Points
    edited June 2014
    Well they should work as they do on my Etrex. Have you tried installing it to the internal memory to see if it works there?

    If so it could be an incompatible card.
  • I installed it in the CustomMaps directory on the etrex. Didn’t display.
  • sussamb 798 Points
    It doesn't go in CustomMaps but in Garmin folder. That's where you said you had it on the card. If you didn't that's why it didn't work.
  • Okay! It displays (and looks so much better than the default). The SD card is formatted to FAT32. The card shows that gmapsupp.img is loaded on it. Could it still be corrupted? Can something called javawa fix it?
  • sussamb 798 Points
    When you say it shows is that with it in internal memory? Does it then not show if you move it to a folder called Garmin on the card? If not then try another card.
  • Yes, it shows only when the file is in internal memory. When moved to the card (with Garmin directory added) it does not display. Will try another card next and will report back. Thanks for the help so far.
  • It occurs to me that maybe the problem with my system is my laptop/etrex/SDcard set-up. The set-up that doesn’t work (and should?) goes like this:

    laptop
    GARMIN (etrex)
    documents
    garmin
    NO_NAME (SD card)
    garmin
    gmapsupp.img

    It should work like this, yes? Should the SD card be renamed Garmin as well? Or is that too many garmins?
  • Adding indents, it should read:

    laptop
    ______GARMIN (etrex)
    ___________documents
    ___________garmin
    ___________________NO_NAME (SD card)
    __________________________garmin
    _________________________________gmapsupp.img

    I
  • nevw 38 Points
    ...just to be explicit, the gmapsupp.img needs to be inside the garmin directory on the sd card and/or inside the garmin directory on the extrex internal drive.
  • sussamb 798 Points
    Doesn't matter what the card is called. Has to be in folder named Garmin. Note the capital G.
  • Boyd 1974 Points
    Note the capital G.
    Does that matter on the eTrex? Upper/lower case makes no difference on any Garmin device that I have seen.
  • sussamb 798 Points
    You're right I'm just grasping at straws. I know on mine they are all capital Gs. If you say it doesn't matter then I have no idea why the OP can't get the map to work, never been an issue on mine.
  • Boyd 1974 Points
    On your mac, are you showing file extensions? Finder > Preferences > Advanced > Show All Filename extensions.

    Probably doesn't matter, but it might reveal a problem. I recall an issue once where a user had named a file gmapsupp.img.img but it was only showing gmapsupp.img on the computer.

    I know you said that you checked and the card is formatted as FAT32, but what you describe is exactly what would happen if it was not. You might try formatting it again using Disk Utility on your Mac.

    Also, how large is the card? Not sure whether cards larger than 16gb will work properly. I know that 32gb cards have issues on some recent Garmin models.
  • Hi y’all. Now I’ve got even more problems. I bought a new card (8 GB) to see if the card was faulty. But now the laptop doesn’t see that the garmin is plugged in with the USB cord. It doesn’t "see" the garmin whichever USB port I use, or whether the SD card is in or not. Or whether it has batteries or not.

    I checked it against another Mac and that Mac sees the Garmin. It’s not likely that it’s the cable. I’m thinking that this is a lemon and I’m taking it back.
  • Boyd 1974 Points
    I checked it against another Mac and that Mac sees the Garmin. It’s not likely that it’s the cable. I’m thinking that this is a lemon and I’m taking it back.
    How did you arrive at that conclusion? The test you did would indicate there's a problem with the USB ports on your Mac. Have you tried other USB devices on it? Did you try restarting your Mac?
  • nevw 38 Points
    I noticed at the osm help site that owennatekha has solved his problem...he states...
    The problem is solved. Finally. The problem was the SD card (16GB). I replaced it with a different brand and smaller size (8GB) and everything worked fine.

    Many thanks to all who thought about my problem and offered suggestions.

Sign In or Register to comment.
↑ Top