This site uses cookies to offer you a better browsing experience. Find out more about how to manage cookies, or dismiss this message and continue to use cookies.

nuvi 40lm language

Only Spanish and Portugese are shown as languages from which to choose, and up and down arrows are grayed out. Need American English, which is not an option

Comments

  • sussamb 813 Points
    edited August 2014
    Run Express and click the device tab, scroll down to Language Files and select the ones you want, in your case English.
Sign In or Register to comment.
↑ Top