This site uses cookies to offer you a better browsing experience. Find out more about how to manage cookies, or dismiss this message and continue to use cookies.

Software Missing on my GPSmap 60CSs

Hi All,

I was in the process of updating the software on my GPSmap 60cs and things went down hill. I have no idea what I did but I ended up with having no software. Please help.

Thanks......Doug

Comments

  • sussamb 792 Points
    No idea if it will work as I don't have a 60 model but try connecting it to your PC and running WebUpdater.

    I assume you didn't make a back up of the files on your GPS?
  • Boyd 1966 Points
    There is nothing that a user casn "back up" on the older Garmin handhelds like the 60 series. No user-accessible internal memory, everything is burned into the firmware. When you use Mapsource or Basecamp, the software actually "talks" to the GPS using Garmin's special protocol, requesting data and transferring it. Mass storage mode is not used for this. The device does have a card slot that can be mounted as a USB disk, although you have to access a menu command on the GPS to initiate this. And the only things stored on the card are maps (although the unit can archive tracklogs there if you choose the option in the menus).

    The 60 series firmware is archived here, although the current version should also be available from Garmin via webupdater

    http://www.gawisp.com/perry/gps60/

    Can't remember, but I think there may have been a standalone firmware installer included in the download of some of the old firmware.

    Unless something is fried on unit, you should be able to just re-install the firmware and get back up and running. Actually, it appears that they want you to use Garmin Express to update these devices now. See:

    http://www8.garmin.com/support/collection.jsp?product=010-00422-00
  • Thanks for all your input but still nothing. I going to try and contact Garmin tomorrow and hopefully get through to them. When I run the updater it says that it can't find my device so I'll let you know how I make out.

    Thanks again.......Doug
  • Hi All,
    Well I tried to do the update again by running the web updater, but this time I put in 2 fresh batteries and holy smokes it worked. Duh I should have tried the batteries earlier.

    Thanks again for your input.........Doug
  • sussamb 792 Points
    Good to know you got it working :)
Sign In or Register to comment.
↑ Top