This site uses cookies to offer you a better browsing experience. Find out more about how to manage cookies, or dismiss this message and continue to use cookies.

Problems at myGarmin

Has anyone tried to log into their myGarmin account this weekend? I've been trying since Friday and it won't let me log in. I've even gone trough their "forgot password" process several times, and although I get the email and go through the enter new password part okay, it just refuses to log me in.

Comments

  • sussamb 813 Points
    There appears to be a problem but if you click on the myDashboard tab you'll find you're logged in. At least that's worked for me.
  • alanb 539 Points
    edited March 2015
    Is it just redisplaying the sign-in fields when you try along with the message "Security is important. Please sign in again to confirm your identity"? Are you using Internet Eplorer? I get this problem with Internet Explorer (but not Chrome). The solution is to use chrome, or if you need to stick with IE, click the myDashboard tab (even though it didn't take your sign In) and Click the :"Sign Out" link on the myDashboard screen. Then sign in again and this time it will take.

    This seems to be some kind of conflict between the Garmin forum signin and the my.Garmin signin on older versions of IE (which Windows VIsta is stuck with).
  • privet01 221 Points
    Thanks for the responses...

    I just tried it again. This time with Chrome and all is well. However Firefox is the normal browser I use on my PC. So maybe a recent update with Firefox broke something. When I try with firefox, it never shows my name at the top indicating I've been logged in. When I click the "myDashboard" tab it want's to install Garmin Communicator again, but just get in an endless loop of installing the plug-in then restarting the browser. Firefox has been the browser of choice for me on this PC for years, so I know it's worked before and Garmin Communicator was previously installed on Firefox.

    But for now, Chrome is working so I'll remember to use that.
  • Boyd 1985 Points
    edited March 2015
    Everything seems to work fine in Safari on my Mac. Perhaps the Firefox problem is related to this?

    http://www.garmindeveloper.com/web-device/garmin-communicator-plugin/

    Notice: Plugin Support Is Ending
    Due to evolving web standards, modern browsers are ending support for most third-party plugins, including the Garmin Communicator Plugin. If you’re using the Communicator Plugin on your website, be aware that most major browsers will not be supporting plugins in the future.

  • Boyd 1985 Points
    edited March 2015
    Hmm. Just tried with Firefox 35.0.1 under Windows 7 Professional. No problem accessing myGarmin. I just clicked the "Sign In" link at the top of Garmin's homepage, entered my user ID and password and I was connected with no error messages. I then was able to use the "Your Account" dropdown menu to view MyMaps, etc.
    alanb said:

    This seems to be some kind of conflict between the Garmin forum signin and the my.Garmin signin

    I had a lot of problems with conflicts between the Garmin forum cookies and other things on Garmin's site. When I browsed product listings I would get lots of redirects and error messages. Finally I delete all Garmin cookies and everything was OK. That convinced me to stop wasting my time reading Garmin's forums. I have not logged into the forums since then and don't have any of those strange issues anymore.

    This was with Safari on the Mac, FWIW.
  • alanb 539 Points
    Sounds like the cookies problems are still there Boyd. It is wierd, when I use the method I described above to sign into my.Garmin with IE, I am still signed into the forum and both sites work OK until I stop and Start IE. I must then re-sign in to the Garmin forum and after that, the myDashboard sign-in no longer works.

    I wish I liked Chrome better ... just can't get used to it.
  • Boyd 1985 Points
    @privet01 - I would try deleting all Garmin cookies from Firefox. That will probably fix the problem (unless you login to Garmin's forum again). :D
  • privet01 221 Points
    I've gotten away from my PC for day. I'll try to do that tomorrow when I'm back, but Safari and Chrome on my macbook both work without issue. I've wondered several times this over the last year why they still have the Garmin Communicator function in the myGarmin site as Garmin Express seems to be taking the place of g.communicator and many other garmin utility programs.

    I suppose there are some really old Garmin products still used that Garmin doesn't want to build into Garmin Express, but certainly as Boyd mentioned, plugins for browsers are going to the wayside. Now it's 'apps' for your OS similar to apps for your smartphone. Which essentially means they are going back to the old way of doing things on the computer with a fancier way of thinking about them! :)
  • Boyd said:

    @privet01 - I would try deleting all Garmin cookies from Firefox. That will probably fix the problem (unless you login to Garmin's forum again). :D

    I have FireFox configured to delete all cookies on shut down of the browser. I just wish FireFox ran smoother on win7 home pro on an Acer disguised as a Gateway.

  • privet01 221 Points


    I have FireFox configured to delete all cookies on shut down of the browser. I just wish FireFox ran smoother on win7 home pro on an Acer disguised as a Gateway.

    Are you sure? I didn't think there is an option to do that. You can delete your "history" upon shutdown, but that is not the same as deleting all cookies including persistent cookies........ AFAIK of course.

    As for the issue in firefox on win7 that I was having, It did go away even before clearing the browser cache. There was at the same time some other login and display name issues at the Garmin Forums too. Garmin apparently ties together some of the login and account information behind the scenes of the myGarmin, Garmin Forums and Garmin Connect.sites. Note that there is no control of display in the Garmin Forums once you register, but in Garmin Connect you can change it. Even though the two accounts had different display names from when I first created them three years ago, the Garmin Forum display name suddenly changed to my Garmin Connect display name. Even after the forum admin changed it back, when I went to Garmin Connect and changed it to something else as a test, my Garmin Forums display name changed immediately.

    The net result is that I still don't use my Garmin Connect account under that login as a year ago there was a similar issue.
  • t923347 432 Points
    You can delete cookies when shuting down Firefox:
    Tools
    Options
    Privacy
    Clear your recent history
    Time Range to clear - Everything
    Checkmark the Cookies entry
    Tap - Clear Now

    As to whether that has to be set each time you want exit Firefox or not I can't say but there is no Save button on the screen. I also have no idea if this clears "persistent cookies".
Sign In or Register to comment.
↑ Top