This site uses cookies to offer you a better browsing experience. Find out more about how to manage cookies, or dismiss this message and continue to use cookies.

Garmin Edge 800 Problem

The Unit keeps turning itself off shortly after start-up. The battery is charged (charged all night) and I have done a hard reset and downloaded/updated software...Very frustrating! It says it's it's looking for satellites, does so for about 5 seconds, and then turns off! This is happening both on my unit, about 3 years old, and now on my wife's Edge 800, which is only 1 year old! Any ideas??
Thanks for the help!

Comments

  • privet01 215 Points
    To me the symptoms just sound like dead batteries. Though it's possible, but less likely, a recent update could be the cause.

    If both units are being charged with the same charger or cable, then I'd try using another. If you don't have another charger, then just use your computers usb. That is how I always charge my edge500 which is pushing 4 years old.

    If that's not it, then be sure to try a hard reset. Data may be lost and settings revert back to defaults. So copy off what you might want. If you are not sure, then just copy everything to your computers hard drive. Does your 800 show up in your computers file explorer when you connect it to your computer? If not, that may indicate a cable issue. If it's the same cable as you charge from then that also may indicate the cause of your problem. Try cleaning it by putting a little wd40 on the terminals and working it on and off several times.

    And if none of these or any other suggestion here don't work, then don't forget that Garmin Support is FREE. Just call them. Especially if your wife's unit has not actually crossed the 1 year old mark as Garmin, particularly in North America is good about replacing defective units under it's warranty.

  • Boyd 1974 Points
    privet01 said:

    To me the symptoms just sound like dead batteries. Though it's possible, but less likely, a recent update could be the cause.

    Do you know if you recently updated the firmware on both units? Are they both running the same version firmware? It is possible to revert to older firmware if needed.
  • Follow-up and Question: After updating software and doing multiple hard resets I contacted Garmin and they exchanged it for a refurbished Edge 800. This one works fine but still has one glitch I can't figure out: during a ride I will get a message asking if I want to continue the trip..and then it starts a countdown to zero. If I don't press "yes" it turns off.. Is there a setting I can change to stop this..I simply want it to remain on until I turn it off!
    Thanks!
  • privet01 215 Points
    Did you start the timer? Edges have an auto-shutdown feature that is enabled by default. It looks to see if the timer/stopwatch is running or not. If the timer is not running then it will shut itself down after about 10 or 15 minutes.

    The timer also determines whether you are recording data to the log/activity file.
Sign In or Register to comment.
↑ Top