This site uses cookies to offer you a better browsing experience. Find out more about how to manage cookies, or dismiss this message and continue to use cookies.

"Problem communicating with our servers"

I have 3 devices: 2 nuvis and an eTrex 20. There is no problem with the nuvis.
Using Express for Mac v4.1.12.0, I get the following - ONLY for my eTrex:

photo Screen Shot 2015-12-22 at 14.31.19_zpstpbdypzw.png

This: for 2 months.
Garmin support: useless.

I have deleted the device, and added it again. No change.
Help would be appreciated.

Comments

  • Tim 1459 Points
    For the purposes of troubleshooting, not as a solution, I would create a new user account on your computer, install Garmin Express, and see if it is able to connect.
  • Ramaprem 110 Points
    Thanks, Tim.
    But nothing is different; same issue.

    By the way - as it didn't seem important - it matters not if the device is connected, or not. Simply clicking in the field for the eTrex in GE gets that message.
  • Ramaprem 110 Points
    @ Tim
    I have also installed Express on two other computers - with no relief.
    What a ridiculous situation.

    Garmin support is not a help. Honestly, though, I think that they also do not know what to make of it. But their responses - which no longer come - are automated; it seems that no human has put their mind to it.

    Can someone please tell me if the software for this device has gone beyond v4.30?
    And if it has, how can I possibly update my device?
  • Boyd 1786 Points
    edited December 2015
    4.30 is the newest version in the Perry archives here. I don't know how frequently they are updated:

    http://www.gawisp.com/perry/etrex/eTrex_10_20_30/

    Have not updated my handhelds for awhile, but IIRC there are two kinds of update files. One of them is for the unit firmware, which is the software that provides the menus, map screens and user interface. Then there is a separate update for the GPS chipset itself. If I'm reading the archive listing right, it looks like the newest version of that is 2.10

    I believe you can manually update by downloading these files , copying them to the Garmin folder on the eTrex and changing the filename to gupdate.gcd. When the eTrex restarts, it will install the firmware.

    Have you tried calling instead of e-mailing Garmin? Many people feel that provides a better level of service, and always gives you the option of asking for a supervisor if you are not satisfied.

    In the end, I think you are at Garmin's mercy though. It is their product, their software and their servers. If they can't resolve this issue, I doubt that anyone here can. :(
  • Ramaprem 110 Points
    edited December 2015
    Thanks, Boyd.
    You've provided some additional info regarding updates.

    So there is something - the last entry - in this perry thingie that seems to be for the 20. It has a date just last week. What is it? How can one tell/know what it is?
    Since this issue is months old, clearly my device hasn't benefitted from it.
    I'm downloading it now. Do I connect my device and double-click it and...?

    "If they can't resolve this issue, I doubt that anyone here can."
    I agree; I wasn't holding much hope that someone of the forum could resolve this. But I gave it the old college try.
  • sussamb 663 Points
    edited December 2015
    Are you trying over wifi? If so try direct cabling as issues with wifi routers can throw up that error message.

    v4.30 is the latest BTW.
  • Boyd 1786 Points
    Ramaprem said:

    I'm downloading it now. Do I connect my device and double-click it and...?

    I described the process above: copy the file to the Garmin folder on the eTrex and change the filename to gupdate.gcd. When the eTrex restarts, it will install the firmware.

    I don't think that file will work on your eTrex 20 however. If you look a little closer at the link, it appears to be for the eTrex 20x and 30x which are the new versions in the eTrex line.
  • Ramaprem 110 Points
    Sorry, Boyd, for not re-reading your instructions. This thing has me a bit ga-ga.
    I also did not know the significance of the "x" in the filename. I thought that it meant all 20s; I don't follow the device-line so closely.

    @ sussamb,
    Thanks. I'll try your suggestion tomorrow, or so.
    Note that 2 other devices don't present this problem. All over wifi.
  • Boyd 1786 Points
    Here's what you missed. :)

    https://buy.garmin.com/en-US/US/into-sports/handheld/etrex-20x/prod518046.html

    "eTrex 20x is our upgraded version of the popular eTrex 20, with enhanced screen resolution for a more readable display and internal memory expanded to hold more maps."
  • Ramaprem 110 Points
    I continue to receive periodic/sporadic advice from Garmin:
    Trash the .xml file in the Garmin folder on the eTrex
    and the result: nada.
    Do a master reset
    and the result: nada.

    However, I've discovered a work-around; the solution might never be found.
    I used WebUpdater - and it had no problem communicating with Garmin's servers.

    So, problem "solved".
  • Ramaprem 110 Points
    Up to this day, the original problem has been present.
    After all this time - 8 months - Express has finally seen fit to connect my eTrex20 to its servers!!
    I was shown a Time Zone update, and the update was installed.

    Garmin support - the last I asked for it - told me the device needed repair/replacement.
  • privet01 145 Points
    This gets complained about a lot in the Garmin forums, though the majority of users never seem to experience it.

    One of the solutions that has helped a small number of those with the issue is to ensure that both the time zone and the country or region is set correctly on the users pc/mac.

    Another issue might be adblocker or malware software you might be running on your computer. I've experienced an issue with the new version of the Garmin Connect site when I had the domains of a couple sites spoofed to my machine. When I allowed them access then the new Garmin Connect site worked fine. I don't know if Garmin Express similarly uses these helper sites to perform stuff or not. Might be an interesting experiment. But I don't use GE. As long a mapUpdater and webUpdater with the old Garmin Communicator still work, that's what I'm sticking to.

    And of course sitting behind some proxy servers or using a vpn or an overly restrictive firewall might do the same.

    I've never seen a perfect solution that fits everyone. Many post on the issue never seem to get resolved. But it still seems to affect a small number of users that doesn't elevate the issue to the point where Garmin wants to put it as a priority to look into.
  • serdej 0 Points
    Hi,
    i am resolving problem with connection on Garmin servers by update on my Garmin 2595.
    I remove and new instalation Garmin expres and (very import) new USB drivers from: https://www8.garmin.com/support/download_details.jsp?id=591 .

  • serdej 0 Points
    Another way to resolving problem with connection o Garmin servers is probably in your browser which has set Anti-Pishing. Tray to temprary turn off this setting and traying to connect to servers.
Sign In or Register to comment.
↑ Top