This site uses cookies to offer you a better browsing experience. Find out more about how to manage cookies, or dismiss this message and continue to use cookies.

Nuvi 3597 and USB 3.0 Issues

For awhile now I have been having trouble connecting my 3597 to my new HP laptop. I plug the USB cable (I've used many) in to the Nuvi and an available USB port on the laptop and although the screen on the Nuvi changes to the "GPS - Computer" icon, the Nuvi never actually connects and doesn't appear in Windows. If I disconnect the USB cable from the GPS the Nuvi is hung and I need to press the power button for about 10 seconds in order to turn it off. As you can imagine this is a PITA when attempting to update software and maps or installing POI files.

Today I had sometime to try and determine what the issue was with my Nuvi or my laptop and I think I've figured it out. Out of desperation I connected the 3597 to my wife's HP laptop which is a bit older than my unit and found that it almost immediately connected and was seen by Windows 10. That got me to investigate what the differences were between the 2 laptops and I found that the main difference with the external ports was that 2 of the 3 USB ports on my laptop were USB 3.0 ports while all of the ports on my wife's PC were USB 2.

After checking which ports were which on my PC I found that I was always attempting to connect my Nuvi via one or the other of the USB 3 connections. I then attempted to connected the 3597 using the only USB 2 port on my laptop and it connected almost immediately.

Although I'll do a little more checking, it appears that at least on my 3597, it doesn't like to play nice with USB 3 and I would suggest that if anyone else is having a similar problem connecting their Nuvi to a newer computer they check to insure they are using an available USB 2 connection only.

Comments

  • alanb 557 Points
    I wonder if it the combination of Win 10 and USB 3. If I get time later today I will try my 3597 on the USB 3 port of my Windows 7 desktop and let you know the results.
  • t923347 533 Points
    It could be. FYI my wife's laptop is also running Windows 10 but with no USB 3 ports.
  • Boyd 2027 Points
    I have an HP WIndows 7 desktop system that has a couple USB 2.0 and a couple USB 3.0 ports. I think my 3550 has worked fine on either of these, but I never paid much attention to which ports I was using.
  • alanb 557 Points
    edited January 2016
    I just tried it on my WIndows 7 desktop and it connects fine on the USB 3 ports. It is a CyberPowerPC that came with Windows 10, but I had to back level to Win 7 because I couldn't get 10 to activate. They (Best Buy) said it would have to be sent back to the manufacturer to have a new Win 10 activation code flashed on the firmware and might take up to six weeks, I didn't want to be without a PC that long, so just wrote off Win 10 and put 7 on it. Last time I will buy that brand I guess, although as I was researching the problem, it was fairly common with several brands in the early days of Win 10. I was surprised to find out the Windows activation code on new computers is no longer provided on the DVD, but burned onto the motherboard. Of course when I contacted Microsoft about the problem, they offered to sell me an activation code/license for Win 10. I declined and decided to try to throw in the hard disk from my old Win 7 computer (that had a motherboard failure). It came up just fine. Of course it had to find all the new hardware and install drivers, but it did allow the the Win 7 activation to proceed (second of 3 allowed activations).
  • Boyd 2027 Points
    Best Buy has a pretty long exchange/return window, couldn't you just swap the whole system on the spot? If you are a Reward Zone member you have an even longer window. I remember exchanging an Asus netbook after almost 3 weeks use (because it was a dog). :))

    But that is the main reason I shop there, have frequently swapped things that were defective of that I just don't like. Usually I don't wait that long though. ;)
  • AndreyT 105 Points
    edited January 2016
    BIOS settings on many machines allow users to configure their USB 2 and USB 3 ports independently with regard to such things as legacy device support, power line voltage and so on and so forth. Which means that your issue with USB 3 ports might potentially be caused by some difference in their machine-specific configuration, not by the mere fact that they are USB 3. Many of us routinely connect our Garmin devices to USB 3 ports under Windows 10 and experience no issues whatsoever.
  • alanb 557 Points
    @Boyd ... it was a Best Buy online purchase. My local Best Buy store pretty much no longer carries any conventional tower desktop models, at least nothing in the configuration I was interested in. They have confined their inventory to the "all-in-one", laptop and tablet configurations. I wanted to save a few components from my old computer (like the hard drive so I could save my data), so I had to go the online route to get what I needed. By the time I received the unit and found the problem, they no longer had it in stock for a replacement. So the choice they gave me was return/refund with me paying the return shipping or send it back to manufacturer for repair which they estimated would take six weeks. I needed a computer pretty bad, was in the middle of the move to my new house, and just didn't have the time or energy to deal with it. So I chose to "take it in the shorts" so to speak and get the new computer running with my old Win 7 hard drive so I would have a computer to use. It is a nice enough computer, and I will probably some day buy a license for Win 10, as I tend to keep my computers until they die. This was my first purchase through Best Buy online and will be my last. I am not a Rewards member and probably never will be because I don't buy much from them.
  • Verified both my 2497 and daughters 2555 donot like usb 3.0 on and Asus x550ZA, the 2.0 port works fine.
  • Kevin_hutch 115 Points
    I have the exact same problem on two of my computers now both running W10 but I had it on the Toshiba as well with W8.1. I am yet to nail down which change I make that overcomes the problem and look forward to any suggestions.
  • privet01 230 Points
    edited March 2016
    I think that this is hints at one of the many possible problems/solutions.
    AndreyT said:

    BIOS settings on many machines allow users to configure their USB 2 and USB 3 ports independently with regard to such things as legacy device support.....................

    I've also seen posts on the mac users forum that indicates that some users upgraded OSX it simply did not install the legacy support drivers for the older usb 2 and 1 standards for the ports it detected as usb 3. Possibly with a win10 upgrade them same thing may have happened. But as with the mac users, there seems to be no rhyme or reason as to why some users have no issue and others do.

    There are physical differences between the number of pins in a usb3 connector and previous versions. USB 3 has 9 pins instead of just 4. Although older usb cables should still work with a USB 3 connector on your computer at the older standard, there is the possibility that a slightly banged up cable connector that works fine in the older usb may not in the newer usb as the tolerances are not there.

  • There are lots of replies pointing at using USB 2 ports verses USB 3s; however I have not seen any references regarding 32-bit verses 64-bit with Windows 10 O/S.
    When I downloaded Garmin Express I could not find a version specifically specified for 64-bit W10.
    If there is a link to the correct download, I would appreciate that direction.
  • t923347 533 Points
    edited March 2016
    AFAIK there is only a 32 bit version.
  • ruggb 181 Points
    I know this is a very old thread, but just in case anyone needs an answer, my 2 cents.
    I believe the issue is the drivers for the USB ports. USB 2 and USB 3 sometimes have different drivers. If you connect a nuvi the power pins supply power and the Nuvi goes into the mass storage mode. However, if the drivers for the USB 2 are not installed, it obviously won't connect. The data pins for USB 3 are not the same for USB 2. There is a different set of pins. So USB 3 devices could work well and USB 2 not so much.
Sign In or Register to comment.
↑ Top