This site uses cookies to offer you a better browsing experience. Find out more about how to manage cookies, or dismiss this message and continue to use cookies.

Garmin Express does not open

I am facing a strange problem.

I installed Garmin Express on a Windows 9 PC to sync with my Forerunner 910XT. It worked fine initially, but now Garmin Express does not load. If I click at the Garmin Connect shortcut ( or try to launch it through the icon in the start up bar) it does nothing. (Earlier Garmin Express splash screen used to appear immediately, and the program would launch)

Tried reinstalling it many times over, but with the same result.

Can someone help?

Comments

  • sussamb 792 Points
    I assume you mean 8 or 10 as I don't believe there is a Win9?

    Can you clarify exactly what the issue is. Does Garmin Express run on it's own?

    If it does and it's Connect that's the issue are you using Connect Modern or Connect Classic? If the latter that is no longer available and you'll need to switch to Modern.
  • tsrawal 0 Points
    I am sorry, yes Windows 8:-)

    Garmin Express does nothing, it does not load at all. It is supposed to load on its own when the ANT+ stick is inserted, but I know that does not happen many times, so I often open it using the Garmin Express desktop shortcut. After my present problem started, there is no way I can load GE. Thus there is no way to sync my Forerunner with Garmin Connect now. Hope I am able to explain the problem.

    Regards
  • sussamb 792 Points
    So you're saying your shortcut to Express isn't working? Have you tried creating a new shortcut or opening it via All programs, Garmin?

    If so the install may be screwed up somehow. You'll need to do a complete uninstall then reinstall.

    Try using the Microsoft FixIt Utility to completely uninstall Garmin Express.

    1.Go to the web page: [url]http://support.microsoft.com/mats/program_install_and_uninstall/[/url]
    2.Click the Run now button
    3.Click Run in Internet Explorer or download then open MicrosoftFixit.ProgramInstallUninstall.RNP.Run.exe1
    4.Click Accept in the license agreement
    5.Follow the provided instructions to select and uninstall the particular application


    When uninstalling Garmin Express select:
    •Garmin Express
    •Garmin Express Tray
    •Elevated Installer
    •Garmin Update Services (skip if not present)
    •ANT Drivers Installer x64

    This program will need to be run again for each item on the list to be uninstalled.

    Then install Garmin Express directly from http://download.garmin.com/omt/express/B/GarminExpressInstaller.exe
  • tsrawal 0 Points
    Thanks a lot sussamb

    I did that, uninstalled everything using fixit, and re-ran, and it still didnt work. I was frustrated, having wasted one full day trying to fix what looked like a trivial problem. Then I tried something very stupid, and it worked :-)

    I changed the location where the program is installed. Lo and behold! It is working now. Perhaps the software was leaving behind some orphan which even fixit was not removing. Or whatever, but it worked. Thought I must share, for the benefit of somebody else who might be stuck up in similar situation.

    Thanks again for all the help. I remembered the early days of Microsoft when every installation and uninstallation was a struggle :-)
  • sussamb 792 Points
    Good to know it's resolved :)
Sign In or Register to comment.
↑ Top