This site uses cookies to offer you a better browsing experience. Find out more about how to manage cookies, or dismiss this message and continue to use cookies.

HELP - dead after update with garmin express; NUVI 1690

Was happy 1690 user, but decided t update maps after 2 years. Garmin Express seemed to update software too - and said could only fit western europe on because of size. All seemed to go OK. HOWEVER
Now when starting it just freezes at the Garmin Logo - never gets to 'loading maps' or anything. So far I have tried:
- Off / On
- Hard Reset via 20 second press. Did seem to re-set as blanked out screen - but turn on gets to same place
- Let battery run down and re-charge
- Plug in to computer. It does start the device to Garmin logo and charges, but does not go to computer symbol and is not recognized as any sort of device by computer.... even tried hard re-set while connected.

HELP - Any suggestions? Moral for others: Unless maps are 5 years old keep away from map updates! (I have updated before without probles, though, to be fair)

Comments

  • stumped 0 Points
    OH - I also tried harad re-set via a 3 minute press too....
  • privet01 195 Points
    Did you watch the video in the August 18 post in this thread? forums.gpsreview.net/discussion/30021/nuvi-2595lmt-apparently-bad-connection-between-cable-and-unit-repair-recommendation#latest What you describe is one of the symptoms mentions for a USB port issue. If you are not using a Garmin cable, then that is one of the first things I'd try to get hold of. If you are using a Garmin cable, then try putting a little WD40 on the end of the cable that connects to your nuvi and connect/disconnect it a dozen or so times to clean off any possible corrosion.
  • alanb 424 Points
    When you say you did a "hard reset", are you following the procedure described in this Garmin FAQ?
    support.garmin.com/support/searchSupport/simpleCase.htm?caseId=%7Ba1f85d30-a65f-11e4-4df3-000000000000%7D&kbName=garmin#200205
  • stumped 0 Points
    Many thanks for these suggestion - but sadly no luck:
    - my finger hurts pressing bottom right while turning on and off and press-and-hold- but no change - just the Garmin Logo. Also tried a touchscreen pointer instead of finger.
    - I am using a Garmin USB cable, and have never had any trouble connecting before... and I had just connected fine the day before in order to do the map upgrade. I tried a different cable and different PC, but nothing seems to get past the logo or recognize the nuvi as a device.

    Any other suggestions?
  • stumped 0 Points
    ...additional info... if the unit is off, then plugging in the usb cable does make it come on, and show the garmin symbol, and stays on, so it does see the usb cable at least for voltage.
  • I've had exactly the same problem on two Nuvi 1690s recently. Like 'stumped' my wife and I were both happy Nuvi 1690 users for the last few years - more or less since the model was introduced.
    I have lifetime update subscriptions for both devices. I connected up my 1690 a few months back and ran an update, and that was the last I saw of anything other than the Garmin logo on that device. After some prolonged discussions with Garmin support, I (perhaps foolishly) accepted the offer of 30% discount on a new device - however no discount on the new accessories (mounts etc) which I needed to be compatible with the new device.
    On the off-chance that the problem had arisen due to a USB problem on my computer, I then ran a map update on my wife's 1690 on my PC at work. This appeared to proceed satisfactorily, and at least maps seemed to be functioning after the update. However her device wasn't then actually used in the car until about two months later (yesterday) when we were once again presented with a Garmin logo and nothing else.
    It now appears to be behaving exactly as mine did - switches on when connected to USB or when power button is pressed, and displays the logo, and stays that way until disconnected or power button is held down.
    I've tried the Garmin 'reset to factory default' procedure, and it does not work on either device.
    I'm about to re-open the matter with Garmin - their update package is evidently incompatible with the 1690, and causes it seemingly irreparable harm. I would strongly advise anyone with a 1690 and perhaps similar machines to be very wary of attempting to upgrade. There are some posts which refer to using Garmin USB cables - I'm doing that, they still have the Garmin sticky labels on...
    Stumped - have you had any useful support from Garmin?
  • privet01 195 Points
    I have not had to deal with Garmin Support in quite a few years. However I've always been happy with the support I get when I call them. As long as you keep them on the phone, they'll continue to come up with possible solutions. You might have to sit on hold for a while when they go off to consult with others, but it may well be worth the time.

    Support through email is a different story. If you read support forums regularly then you'll see how a issue described by one gets mis-stated, mis-read or mis-understood....... likewise for emails to garmin support. As well, you don't have the immediacy of saying "I've already done that".
  • Zemartelo 102 Points
    edited October 2016
    It looks like the map installation got messed up and the device doesnt boot anymore becuase of it.
    Was the map saved to a SD card or to the internal memory?
    If you could access the internal storage and delete the map file you should fix the problem.
    There is a program (I think its called updater.exe) and it allows to send an update file to the GPS via USB even if the computer doesnt recognize the device.

    I found the link;
    https://garminoregon6xx.wikispaces.com/Recovery#Forced RGN Install

    I have used this method to recover an Etrex and an Oregon, but I dont know if it will work with a Nuvi. I believe that it should work but I cant guarantee it.
  • Garmin Support also sent me the code for 30% discount, but have not used it yet as still not sure.
    Not sure about trying this rgn method - there is no way to remove the Nuvi battery so one of the steps is difficult!
Sign In or Register to comment.
↑ Top