This site uses cookies to offer you a better browsing experience. Find out more about how to manage cookies, or dismiss this message and continue to use cookies.

Garmin GPSMAP62s in not powering on

I have similar problem with my garmin GSPMAP62 s as is described in attached discussion
(https://forums.garmin.com/archive/index.php/t-12831.html)
I have tried all recovering steps adviced in the discussion without success.
Is there anybody who having more ideas how to proceed?

Br
Huba

Comments

  • privet01 145 Points
    Best not to compare your problem to another as "similar". If it doesn't match the symptoms given by the OP exactly, then you might hinder any readers in giving you the correct solution. Seemingly small differences in behavior frequently can be the clue to an entirely different problem/solution.

    So if this.............

    "Now, when I plug it into my PC USB it starts to power on (welcome screen), then slowly fades off. I tried to turn it on with it's batteries and no luck. I tried to turn it on with a new set of batteries (alkalines) and same thing, it starts to boot up at the welcome screen where it's loading waypoints, then slowly fades back off.""

    ........... is not what yours is doing, then let us know in your words what's going on.
  • Huba70 0 Points
    Ok. Just to clarify that my device has done this few times before already but I have succeeded to recover with the instructions but not this time.
    Starting from the beginning how I comes to this at this time
    - I tried to download new gpx-file into my device via USB (without batteries plugged if I remember correctly).
    - it succeeded but after that device did not start. It starts to load waypoints and then slowly fades off.
    - I followed the instructions (1-6) and removed recently added files -> no success
    - I tried the same without memory card -> no success
    - I tried the same with memory card so that I first removed gmapsupp.img
    - then in some point I tried also master reset but it fading also similar way
    - Now the situation is that I can get my device into mas memory mode by following the steps (1-4) but it does not start normally.

  • alanb 366 Points
    I have had this same symptom on my Oregon 550T, once when I had a corrupt GPX file and again when I had about 3 GB of Birdseye satellite images. Like you said, I was able to get it into mass memory mode by following the initial steps of a master reset. That allowed me to remove the offending files. After cleaning out the files, the unit would boot up correctly again. When I put the files back on the device (I had backed them up first), I got the same failure again. So I got rid of the bad files and it has been OK since.
  • Huba70 0 Points
    I removed all gpx files and I don't have any recently updated birdseye images in my device.
  • alanb 366 Points
    I would try backing up, then removing all added content, including map files, Birdseye, GPX, POI, etc. Then do a hard reset and see if the "clean" device will boot up. If it does, start adding the removed files back in 1 or 2 at a time and test. If the clean system won't boot, I don't know what else to tell you to try other than contacting Garmin support by phone.
  • Huba70 0 Points
    I have tried to remove files one by one but it does not help.
    I found that system.xml and Gamin_device.xxx (I don't remember the extension) were changed at the day when the problems appeared so those files might be corrupted somehow. But those files cannot be removed because then device does not start for sure. It might help if somebody could share similar files from working device so that I can make comparing.
  • privet01 145 Points
    By "fading" do you mean it appears that the batteries are going dead and/or it's loosing power?

    If so, I'd think you have the USB port problem where it doesn't have a good connection to the circuit board. This video was posted in another thread a few days ago....... https://youtube.com/watch?v=ixe0mxxji5A&feature=youtu.be IMO, it's a little long with small pics, but the information it gives is very valuable. I've never used them but SHARCNET-USA does have a good reputation. And their site is a valuable source of information for DIY'ers. You just have to decide if the cost to fix is worth the cost of replacement. A local TV repair place if you have any could do the same thing. But I doubt they'd be any cheaper. A vocational or community college might do it for parts only. But if a person learning skills to solder circuit traces isn't quite there yet, you are SOL for ever getting it fixed.

    If it were mine, I'd open the case and take a look at the usb port and it's connection to the board with a strong magnifying glass. But if you are not used to opening small electronic devices then that may do more harm than good.

    I don't think that cable issues or completely failed battery can be ruled out though. But I'm just an armchair quarter-back. <<grin>>
  • privet01 145 Points
    By "fading" you mean that it's like the power is going dead and the screen fades away to blank?

    Sounds like it may be the USB port no longer has a good connection to the circuit board. This video was posted in another thread a few days ago.... https://youtube.com/watch?v=ixe0mxxji5A&feature=youtu.be IMO, it's a little long with small pics (go full screen on a desktop), but very useful information.

    I don't think it rules out a flaky cable in combination with a failed battery, but the USB port being loose seems the most likely to me with the current info. I'd open the case and look at the USB ports connection to the board with a strong magnifying glass. But if you are not used to opening small electronics, that may be more harm than good.

    I've never used them, however SHARCNET-USA does enjoy a very good reputation. Their website does provide a lot of information that is valuable for a DIY'er as well as just simple troubleshooting.

    So if you decide it might need repair, then they are likely as cheap as a local TV repair shop if you have any around you. A vocational or community college teaching electronic repair will probably do it for the cost of parts. But if that kid learning to solder circuit traces isn't quite up to par, then the device is likely toast forever.

    Balancing the cost of repair over a new unit, you need to closely check the features your old unit has against the features of the new unit.
Sign In or Register to comment.
↑ Top