This site uses cookies to offer you a better browsing experience. Find out more about how to manage cookies, or dismiss this message and continue to use cookies.

64st not accepting maps

HI all,

I did a search to try and find this topic with no luck. I have been utilizing GPS MapEdit and MapUpload to create IMG files to load onto my GPSMAP 64st. I had to create and load a few different iterations as I tweaked zoom levels to get what I needed. At one point my unit froze and I had to do a hard reset. After booting it back up, maps will load and show as a gmapsupp file on the computer when connected by USB, but now do not appear on the unit when I disconnect. Any suggestions would be appreciated.

Comments

  • Boyd 1794 Points
    Not sure how much help anyone can provide since we know nothing about your maps and you have given us very little information.

    When you go to map setup on the 64st, what maps are listed? What maps are enabled? Make sure that your map is the only one enabled. If more than one map is enabled, it may prevent yours from showing.

    Can you test the map on another device? If not, how do you know that the map will work at all? Do you know how to install a map in Mapsource/Basecamp? I would suggest doing this for starters, so that you can check the map on your computer before sending to the GPS.

    This tutorial should help with that: https://www.gpsfiledepot.com/tutorials/how-to-load-.img-files-into-mapsource-with-mapsettoolkit/

    Also note that new devices like the 64st don't require that the map be named gmapsupp.img. You can use any name you like as long as it has a .img extension. This might help you keep track of different versions of your map.
  • Thanks for the input, I'm new enough to this that I'm still figuring out what info is needed/relevant. The maps are IMG files created from ArcMap shapefiles using the above software.

    Before the hard reset any new map uploaded would be the one to display on the screen upon power up. Now it not only doesn't display when I turn it on, but going into setup its not included in the list of maps at all. It might work on another device - if I have a chance I'll see.

    I have not tried Mapsource/Basecamp because this was working fine until the reset yesterday. I do have a few other maps on the device that I've changed the names on to keep track of. I just can't figure out why it will load onto the device as per the computer UI - there's a new gmapsupp file with the right time stamp there, but doesn't seem to exist anywhere on the device when I turn it on.
  • Boyd 1794 Points
    Well the simple answer is that something is wrong with the map. If it was a valid map file, it would show in the map setup menu. I don't really understand your confusion about "why it will load onto the device as per the computer UI". This seems completely irrelevant to me. There is no "computer UI" as you describe. It behaves just like any USB disk when you connect it to your computer, it might just as well be a USB flash drive. The fact that you can copy files to it really means nothing beyond the fact that there's a file on the device.

    Since you mention other maps with names that have been changed, I suggest that you back these all up to your computer and then remove them from the GPS. It will simplify troubleshooting if the new map is the only one in the Garmin folder on the GPS. If you have multiple maps that all have the same FID, that can cause problems.

    Really, this discussion is way beyond the scope of the GPSReview forums though. I'm pretty sure that I am the only person here that makes their own maps. GPSFileDepot would be a better place to discuss the "nuts and bolts" of making maps. It's a highly complex topic. ;) https://forums.gpsfiledepot.com/index.php?board=2.0
  • I'll check out the other forum.

    My apologies if I got the terminology incorrect. I hope I can be perplexed about why it shows there's a new file on the Garmin through the USB, but no map anywhere on the unit. Especially given that it worked yesterday.

    I have several maps made (all IMG files) including some older ones that have worked in the past and nothing makes it to the display. In fact everything is already backed up, I'm just afraid that if I take everything off I might not get it back on! I was hoping there was a setting (or something) that may have been shifted in the hard reset so I could avoid more complicated troubleshooting. Just looking for options.
  • Boyd 1794 Points
    edited August 2016
    The hard reset should change everything to the default. But I can't think of any reason why a map wouldn't be recognized due to that.

    I can only suggest what works for me, and I make extremely complex maps, some of which have been downloaded thousands of times at gpsfiledepot. If you can't check the map on another device, and aren't willing to install it in Basecamp so it can be checked on your computer, I just don't know what you can do. Those are the logical steps I would take, just to ensure my map files are usable.

    I understand the point that "it worked yesterday", but you can't get help from Garmin, because you are doing something they don't support (making your own maps). In fact, Garmin's position would be that you have violated their user agreement, because software like cgpsmapper and gpsmapedit depend on reverse-engineering Garmin's proprietary map format. This is specifically forbidden in their software license. Of course, many people make their own Garmin maps, and it helps sell GPS units. They know this, and generally look the other way, but they will only help you troubleshoot problems with their own maps.

    FWIW, you said your maps were made with GPSMapEdit, but that is only half true, I think. You will find that GPSMapEdit uses a different program, cgpsmapper, to create the actual .img file. The cgpsmapper author discontinued development of that program a number of years ago. This is a growing concern as time passes, because Garmin constantly changes their device firmware and this has the potential of breaking maps made with this old software.
  • nevw 37 Points
    You could download Javawa and see what it sees on the device. It also helps with changing the names of maps.
Sign In or Register to comment.
↑ Top