This site uses cookies to offer you a better browsing experience. Find out more about how to manage cookies, or dismiss this message and continue to use cookies.

EU map update disaster

Device: nuvi 3597
Software: v5.20
Garmin Express (Mac): v4.1.27.0
sd card: 16GB
present map installed: CN EU 2017.10 NTU (the full map; 45 countries)

This is a long story; I cannot possibly give all the details of this disaster.
My device may be bricked; I’m hoping someone has a solution for me.

Each attempt to install CN EU 2017.20 NTU fails; it “hangs” (simply stops downloading) at some - and various - point. Left for as many as 16 hours, once stalled, it never progresses. It’s not the app that freezes; it’s the download that stalls.
I have - despite the warnings - quit GE, shut down computer and device, and started over. (What else to do?) Several times - to no avail. It “resumes” at the same “place” - as indicated by the progress bar - but nothing further is downloaded. It remains stalled.

I have now successfully updated another nuvi (a 3590), by connecting to another computer and running Express. No problem-o.

So I connected the 3597 to this second computer, and the download gets to some (different) point, and hangs.

So I started the update/download over, this time choosing to install to computer only. The map was completely downloaded; no problem-o. I downloaded BaseCamp/MapInstall. And MapInstall has successfully transferred it to the device.

But this map is simply not complete. I can see some details - streets - missing. And the previous map has not been deleted.
In addition, myMaps now show:
CN EU NTU 2017.10 ALL
CN EU NTU 2017.20 (with several strange place names - even though I downloaded the full EU map. I don’t I have CN EU NTU 2017.20 ALL?)
EU DEM
CN EU NTU 2017.10 3D

photo Screen Shot 2016-09-21 at 15.30.01_zpsio8s78x8.jpg

I have purchased a new sd card (empty), but if I connect to one computer, I’m offered only Western Europe. When I connect to my other computer, I’m offered Central Europe. I’ve not attempted to download these map subsets; they aren’t useful - and I’m entitled to the full map.

And:
myMaps on the 3590 are now:
EU DEM
CN EU NTU 2017.20 3D
CN EU NTU 2017.20 Western EU

Why only Western Europe?
My device came with the full EU maps. The sd card is 8GB, and I did not choose anything but the full EU map. In fact, there was no choice; I was downloading the full map - but it arrived only as Western Europe.

I don’t know what to do.
I have a clone of my 3597; the device only - made before this attempted update - but not the sd card containing the CN EU NTU 2017.10 ALL map.
Possible solution: erase my device completely and restore from clone. Scary; won’t do this without some of you saying, “Go for it.”

Comments

  • I've just thought of something:
    Is the full EU map too large for a storage device which is FAT-32 formatted?
  • sussamb 765 Points
    edited September 2016
    No, the full EU map fits easily onto a 8Gb SD card, I use one in my nuvi. Difficult to advise without looking in detail but IF you have a full backup you could delete and then restore, whatever you do don't format it though. However a safer option would be to use the cloning technique to download the files first to a SD card and then transfer the files to your device and card. Just google cloning your nuvi.

    The normal cause for what you describe though is a device with a full memory. Check if it is full, and if so free up space by deleting unused voices, keyboard, text, EULA and help files. Since you're on a Mac also ensure the trash is emptied!
  • Thanks.

    "the full EU map fits easily onto a 8Gb SD card"
    Yes; this is clear.

    My question, however: "Is the full EU map too large for a storage device which is FAT-32 formatted?"
    But a device/card formatted FAT-32 cannot have a file greater than 4GB. Correct? So if the map is greater than 4GB, it won't install. Correct?
  • sussamb 765 Points
    Yes, but the full map isn't over 4Gb.
  • See my screenshot.
    The 2017.10 map - from April - is shown to be 4.24GB. Which I don't understand - if the restriction is 4GB.
  • Boyd 1954 Points
    Ramaprem said:

    "Is the full EU map too large for a storage device which is FAT-32 formatted?"

    I wouldn't worry too much about this until some point in the distant future. ALL of Garmin's devices are designed to use the FAT32 filesystem. They can't exceed the 4gb limit without breaking everyone's GPS.

    When (if?) the day comes that Garmin introduces a device with a more modern filesystem, that might point the way to a change, but it would have to be very gradual due to the huge number of devices that are currently in use.
  • sussamb 765 Points
    Ramaprem said:

    See my screenshot.
    The 2017.10 map - from April - is shown to be 4.24GB. Which I don't understand - if the restriction is 4GB.

    It's being reported incorrectly, it's under 4Gb ...

  • Boyd 1954 Points
    edited September 2016
    There's an old issue of calling a kilobyte 1,000 bytes (1k), when it is actually 1,024 bytes. So a megabyte is actually 1,048,576 bytes and not 1,000,000 bytes. And a gigabyte is actually 1,073,741,824 bytes.

    And if you do the math, a "4 gigabyte" file would be 4,294,967,296 or 4.29 gigabytes which is pretty close to your number. This is one of those things that has confused everybody for many years, and as files and disks get bigger the error is more significant. :)
  • @Boyd:
    Thanks for that. It's info that I "know" - but forgot to connect the dots.

    Update:
    Regarding the 3590:
    The device was 93% full - having 450MB free. Deleting some unused files saved only an additional 50MB.
    I later discovered that the 2017.10 map wasn't even on the card; it was on the device! Strange - to me. I guess because it fit?

    To repeat from above, GE had installed only the Western EU map, not the full map. Connecting again, this time I got to Map Options>Change Map (Change the map that is currently on this device).
    I was given the choice now to install the full EU map - which was done successfully.

    Regarding the 3597:
    The device had 1.6GB free; I deleted a few files - which saved an insignificant amount of space.
    Then I tried sussamb's advice about installing directly to a card. Nothing works.
    Here is what I've done (following the directions to the letter):
    using a blank 16GB FAT32 sd card, I created a folder Garmin on the card, and copied the file GarminDevice.xml from the 3597 to this folder. I disconnected the 3597, and used GE to try to install the map onto the card.

    The card is mounted. GE doesn't recognize the card as a device under any circumstance.
    I've now plugged the card into the computer's internal card reader, and into an external USB-reader. Nothing. Did the same with a second computer. Nothing.
    I've done all the same with a 16GB USB thumb drive - again, as per the instructions from the POI site which I found using sussamb's advice. Nothing.
    I've also used Garmin Map Update app, with the same result: nothing.

    In every possible configuration, the card/flash-drive is mounted - but not seen as a device by Garmin's software.

    I sure can use your help.
  • sussamb 765 Points
    edited September 2016
    Hmmm. I wonder if the file is corrupted? Delete it on the device then power cycle your nuvi, which will recreate the file. Now try again.

    As for your 3590, if you have a part map installed then Express will insist you update that map first before giving you the option to change regions/full map. Why that is so I have no idea ;)
  • Ramaprem 111 Points
    edited September 2016
    Followed your advice - and installed the newly-generated GarminDevice.xml file to both the sd card and USB flash-drive. Launched Express>Add a Device (for the umpteenth time).
    Result: same-same. No device recognized. :((

    Possible that I need to use an 8GB card?
  • sussamb 765 Points
    8 or larger should work. ... maybe the connector/device is faulty?
  • Nothing - including the various cables used - is faulty.
    I've tried various USB ports, cards, USB flash-drives, computer ports, card readers...
    The devices all work; they perform in every way. I can read and write to all.
    Garmin's software just isn't seeing it/them as a "device".

    And I'm going crazy - something I cannot afford to do.
  • alanb 424 Points
    edited September 2016
    The only thing I can think of that would cause all of these symptoms is if there is something wrong with the GarminDevice.xml file. Unfortunately sussamb's suggestion to delete and recreate the file didn't help. If you know someone who has another 3597 with your same map version, you could try to compare the two GarminDevice.xml files line-by-line to see if you can identify what might be missing or incorrect. But your best bet is probably to contact Garmin support by phone so they can remotely access your device.

    Does Garmin Express actually show the device, but just not offer the updates, or is the device completely missing in Express? If you log into my.Garmin.com, is your 3597 shown in the device list? If it does not show up in either place, there is a back-door way to manually register the device through my.Garmin.com. Don't know if that would help, but is worth a try.
  • I did it. I nailed it.

    I gave up completely using the cloning technique that sussamb mentioned. That process was going nowhere fast.

    So I finally went back to the normal way of updating one's map. I opened Express, and saw that a map update was available. Nothing new about that. At various times - in the last 10 days - I've been offered an update to the full EU map, sometimes to Central EU, and sometimes to Western EU. Each time that I was offered the full update, I tried it - and it failed. Each time that I was offered the map subset, I declined. I never understood why I was being offered a subset of a map. I've never downloaded the Central EU or Western EU map, and I don't even live in central Europe. So it never seemed the thing to do: it looked like it would lead me to grief in the future.

    The map update offered this time was to Central Europe. Express seems to have randomly chosen a map to update, each time I connect in the last days.
    But this time, I accepted it. However – Express being Express – the very next screen said that the full map of Europe will be downloaded to my sd card. (I used a blank sd card.) So I clicked on continue – not having any idea which map, if any, would be (successfully) downloaded.

    A new map was completely downloaded and installed. After disconnecting the device from the computer, I – with trembling hands – turned it on and clicked on myMaps.
    And there they were: the new maps were installed.

    The map is 4.28GB in size; it can’t get larger. Something, it seems, has to change. And soon - no?
  • sussamb 765 Points
    Wow, well done :)

    And yes, the map can't get bigger. What will happen next update only Garmin knows :)
  • BTW, thanks to all who gave their time to help.
  • It's possible that this map has already been "dumbed down"; I seem to have far fewer POI than older versions.

    A question regarding old files:
    Can I (should I) delete the highlighted files? They are quite old. Are they useful/needed? Could they be the source of Express' "confusion" regarding my updates?

    The contents of my nuvi's Garmin folder:
    photo device g_zpscsxqjzx1.jpg

    The contents of my nuvi's .System folder:
    photo system_zpsbsvvtg1x.jpg

    Thanks.
  • sussamb 765 Points
    gmapbmap and gmapdem shouldn't be deleted, they are the basemap and DEM map and aren't updated.

    The old gma files can be deleted as they are authentication files for older maps. You can also delete all the files in the Garmin folder, the only one that needs to be there is the .xml file, but even if you delete it it will be recreated when you power on your nuvi.
Sign In or Register to comment.
↑ Top