This site uses cookies to offer you a better browsing experience. Find out more about how to manage cookies, or dismiss this message and continue to use cookies.

POI Icons

Hi there,

First post.

I have a Nuvi 2589. I have found that POI icons tend to clutter up the screen at times and I can't seem to get rid of them. I unchecked the box to remove upahead places, but it doesn't remove them all. Out of the 6 categories, 2 always remain. If I click the x in the map view, the icons still appear on the map.
Is there a way to fix this. I would prefer to remove all the POI icons.

Thanks for any help.

Comments

  • sussamb 664 Points
    Have you also turned off the relevant map layers? It should be in Map & Vehicle, Map Layers
  • Yes, that's where I unchecked the Up Ahead places.
  • sussamb 664 Points
    Strange then ... are these POIs you've loaded yourself (custom POIs) or part of the map data?
  • The POI's came with the unit. They are Rest Areas, Restaurants, Gas Stations, Banks &ATM's, Lodging, and Parking. Three of those you can select to be displayed in the Up Ahead area. You must select three of the six.

    If you select Restaurants and Gas Stations your screen will be cluttered with many icons. I choose Rest Areas, Parking and Banks because there are fewer icons than the others. Still too many if you go through a large city.

    I'd like to be able to turn some on when I want to, but also to remove them all when I want them.
  • sussamb 664 Points
    Well that's weird. If I remove that layer they all disappear.

    Have you done a full shut down or just put the device to sleep? Try a full shut down if you haven't, long press of the power button until you get the Turn off the device? message and select Off.

  • This unit was in the mail for 7 days, so I assume it was powered down. But, I'll give it a try the next time I'm on the road.

    BTW, when you say "if I remove that layer" what do you mean by that? Do you do that in the settings?

    Cheers
  • t923347 406 Points
    Yes, it is in Settings.

    Tap Settings - Map & Vehicle - Map Layers and uncheck the Places Along the Road box. Finally Save the change.
  • Trip layers gives me Up Ahead Places, Traffic, and Trip Log. Up Ahead places gives me
    Customize Up Ahead which just allows you to select the three things you want to show up in the Up Ahead area.
  • sussamb 664 Points
    Uncheck up ahead places, I thought you said you'd done that though?
  • Done that. What that does is turn on or off the display of the three selected choices that I mentioned previously.

    There is no setting that will allow a map with no icons. I thought there might be a workaround like using the POI uploader to upload a file with no icons, or modify a system layer file to do the same.

    Thanks for your patience.
  • sussamb 664 Points
    edited November 2016
    Okay, but normally you wouldn't get any icons with that unchecked, hence my comment to ensure you've done a complete shut down since you changed the setting, rather than simply putting it to sleep. Out of interest which are the two that remain (from your first post)
  • There are six choices. Three always have to be in the Up Ahead area.
    In my first post,I made a mistake when I said 2 always remain. I should have said three always remain. You start with three in the display area. You can change an item in the display area by selecting one of the three that are not being displayed. But that's all. You cannot unselect any one ...you just replace one. And if you turn off the display, the icons still appear on the map.

    I rebooted the unit as you suggested, but it didn't change anything.

  • The problem is that when you turn off the display, the sidebar with the selections disappears but the icons remain on the map.
  • I just talked to Garmin and they said to make a suggestion to their engineering staff, so i guess I'm stuck with those icons. Thanks for your help.
  • sussamb 664 Points
    edited November 2016
    Then yours clearly works differently to mine. Just a final thought. .. you are sure you've been unchecking the places along the road map layer rather than checking it?

    I ask again because the up ahead sidebar is separate from selecting the relevant map layer. I have the map layer for places along the road turned off but use the sidebar when I do want to know what's up ahead. If that sidebar isn't selected nothing shows on the map, the three items I've selected only show when I activate the sidebar.

    The normal complaint with Garmin POIs is that they no longer show up on the map. Somehow you have the opposite issue.
  • I was an electronic technician for many years. Believe me, I know how to check and uncheck a box. This unit is not that complicated.
  • sussamb 664 Points
    edited November 2016
    Well you wouldn't have been the first to do it the wrong way around so worth checking as something isn't working correctly. Reviewing this thread I'm still not sure exactly what you've done/not done as there is confusion in some of your statements. There are two places within the Map & Vehicle menu that affect what is displayed.

    One is map layers. If in Map Layers you deselect Places along the road nothing should show on the map. Then in Map tools you can check or uncheck the Up ahead map tool. If you uncheck that you don't then get that option when you tap the menu icon bottom right in map view.

    If yours isn't working that way then the final option would be to master reset your device.
  • I tried a Restore and reset all the settings. Tomorrow I'll take it out for a drive. I don't know if that's what you meant by a master reset.
  • sussamb 664 Points
    Master reset instructions are here.

    Make sure the device's battery is charged before you begin. You will need to unplug the device from power and turn it off completely (not the stand-by mode).

    To turn it off completely, while the device is on, press and hold the power button until you are prompted on the screen with the message "Turn off the device?". If you touch the "off" button on screen the device will shutdown completely.

    Power on the device
    When the first copyright screen appears press and hold the lower right hand corner of the display portion of the touchscreen
    Remove your finger from the touchscreen when "Erase all user data?" appears
    Touch Yes
  • sussamb 664 Points
    Sorry should have suggested you back up your data first as you'll note in doing the reset all your data is deleted.
  • I'll try the master reset later. BTW, you have used the phrase " Places along the road"
    a couple of times. I don't have a box that says that. Mine says "Up Ahead Places" and has an arrow that leads to "Customize Up Ahead".
  • sussamb 664 Points
    Ah yes, sorry, difference between certain locales ... Garmin mix it up but it's the same thing. There is the item in Map layers (places along the road on mine) as well as Traffic and Trip Log. Then there is the 'Up ahead' sidebar that you access via the menu item (sometimes referred to as the 3bar icon) bottom right on the map screen. Yours may well be called something different.
  • It looks like the Restore did the trick. The only issue I have now is the unit is showing the route I've travelled in a faint blue line. That's probably a setting I haven't got to yet.

    The next thing I'm going to try is to turn on the Up Ahead setting to show the icons and then turn it off again to see if they go away. I can always Restore if I have to.

    Thanks for the help.
  • sussamb 664 Points
    Great. The faint blue line is the trip log, which you can switch off in Map Layers.
  • Boyd 1794 Points
    mattspop said:

    It looks like the Restore did the trick.

    Do you mean the "restore" option in the Nuvi menus? The only thing that does is set all the options for that particular menu back to their defaults.

    Or did you mean that you did a master reset as described by @sussamb?
  • I didn't do the master reset. I did a Restore, but I don't know which menu I was in. I thought I was restoring everything. I suspect it was in the Map & Vehicle menu but I can't be sure.

    Anyway, it seems to have fixed everything. I unticked Up Ahead and the icons vanished and when I reticked the box they appeared.

    I switched off the Trip ...in Map Layers and the blue trace is gone.

    So it looks like everything is working like it should. Thanks for the help.
  • Boyd 1794 Points
    Glad you got it fixed. But from what you describe, the problem was that you had some menu option wrong on the nuvi, since all that "restore" does is set the menus back to their factory default.


  • Do you mean the "restore" option in the Nuvi menus? The only thing that does is set all the options for that particular menu back to their defaults.

    Or did you mean that you did a master reset as described by @sussamb?


    I don't know how the Restore function is implemented in the Garmin software, but the Kansas City support tech and I just went through the same tests as I did with sussamb.
    The settings are not very complicated. I suspect a software glitch.
  • Boyd 1794 Points
    As they say, "all's well that ends well". :)
  • True dat. :)
Sign In or Register to comment.
↑ Top