This site uses cookies to offer you a better browsing experience. Find out more about how to manage cookies, or dismiss this message and continue to use cookies.

Montana 600 Waypoint Limitation and Issue

I use a Montana 600 and have developed a serious issue that Garmin cannot or will not resolve. I have 980 saved waypoints and the unit is supposed to allow up to 4,000 waypoints – that is less than 25% of the rated capacity. At some point, I reached the threshold of the unit’s capability which is considerably less than 980 waypoints! Now when I use the Waypoint Manager function and select any waypoint greater than “T” the unit gives me a blue screen of death and freezes. The only way to reset the unit is to pull the battery as the on/off switch does nothing once it freezes. Garmin told me to reduce the number of waypoints because all the Montana-series handheld units have the same issue. Does anyone else have this issue? Is there a fix for it because it doesn’t look like Garmin is going to help me after several weeks of communication with them over this issue? Also, they told me not to use any BaseCamp waypoint icon that is not available on the Montana. The Montana only has about half of the icons available on BaseCamp.

Comments

  • Boyd 1781 Points
    edited November 2016
    Have had a Montana 600 for a number of years, but never used anywhere near that number of waypoints so I have not experienced this problem. If you don't get a response here, I suggest you visit the GPS section at forums.groundspeak.com. This is where geocachers discuss gps devices, and they are more likely to have some experience with large numbers of waypoints.
  • sussamb 658 Points
    edited November 2016
    Good idea although geocaches have a separate limit, rather than the 4000 waypoint limit, so geocachers may not be able to help.

    @BDSUSA Looking at the Montana wiki there is no mention that I can see of anyone having issues with the waypoint limit of 4000 and like Boyd I've never run into an issue. Are you sure you don't have more waypoints, for example waypoints within routes? If you really only have 980 waypoints and are experiencing freezes I'd try a master reset to see if that resolves it. Note you need to back up your data first.

    ◦With the Montana powered off, press and hold the top left corner of the screen (while held in portrait mode) and press the power button.
    ◦The Montana will begin the boot process.
    ◦When prompted "Do you really want to erase all user data?", select [Yes]

    Incidentally I assume you're running an up to date software version? If not that could also be worth trying.

  • Boyd 1781 Points
    The curious thing is (taking him at his word), Garmin apparently acknowledged that this is a known problem with no real resolution….
  • sussamb 658 Points
    Yes but we know sometimes Garmin support get it wrong ...
  • This is what I have done so far some of which was directed by Garmin –
    • Deleted all the gpx files on the unit
    • Deleted all maps and reinstalled
    • Cleaned up waypoint list to ensure there were no duplicates
    • Removed all dashes from waypoint names
    • Loaded waypoints on internal storage only
    • Loaded waypoints on external micro SD card only
    • Loaded only waypoints with all tracks and routes removed
    • Ensured I had latest updates for Montana and BaseCamp
    • Preformed a Master Reset
    • Tried waypoint list (micro SD card) in another Montana with the same results
    • Removed BaseCamp and reinstalled
    • Ensured on Montana specific waypoint icons were used as BaseCamp has many icons that are NOT available on the Montana
    • Sent Garmin my waypoint GPX file (apparently, they had the same problem I am experiencing)

    Garmin even tried to sell me a refurbished unit for $160 which would not have resolved the issue.

    This is one of the responses I received from Garmin, “If you have fewer waypoints on the device does this happen? If you only had say 10 waypoints on the unit does this happen? There is an issue where the Montana devices can shut down if more than 500 waypoints are loaded on it. Simply reducing the amount of waypoints loaded to the device will fix this. Yes, for the time being the Garmin solution would be to reduce the amount of waypoints on the device, and yes, this is true of all of the Montana devices.”

    It is unfathomable to think Garmin advertises its Montana-series units with a capability of 4,000 waypoints when in fact it will only function with less than 500 waypoints! So, if they know they have this problem why don’t they fix it!

    I've spent years using the Montana with countless hours on the ground hiking and marking waypoints and deleting these waypoints is not a solution!

  • In the Map mode on the Montana all the waypoints are visible; all waypoints are visible and useable in BaseCamp; all waypoints transferred to Google Earth with no problem. The Waypoint Manager is the culprit which leads me to believe this is a Montana-specific software issue.
  • truckinguy 110 Points
    edited November 2016
    Did you check over at the Geocache fourms? those guys are ace's at gps use.. you might need to change the file setup in storing or naming,etc. something simple. It may be the way you are doing it. I had a lot of my many ( not 4000 but) WP's on.Custom POI that is in my Montana's menu..organized in albums,etc. I used a quality SD card as well to store maps etc. to free up space in the unit.
  • This is the latest response from Garmin: Thank you for contacting Garmin International. I apologize for the frustration this issue has caused. Unfortunately when a large number of waypoints are installed onto the Montana device it can cause this issue when attempting to scroll down through a large number of waypoints in the Waypoint Manager. There are a few workarounds for this however that will prevent the unit from freezing like that and allow you to get to the waypoint you are looking for more quickly. While in the Waypoint Manager you can switch back and forth between sorting alphabetically or by distance from your current location so that you do not need to scroll down through hundreds of points to find what you are looking for. Another option is to search based on a specific location or even search by the name of the waypoint to find it. All of these options can be found by pressing the menu button (three straight lines) while in the Waypoint Manager or after selecting Where To? and then choosing Waypoints. Again, I'm sorry for the problems this has caused but I hope using these other methods for accessing the waypoints you are looking for will resolve this.
Sign In or Register to comment.
↑ Top