This site uses cookies to offer you a better browsing experience. Find out more about how to manage cookies, or dismiss this message and continue to use cookies.

Can't update maps on 5430T-LM (SmartGPS Eco)

When I go to update maps in SmartGPS web interface, it always tells me that "plugin not installed". I have tried it multiple times on both my Windows 10 and Windows 7 machines with multiple browsers - Chrome, Firefox, x64 and x32 versions, but no luck. Does anyone have this issue? Magellan support is no help with their robot response. I feel like I've been shafted with so-called "lifetime map updates", which worked 2 times and now their site is broken and no one is bothering to fix it.


  • gawettla 181 Points
    I am having a similar problem with my 5390.
    They were having some website problems, and now I think they are having software problems.
    I can get connected to smartgpseco, and the software sees my GPS, but it wants me to pay to update my maps.
    And when I try to transfer some favorites to the GPS, the software fails to transfer to my GPS.

    I am considering switching to a more reliable GPS vendor.
Sign In or Register to comment.
↑ Top