This site uses cookies to offer you a better browsing experience. Find out more about how to manage cookies, or dismiss this message and continue to use cookies.

Montana 680T not showing as USB.

Hopefully someone will have a suggestion as I think this will be a case of "the more I scratch it the more it bleeds!"

Noticed my new 680T was not being safely removed under Windows 10 when I wanted to disconnect. The 'Safely Remove' icon would not show the Montana being disconnected and about thirty seconds later it would be available to click on to disconnect again. Have pulled the lead a couple of times as I thought it must have disconnected. Pulling the lead did not turn the GPS off and it was unresponsive with the USB symbol showing, plugging in the USB lead again caused the Montana to boot directly into normal operation and not USB

Thought I better have a look at this and already had a backup as I'd also had a funny on it with it doing an unprompted partial reset the day I got it. Thought USB removal might be a Windows problem so tried a recommended programme 'usbsafelyremove' but that didn't work either.

Now it's got worse needless to say.

Plug the USB lead in and the SD drive is recognised but not the Montana, Garmin Express does not start automatically. Start Garmin Express manually and it crashes with a 'contact Garmin if the persists' error - it does. Have GE running when I plug the USB in and it does not recognise the Montana.

Strangely the Montana still boots when not connected or when rejecting mass storage in 'spanner' mode.

I have a flash drive tester but cannot get at the drive, either to test or restore the backup.


Any thoughts on what to do, before returning it would be welcome .

Comments

  • Chris_Sav 58 Points
    Think it's well screwed unfortunately.

    Device appears under devices and printers as USN mass storage when plugged in, troubleshooting just says may not work under USB3 tried a USB2 port and get the same and 'not fixed' so no help there

    Removed SD card and that comes up as an empty drive OK.

    Unplug USB lead:
    Sometimes montana turns off
    Sometimes boots up as if power cradled,
    Sometimes totally seizes.

    Looks like an RMA
  • Chris_Sav 58 Points
    Usb failure might be a known problem.

    Looking at

    https://garminmontanagpsr.wikispaces.com/Recovery#Forced Mass Storage

    And

    https://garminmontanagpsr.wikispaces.com/firmware#Firmware History

    Second one mentions USB not being recognised. Anyone tried forcing a load or master reset?
  • Boyd 1703 Points
    Wow you are not having very good luck with Garmin. :(
  • Chris_Sav 58 Points
    After the experience with the ill prepared 276CX this has not repaired my thoughts on Garmin's competence - far from it!

    What do I know now as things have moved on very late last evening, cat got impatient and went to bed without me!

    680T does not get recognised as a USB drive (ver 2.60 was supposed to fix this) in my normal USB3 ports. Diagnostics suggested a UDSB3 problem.
    680T did not get recognised in a USB2 port on the same machine.
    My Drivelux 50 and my battered 3790T both perform exactly as expected on my machine, updates to 2017.30 fine yesterday.
    Plugged the 680T into my old PC that 'erself uses which is USB2 and up comes the 680T as a USB drive!!!!
    Repeat test on my machine - no joy.
    Plug 680T into the old mahine again and bingo! connects / ejects fine.
    Run a read drive test on the 690T flash and it passes.

    What do I do now is the question?

    I'm contemplating blatting the flash in the 680T and doing a full read/write test on it and follow that with a clean RGN recovery install re the links above. Better do some reading first though!
  • sussamb 591 Points
    Is this a new device? I'd take it back ... and get a replacement.
  • Chris_Sav 58 Points
    edited January 7
    Hi, yes, brand new, week old, replacement for the 276CX. Have emailed Garmin and the suppliers before proceeding.

    As Boyd said, not my lucky day! Just a little itchy as I have just returned one and the fact that I can see Garmin saying it is a P.C. problem because it works on my old P.C.
  • privet01 132 Points
    For the last two years or so I've seen many posts in many different help forums concerning issues with connecting to various devices including Garmin. The common things seem to be a device that doesn't use usb3, a new computer that has usb3 and a new OS whether OSx, Windows, or Linux distro.

    Essentially they have the same issue you are seeing, the device won't show on the new computer, but will on the old computer. Seldom have I seen any resolution other than one day it magically started working after much tinkering and cussing.

    The suggestion/fix that I suspect is close to solution was on an Apple help forum. It boiled down that some new computer which had both usb3 and usb2 plugs the install programs were only installing usb3 drivers. And the only reason some old devices worked and other didn't was that they didn't have the strict demands that others did for their communication.

    But I've never experienced any of this issue with my computers, so I'm only relating perceptions I've gotten from reading the posts of others.

  • Boyd 1703 Points
    I agree that we have seen a lot of Garmin vs USB issues here in the forums and I don't have an answer. Seems like they are usually on Windows 10 machines. My PC is still on Windows 7 and I have not seen problems. But I don't have any new Garmin devices either. :)
  • Chris_Sav 58 Points
    edited January 7
    New to me but yes thanks!

    Mine has all those symptoms, mostly USB3 and a couple of USB2 ports though troubleshooting suggests USB3 drivers, also Windoze 10 Pro 64 bit, year old Scan 3XS gaming machine, very high spec.

    Works on Windoze 10 home machine that is nearly ten years old and only USB2.

    No reply from Garmin or suppliers so doing other bits and bobs today like trying to upgrade my cr@p phone broadband by interleaving services!
  • privet01 132 Points
    edited January 8
    It's not unique to Windows. One of my first exposure to the was a person in the Garmin forums with new macbook and a recently installed OSx upgrade. I think that was three years ago. But to this very day the issue is still happening. And it's not just Garmin devices. The biggest problem though in solving it is that not everyone has the problem, even though they have similar or even the same hardware and software. In addition most people posting this issue never follow up with additional post to say yay or nay as to whether suggestions helped.
  • truckinguy 57 Points
    I own a 680T now... with win 7... my win 7 see's it and the sd card fine.. but when I disconnect it stays in the usb mode.. I have to disconnect the battery for a second then it will be shut off. Works fine other then that.
  • Chris_Sav 58 Points
    That's exactly how mine started off.

    Still waiting to hear from Garmin or supplier here before possibly proceeding with RGN low level re-install.

    Situation now is still the same. USB3 machine only recognises the SD drive not the main drive though 680T shows the USB logo, cannot normally disconnect, reboot PC and the 680T goes into normal powered mode NOT mass storage. USB2 machine 680T works normally and fine.

  • Chris_Sav 58 Points
    Got fed up off waiting this morning so completed an RGN install on the 680T (poor instructions) from my old machine, made no change whatsoever. At least I know I have a clean install which means I cannot cure it now.

    Will advise when I hear from Garmin as unsafe removal of USB device is playing Russian Roulette.
  • privet01 132 Points
    Most tech people willingly allow you to believe that pulling your usb drive without doing a "safe removal" will corrupt the data. But on these Garmin devices and things like usb thumb drives, this is not true since the days of winXP.

    Every device has a description that is read every time they are connected. One of the descriptions is "removal policy". For these devices, the default is "3" which means "Expect surprise removal". When the OS sees this, it disables write-caching.

    Write caching is a way to speed up the transfer of information of these devices when used for heavy IO operations. If you have a true external drive or certain other device that normally will stay connected via the USB port, then it's Removal Policy will be a 1 expect no removal, or 2 expect orderly removal. Then write caching will be on for that device only and you must use safe removal for it.

    This is one of the things PC techs are willing to let others believe because it can save them from having to find the real problem which frequently will solve itself. Though in your case it's not.

    I'm not sure why you are focusing on the device. My suspicion is your new machine.

  • Chris_Sav 58 Points
    Thanks for the suggestions but I am still focusing on the 680T.

    My PC works fine with my Drivelux 50 (2016) and my 3790T. I have been down the route of installing the latest Garmin USB drivers as well.

    Have now heard from Garmin with forced USB mode suggestions that I have already tried.
  • privet01 132 Points
    Might try different cables. Even among Garmin cables there are some differences in the use of resistors on bridging some pins.
  • Boyd 1703 Points
    edited January 10
    Might try returning it and just use your phone. >:)
  • Chris_Sav 58 Points
    Phone costs money!! and I like to spend my pennies on devices, not British Telecoms!!

    Tried several cables & several ports, tried uninstalling the USB devices, tried driver updates but DVMR tells me I have the best ones. Still researching the USB 2 compatibility side of it.

    Enough for now!! dinner time.
  • privet01 132 Points
    I hope you'll stick with it and let us know what solves it.

    In all the years I've seen this issue reported in various posts, the ones the most similar to yours seem to give up.

    I'd even go so far as to try and connect it to other pc's and macbooks that are on the latest and greatest version of their hardware and software.

    But as I mentioned, I've never had the issue myself but it does interest me as to the why. I tend to think it a case of older tech not being handled correctly by the newer tech every time.

    Just because they support the same standard doesn't mean they won't fumble the handshake, just like sometimes I go to shake someones hand and they don't quite have the same grip. And it feels odd and awkward<<grin>>
  • Boyd 1703 Points
    Chris_Sav said:

    Phone costs money!!

    There are plenty of apps that store the maps on the phone, just like a Garmin GPS. The maps can be loaded at home on wifi and there will be no data charges when you use the app.
  • Chris_Sav 58 Points
    Not enough 'G's in my phone
  • Chris_Sav 58 Points
    Arranged to meet a friend this evening who has a laptop with USB 3.0 on it will try that.

    Not necessarily definitive if the 680T works, but a definite answer if it does not!
  • Chris_Sav 58 Points
    edited January 11
    Result of last night's test was that my friend's laptop recognised the 680T but it refused to disconnect cleanly and I had to pull the battery.

    His machine had one USB port (black) with DVMGR showing a USB 3.0 hub and a USB 2.0 hub, slightly config different to mine which is a USB 3.1 hub (not 3.0 as I previously stated). I forgot to look in the port to see if it had both banks of pins for USB 3.0.

    Thus it's fairly safe to say the problem lies in the Montana. My contemplation is to send it back regardless at the moment.
  • privet01 132 Points
    edited January 11
    The trial and error stuff really won't allow you to determine who is at fault unless you get to the point where you have one 680T that will connect, and yours that won't connect to the same system.

    To me it just suggest that the newer computers and OS's can't handle some of the older devices properly .
  • privet01 132 Points
    Do you have a micro sd card in it?
  • Chris_Sav 58 Points
    It behaves differently with or without the microSD card.

    In garmin serial mode

    Without the SD card I just get the empty drive, no montana under Windoze and nothing to disconnect, 680T thus frozen.

    With SD card the SD drive shows but no montana, safely disconnect the SD drive and the montana reboots on its own as if in power cradle not mass storage. Tried same test with drivelux and it goes back into mass storage.

    Just in process of digging deep in device manager and showing hidden devices under USB devices. The Montana shows there but with errors "Device USBSTOR\Disk&Ven_Garmin&Prod_Montana_Flash&Rev_1.00\0000ea778738&0 could not be migrated". In process of investigating that and compatibility mode for the driver install but out of time for today I'm afraid.

  • Chris_Sav 58 Points
    What is further weird is that having left the montana connected as if in powered cradle I shut down the PC and the montana went into mass storage mode!
  • privet01 132 Points
    edited January 11
    Well maybe you are right. There may be something up with the 680T.

    Without the sd card, it should show up as a removable storage device in windows. With the sd card you should see two devices show up.

    As for the mass storage mode after shutdown, I'm not sure if that's weird or not. All my devices, nuvi, edge, gpsmap and others do unexpected things when I shutdown and they are connected. I just haven't paid attention to them close enough to say what mode they go in.

    I feel that if you get Garmin on the phone, they'd find the issue or they'll get you another. But if it's still replaceable with the vendor, then you might better swap with them so you get a completely new warranty.

    For the record..... I use win10 64bit on a system I built seven or eight years ago. I've not had any usb issues with Garmin devices from my oldest... a gpsmap 76 csx and the newest being a nuvi 57 LM I also use a late 2008 Macbook pro and no issues there either.

  • Chris_Sav 58 Points
    It's got me beat.

    The device could not be migrated message appears a lot when googling legacy usb on usb 3.0 but no one has a fix. I even tried disabling the USB 3 support in BIOS. Every test I ran with the Drivelux and/or 3790T alongside and every test the drivelux and/or 3790T worked and the montana did not.

    So it's going back.
  • sussamb 591 Points
    Probably best. Had no such issues with my Montana 650
  • Chris_Sav 58 Points
    sussamb said:

    Probably best. Had no such issues with my Montana 650

    No my 650T worked fine before it was stolen as did the abortive purchase of the 276CX.

    Think I am going to wait a while before buying another new one, going to keep an eye out for a cheap used 650T or Monterra to tide me over.

  • Boyd 1703 Points
    edited January 12
    Here in the US, I see a factory refurb Montana 600T for $330, less than half cost of a 276cx. Since you are determined to stay with Garmin, that should be a safe bet (although IIRC, you were not completely happy with battery life on your Montana). Does Garmin offer refurb units on your side of the pond? In the US, they have the same warranty as a new device.
  • Chris_Sav 58 Points
    Yes we cab get refurbs thx.

    Montana internal and a set of AA's gave me a good eight hours which is fine for a day's classic bike rides.

    276CX battery life was brilliant, I hope they will fix the problems.
  • Chris_Sav 58 Points
    Finally heard from Garmin after five days! They have offered me a replacement refurbished 680T in place of my ailing new one! Good job it's already on its way back to the retailer.
  • truckinguy 57 Points
    edited January 29
    Chris_Sav said:

    Finally heard from Garmin after five days! They have offered me a replacement refurbished 680T in place of my ailing new one! Good job it's already on its way back to the retailer.

    My new 680T crashed good yesterday... I finally got it to do a hard reset after many tries of initiating a reset it took and all is fine again...went for a hike and transferred the track fine.. but connecting to my 64 bit usb 3 Win 7 seems to set it off. As I mentioned above after transfer of waypoints or whatever either when use the safe to remove way or just unplugg it it won't come out of mas storage ..I have to remove the battery.. then it's ok. My old 610 did that as well If I remember.. it finally wouldn't start up like this one did over the weekend so I returned it.. so I don't think a refurbished is going to solve this...
    If there is a setting or way I'm missing let me know as it set's the unit into a corrupt mode eventually so bad it won't start up .. or reset even.. I am thinking that it takes many hours to try to work and I don't give it that creating more of a mess until it crashes good.
  • Chris_Sav 58 Points
    Sorry to hear of your bother, even if it does concur with my worries over the device.

    Can you get it into USB mode at all? possibly on an older computer with USB2? Next step would be to try forced USB mode. My thoughts moving to a clean RGN install if you can get the 680 into USB mode.

    Garmin's instructions to me on forced USB (which did not work) were:
    1. Ensure device battery is fully charged
    2. Disconnect device from computer
    3. Power device off
    4. Press and hold the POWER button
    5. Plug device into computer
    6. Wait until device is recognized by computer, it may take up to 30 seconds for device to be recognized as a drive
    7. If prompted, install USB device drivers
    8. Release appropriate button(s)


  • I got it to do a hard reset finally... I had tried that at first and after I pressed to erase all user data it did nothing just kept showing the choice screen... the last time I left it on that screen after pressing "yes" and eventually it went into hard reset and has been fine since.. but it still won't stop the mass storage mode without taking out the battery... so next time it jam's up I'll have to just leave it and see if it sorts itself out again. I am hoping it just needs lot's of time to sort out and reboot..
  • Chris_Sav 58 Points
    edited February 2
    My gut feeling is that you'll still hit trouble again sooner or later if the 680T refuses to safely disconnect. If Windoze refuses to safely disconnect it doesn't sound like it's being loaded as a portable device as pulling the rug out from under the drive is likely to corrupt it again. Mine got worse after the same symptoms as yours.

    Might be worth trying disabling in device manager before you pull the battery (device manager / show hidden devices / USB I think). I didn't try that before the PC refused to recognise internal storage at all.

    Reconditioned Monterra arrived yesterday, to tide me over for now until 680T or 276CX get fixed. Now there's a Pandora's box of goodies!
  • I'll try device manager next time thanks.. also I want to try a 276cx for my snowmobile.. I use the 680 for hiking and snowmobileing now... would love the buttons as my gloves are a pain in the butt ..on the screen..of 680..also the larger screen would be nice. I bet it's much brighter too. I would only load a Topo in it.
Sign In or Register to comment.
↑ Top