This site uses cookies to offer you a better browsing experience. Find out more about how to manage cookies, or dismiss this message and continue to use cookies.

3790 bricked?

Bought this unit used a couple weeks ago and it was working fine. Tried to connect to PC to update maps and was not able to find unit on PC (I know all about hidden files). Did a factory reset and now it seems bricked: loads up to "Loading maps" then stays there.
I tried
* turning on then pressing on power switch at copyright screen until "turn off device" appears, but neither button "cancel", "off" does anything
* putting a downloaded gcd file renamed to gupdate.gcd into microSD Garmin folder to try to boot from that
* calling Garmin support who told me there's nothing you can do
Hopefully one the gurus here can think of something?
MANY THANKS

Comments

  • Boyd 1735 Points
    edited February 17
    Sounds like it really is bricked. :( I used to have a 3790 and had a problem where it would hang at "Loading Maps", but the trick you describe worked for me; pressing the cancel button allowed the boot to continue without loading any maps. In my case, the problem was a corrupt map file that I had created myself.

    But the fact that neither button works in that dialog box is a bad sign. Have you tried the Garmin Cure 3 program (do a google search)? Never needed to use that myself, but it's worth a try.
  • Thanks Boyd.
    I kept on turning off and on and finally that trick worked! So now I'm back to where I was before, i.e. can't see the unit as a drive on my PC like all other Garmins I've had in the past. I did check online and the 3790 does not have a MTP mode.
  • Boyd 1735 Points
    Have you tried it on another computer? Are you using Windows 10? There are a lot of reports of problems recognizing Garmin devices on Windows 10, not quite sure what to make of them, I'm still on Windows 7. Anyway, I would try it on a Windows 7 machine, also on a Mac if you have one available. Also never hurts to try different USB cables - are you using the "real" Garmin cable that originally shipped with the 3790? IIRC, it was a really short little one. I think the 3790 was the first Nuvi to utilize a micro USB port, due to the thin design.
  • My experience of the USB problem was more associated with the USB version. My 680 would not load on a machine with a dedicated USB 3 port, but would load on an older machine with a USB 2 port, all on Windows 10.

    May not be any use to you, but worth a mention.

    Does the 3790 show up in device manager (show hidden devices) when plugged in? might give a clue as to whether its the port or the drivers.

    My 3790 has had a clout to the USB port area and is fussy as to which USB lead I use.

  • Thanks Chris and Boyd. A lot of useful answers.
    For me a 3rd USB cable did the trick. The others apparently were power-only!
  • sussamb 634 Points
    edited February 18
    Yep, those won't work for data transfer :)
  • Boyd 1735 Points
    Great, glad you got it working!
Sign In or Register to comment.
↑ Top