This site uses cookies to offer you a better browsing experience. Find out more about how to manage cookies, or dismiss this message and continue to use cookies.

Error message during most recent update Nuvi550

For my Nuvi550...
Last year I was able to use the cloning method to install larger maps on an SD card. It worked fine.
Since then, I've been able to update the maps, too...no problem.
This time (2018.20), following the same instructions I previously noted, I received this error message:

This Garmin GPS is not eligible for this update because a previous map version has not been installed.

I backed up all my files from the device and SD card to the computer first (of course).
Removed the SD card from the device and cleared it's contents, created a new folder named Garmin, transferred the file garmindevice.xml from the GPS device to the new Garmin folder on the SD card.
Unplugged the GPS from the computer, installed MapUpdater, which recognized the SD card as the device, checked off the acceptance of terms, and then...the error message.

Am I missing something?

Comments

  • t923347 403 Points
    edited May 19
    I attempted to update my 3597 yesterday using the cloning method and Mapupdater and got a message asking if I wanted to purchase a map update from Garmin. My only alternatives where to purchase an update or exit the program.

    I then attempted to update the Nuvi using the cloning method and Garmin Express and it proceeded to install 2018.20 with no problems.

    Maybe Mapupdater has finally come to the end of the line, but there has been occasions in the past when the update was available via Updater a day or so after you could get it from GE, so I guess we will just have to wait and see.
  • menhir 50 Points
    edited May 19
    I tried Garmin Express too but it would only offer to install the Lower 48, which pretty much negates the reason I switched to the cloning method in the first place.

    I purchased a reconditioned Zumo660 to replace my aging Nuvi550 about a month ago, so it's not like I'm lost (punny :-) )without it.

    Still, it works and I'd like to keep it updated. If I can't get the most recent update to work I'll just reload the last maps to the SD card or forget the SD card entirely and just update the Lower 48.

    Still hoping, though.
  • menhir 50 Points
    edited May 19
    It looks like thunderstorms are blowing in, so I'm back at the computer.

    I tried reinstalling the previous maps to the SD card and renaming them from gmapsupp back to gmapprom in the hopes of getting the server to see the previous maps, but still...no joy.

    Of course, I'm just puffing in a windstorm here. :-)
    t923347 said:

    ...there has been occasions in the past when the update was available via Updater a day or so after you could get it from GE, so I guess we will just have to wait and see.

    Ya know, now that you mention it, I recall that happening before, too.

    I'll just give it a rest for a day or two and give it another try.

  • menhir 50 Points
    I tried again today and was careful to note the MapInstaller did in fact recognize my SD card as my Nuvi 550 and indeed offered to install the latest map update. I checked all the agreements and, after it stated "connecting to server," I received the same error message.

    Back to square one.
  • menhir 50 Points
    I might as well follow up with some new details...

    I was able to load the new maps, but only the lower 48, to the SD card with Garmin Express, using the normal cloning method.

    MapUpdater was a fail. I never got it to work.

    (Incidentally, I couldn't even go back to loading the maps on the device either. Even with it stripped of extraneous files and voices, etc., there is no longer enough storage on the 550 for even the lower 48. )

    So that's somewhat resolved, but I wasn't giving up on Canada that easily so I called Garmin customer support which, by the way, was excellent.

    I was told that MapUpdater isn't going to work anymore. Express is necessary. Fine, said I, but Express only offers the lower 48 for my 550, not giving me the option for all on North American.
    Since I had already loaded all of NA to my computer when I updated my other devices, she sent me a link to MapInstaller which, she said, would allow me to transfer the full maps from my computer to my device.

    I haven't tried it yet, gotta get back to work, but I'll report if it works as stated.
Sign In or Register to comment.
↑ Top