This site uses cookies to offer you a better browsing experience. Find out more about how to manage cookies, or dismiss this message and continue to use cookies.

problems with my tomtom go 60

I have no maps on this gps. I can not choose my country. I can choose my language. When I first log on to drive connect the program says ( your gps is up to date ). When I look at the content of my gps, there is over 6000 bites free, so I know from that, no map is on my device. Map updates are free, but there is an icon there for map purchases. I have contacted tomtom support, and they have sent me an email.The email has an activate button displayed. I have applied the activate button as part of applying the drive connect software. Nothing happens. The software recognizes my gps and states...your device is up to date...I have tried many times now, but my tomtom go 60 is not working, no maps, no country, no updates. any help or suggestions, thanks for reading .

Comments

  • dhn 328 Points
    Anything here?:
    http://us.support.tomtom.com/app/answers/detail/a_id/16695/kw/no maps found

    Try this:
    1. Completely remove MyDriveConnect using the FREEWARE version of Revo Uninstaller. Get it here:
    https://www.revouninstaller.com/revo_uninstaller_free_download.html

    2. Get a fresh copy at tomtom.com/getstarted. Install.

    3. Do a drum reset on the unit by holding the power button about 20 seconds till you hear the drum sounds. Reconnect the device to the computer (use the cable that came with the device).

    4. If no success, call support:
    United States
    877-757-7137
    Monday - Friday: 9:00 a.m. to 8:00 p.m. EST
    Saturday: 10:00 a.m. to 6:00 p.m EST

  • johnward 19 Points
    thanks for your response....., working with tomtom support, but my tomtom go 60 remains a brick.
  • johnward 19 Points
    Actually after two frustrating weeks of back and forth with TomTom support, they finally came thru with a fix. I was able to download a map. The download was very slow but steady. I thank dhn for his timely response. I do appreciate this forum, you have always have been there for me. Thanks. My brick is now a gps.
  • dhn 328 Points
    Good to hear. Can you detail exactly what support did so others (including me!) can learn, please.
  • johnward 19 Points
    regarding my problem, difficult to get into my account, my gps would let me select a language, but not a country. there was no button to select. When I was in my account the software always said that my gps was up to date. But if you looked at map content there was almost none. so i could tell there was no map to download. Support helped. I was asked to give my account address and gps serial number. The next time I logged in there was a map to download, it no longer stated that my gps was up to date. I had to omit some content because the full map was to big to download. I downloaded a partial map to suit my needs. my emails to tomtom were over a two week span. there was always a reply button to their emails, so no problem there. And yes tomtom got back to me in a timely manor. I believe tomtom support of recent is much more receptive to emailing. That is wonderful. The last time I tried to log in to my account i was locked out. i emailed them and they sent a password reset email immediately. That worked. Over all i think of recent is tomtom is more receptive to emails. I hope this helps someone. I just hammered them with emails, time after time and they answered each one.
  • dhn 328 Points
    Thanks for the feedback.
Sign In or Register to comment.
↑ Top