This site uses cookies to offer you a better browsing experience. Find out more about how to manage cookies, or dismiss this message and continue to use cookies.

etrex Vista HCx no longer sees my microSD card, conputer will not recognize it.

I was out with it this past weekend and realized the battery was getting low so I put in some fresh batteries as I've done 100 times before. When I tried to turn it on again it got stuck on the opening Garmin screen for quite a while. After multiple attempts to turn it on it finally came on but it's no longer recognizing that the microSD card is in the unit. It only sees the basemap. Under Menu, I can restore defaults and have done that, Card Information is grayed out. It doesn't see the card. I can see the software version. I've inserted the card into my notebook and the microSD card itself seems to be fine. Windows 10 sees the files. I've had the same card in the unit for years and never had any reason to take it out as it has all the maps I ever want on it.

I tried to connect the etrex to the computer to see if I could do anything that way and the unit will not show up in Windows 10 explorer. Windows 10 gave a message that some garmin file did not have a proper signature and will no longer even attempt to connect the etrex via USB. Reboot turn off it will not give me the message again. The etrex doesn't show up in Explorer and neither Basecamp nor Mapsource are able to locate it.

Any ideas first how to just get the etrex to see that here is a microSD in the slot? It's only a 1GB microSD. Any idea how large a microSD card this old unit can take if I try copying the maps onto a brand new card? Even though it looks to me that the card itself is fine? I doun't they even make 1GB microSD cards any more.





Comments

  • Boyd 1795 Points
    Well the old eTrex models are not mass storage devices, so if there is no memory card they will not appear as a USB disk like the newer models. But Mapsource should recognize it if you try to send/receive data like waypoints or tracks since that is done with Garmin's proprietary protocol (which is no longer used on newer devices).

    If you can't do that, then clearly something is wrong. You could try to update to the newest firmware and see if the updater will recognize the device: http://www8.garmin.com/support/download_details.jsp?id=3709#Instruct

    What version firmware do you currently have. Note the 3.10 version history at that link that says they "Fixed potential lock up when SD card installed." Not sure what issues you might have with this old software updater on Windows 10 however.
  • Hi Boyd,

    Under Software is has:

    "Software version is 3.3

    GPS SW Version 2.9

    Unit ID lskdfjasf etc"

    I almost never have a need or desire to connect the etrex to the computer. This computer is about 2 years old. I don't know if I've ever tried to connect it until now. I wish I could get that error message about the garmin file that had an improper signature to even show again. I connect the unit to the computer now and zero happens other than that the unit appears to be drawing power from the computer.

    It just sits here. Mapsource, which I used to load the segments of United States Topo 100K onto the etrex from the CD's back around 2009, just can't find the etrex.

    Software version 3.3 is not a typo. I double checked.

    I don't really need to connect to the computer unless that will somehow fix it's ability recognize the card. I suppose I can hunt around and see if I have an old microSD card around and put the maps on that and see what happens?



  • I tried a different cable. Still it shows up nowhere. I thought it showed up in File explorer but as a device like Mice and keyboards do, though not as a drive. But it doesn't show up in the system tray and still neither Basecamp nor mapsource can locate the unit.

    I have the feeling my best bet is to find as small capacity microUSB card as I can find and try moving the map files. But still, my computer can read the existing card just fine. Otherwise all I can think is that the unit has finally malfunctioned. It lasted a lot longer than the etrex Legends that I have had.
  • Boyd 1795 Points

    It just sits here. Mapsource, which I used to load the segments of United States Topo 100K onto the etrex from the CD's back around 2009, just can't find the etrex.

    As I said, Mapsource won't be able to send maps unless the card is present and accessible, even if there's nothing wrong with the GPS. Did you try sending some waypoints to it? Of course that won't work if Mapsource doesn't see it at all.

    I don't recall clearly what was updated on those older models, but I'm sure they support 4gb cards, probably even 8gb. I suspect 4gb is the smallest you will find these days. But if you can't even send waypoints, you might as well save your money.

    Sounds like you have the newest firmware, but it would still be worth trying to re-install it and see if Garmin's software can even find the eTrex for that.

    There should be some kind of hard reset procedure for it, don't recall what it is on those old ones, typically it involved holding some buttons at startup. I'm sure Google can find it for you. If that doesn't work, yeah it's probably just dead. These things don't live forever. :)
  • If it's dead I suppose there is no harm trying to reinstall the firmware :)

    I think it's worth the money getting a small microSD card and trying it.

    I just have a lot of expenses coming up and wasn't planning on replacing the Vista right now. I just got a new DriveSmart. I just replaced my 17 year old Subaru with a new Outback and after 15 years I have car payments again. The Outback needs new Yakima landing pads and towers and that will be a few hundred dollars. The Outback also needs new quality speakers because the stock speakers are crap. That's another few hundred dollars.

    If I can kick start the Vista into reading the card again that would be good.

    It was just this summer that for some reason the Vista would not orient the map in the direction I was walking or riding. No Map up setting would make it do it. I wonder if that's somehow connected to a progressive systems failure.

  • crazyfingers 100 Points
    edited September 26
    Well I was at the pharmacy today and the smallest microSD they had was 32GB. Figured I'd try it. I put all the map data from the old card on the new one. It worked! I don't understand why since my computer had no problems reading the old card but whatever. So now I have 32 instead of 1gb of available space. Some day when I have absolutely nothing else to do maybe I'll put more maps on.

    At some point I will still want to try to get the computer to recognize the unit so that I can backup my waypoints. But that's not an urgent need.
  • alanb 375 Points
    Wow! It is surprising a 32 GB card works in a device that old.
  • I was surprised too. I only got it because I knew that I could use it to upgrade the storage on one of my kids tablets if it didn't work. Otherwise I would have waited. I can still get a smaller card down the road and give the 32 to the kid.
Sign In or Register to comment.
↑ Top