This site uses cookies to offer you a better browsing experience. Find out more about how to manage cookies, or dismiss this message and continue to use cookies.

Garmin dezl 760 lost it's map after update

Hello. I bought this Garmin dezl 760 almost a year ago, had no problem what so ever, until I updated the maps ( which I usually have done in the past) couple of days ago. Ever since when I want to enter a new address this message comes up: MAP DATA IS NOT AVAILABLE !!! Tried to connect it to Garmin express, but it didn't connect. Software version : 5.40, GPS firmware: 3.05.09 FMI: 3.1 HOS_FMI: 2.2
What is possible to do to bring this back to life? I'm a truck driver (OTR) & need this to work. Please help/advise. Thanks a lot.

Comments

  • alanb 375 Points
    Does it show up as a storage device when plugged into the computer? One thing you could try is to change the MTP setting from Auto Detect to Mass Storage mode: https://forums.garmin.com/forum/into-sports/garmin-connect/faq/37061- . Then see if it will be recognized by Garmin Express.
  • I followed all the steps that was in that link but still the computer does not recognize the GPS. Also when I go to map and vehicle and I tap on my maps there is nothing in there. Any idea?
  • alanb 375 Points
    edited October 21
    As I recall, the dezl 7xx series has a powered mount. Make sure you are plugging the USB cable directly into the dezl and not into the mount.
  • Boyd 1794 Points
    edited October 21
    Yes the Dezl has a powered mount and you will need to use the micro USB connecton on the device itself and not the mini USB connector on the mount. But since you have updated the maps before, I imagine you already know that. :)

    What you describe indicates that there was a problem with the update and your map is either missing or corrupt. The usual solution would be to just update again, but if the computer won't recognize the device then you have a real problem. The odd thing is that usually when a device is "bricked" like this, it will not function at all. However you indicate that the Dezl starts up and works, but it displays an error message.

    That seems odd. For starters I would try to eliminate the basic problems: connect it to a different computer and use a different USB cable. If it still doesn't work, the best bet is probably to call Garmin support and have your GPS and computer handy. You may have to wait a long time on hold, but they can walk you through diagnostics and even remotely test it.
  • Boyd 1794 Points
    FWIW, I just updated my own Dezl 760 for the first time since 2013 and everything went fine. But here's how the process went, maybe that will help. First it downloaded the new firmware and (evidently) some of the other Dezl-specific files. This only took about a minute on my fast FIOS connection. After completing this download I had to disconnect the GPS and restart it. This took awhile and I was wondering if everything was OK at first. But eventually it displayed a "software loading" message on the screen. After a little longer it started up as usual.

    Then there were two additional messages on the GPS screen about software being updated. Finally it said I would need to restart again to complete the process. Did all of this happen on your Dezl? Did you give it plenty of time to complete the firmware update?

    Finally, I plugged the Dezl back into my computer and it downloaded/installed the new map. This took 18 minutes on my 150mbit FIOS connection. After restarting the Dezl, everything was fine and it showed the 2018.30 map had been installed.
Sign In or Register to comment.
↑ Top