This site uses cookies to offer you a better browsing experience. Find out more about how to manage cookies, or dismiss this message and continue to use cookies.

CN EU 2018.20 NT

Comments

  • alanb 429 Points
    Is it the NT or NTU version? or both?
  • NT

    NTU came out in August..
  • I updated to the NTU version on the 28th August.
  • Ramaprem 111 Points
    edited November 2017
    "Is it the NT or NTU version?"
    Pardon my xxx, but what is the difference? What does each represent?

    I updated my map to CN EU 2018.20 a couple of months ago. And it was far more than 5+ GB.
  • sussamb 780 Points
    NT maps are used by older models that use the EU or part of the EU map, the NTU version is for newer models. For NA models there is only the NT version.
  • alanb 429 Points
    edited November 2017
    The "U" stands for the Unicode encoding standard, used for expanded text support of multiple languages.
  • alanb said:

    The "U" stands for the Unicode encoding standard, used for expanded text support of multiple languages.

    NT also have support for extended alphabets, etc.g. Danish (ÆØÅ)
  • Ramaprem 111 Points
    "For NA models there is only the NT version."

    I have had, for years, an "inconsistent" affair with Express. It often reports false - clearly false - info. But I'm sometimes unsure of some things that it reports.

    I have a European-bought 3597LMT unit - and also have a lifetime subscription to the NA map for this device. I've have had this for years, and have updated the NA map whenever an update has appeared.

    My device has this map installed:
    CN NA NT 2019.10
    and Express reports that my map is up-to-date.

    This is wrong, right?
    I see on the "map-update thread" that there have been two updates:
    2019.11 and 2019.20

    I'm entitled to an updated map, right?
    If so - and I don't see why not - can someone help me accomplish this? Calling Garmin (Germany) is one of my least favorite activities, and I do it as a last resort.

    Thanks for your support.

    Express for Mac: v6.7.0.0
    I've used Disk Utility to repair device and card.
  • alanb 429 Points
    One thing you could try is the old Garmin MapUpdater program. It appears Garmin has removed the download links for this program from their site and I couldn't find it on the Perry archive. So unless you already have it, I am not sure where you can get it. I have a copy for the PC, but not the Mac. Maybe some other member knows of a link where the Mac version of MapUpdater can be downloaded.
  • Boyd 1955 Points
    alanb said:

    It appears Garmin has removed the download links for this program from their site and I couldn't find it on the Perry archive.

    Look a little closer Alan. :)

    http://www.gawisp.com/perry/macintosh/MacMapUpdate_451.dmg

    I connected my Nuvi 3550 and ran this on my Mac. It asked me to agree with the license and then offered me City Navigator North Ameria 2019.20. I didn't go so far as to actually download it however.
  • Boyd 1955 Points
    edited August 15
    I just tried with Garmin Express now on my Mac. It forced me to install a "critical update", then it also said that 2019.20 was available for my Nuvi 3550.

    Seems to me that your problem is the fact you bought a separate lifetime subscription. Did you do that when they were still selling the DVD version? Can you still even buy lifetime subscriptions for different regions? I didn't think you could.

    Probably, the only way to resolve this is through Garmin, and if they won't help then you're probably out of luck. Because it sounds like the problem is that their database does not say your device is entitled to an update.
  • alanb 429 Points
    Thanks for the Perry link Boyd. I still can't find the PC version of Mapupdater on Perry, but it is probably there someplace too.

    I think you are right ... add-on lifetime map subscriptions for regions not pre-installed on a device are a thing of the past. I think this is most unfortunate for people who buy a Montana with the automotive cradle, although I suspect that market is in decline also.
  • Ramaprem 111 Points
    edited August 15
    Thank you for your suggestions. I will be trying them presently. I've just downloaded the MacMapUpdate application. I will let you know how it goes – but that probably has to wait until tomorrow.

    In actual fact, I haven't told you the whole story – because the whole story is a real mess, and confusing, too.
    Initially, Express told me that a new map was available. But it also told me that the map could not be installed directly to my device, but would be downloaded to my computer – and then I could use MapInstall to install it to my device. This is something that happens half the time when I use Express – with my North America map and with my European map; it doesn't matter. Half the time when there is a map update to download and install, I'm told that it cannot be installed directly on my device. And the other half times? It installs the map directly onto my device, as it should. I have been living with this situation/issue for years. I hate it - but have gotten used to it. (I have an sd-card with 10GB free space - so that is not part of the problem.)

    So I downloaded the map and used MapInstall to install it to the device - as directed, and as I have been forced to do in the past. Everything took place beautifully and then at the very end, I was shown this error message: ”An error has occurred. Make sure your device is connected and turned on.” Clearly, my device was connected and it was turned on. I attempted the same process about 10 times.

    So I completely deleted MapInstall, and re-downloaded and installed it. And that has left me with my present issue that I posted: Express doesn't see that there is a map update available for me.

    @Boyd
    ”Seems to me that your problem is the fact you bought a separate lifetime subscription.”
    - Hasn’t been an issue for all these years.
    ”Did you do that when they were still selling the DVD version?”
    - Yes. I bought the DVD version, and then bought a lifetime update subscription. On that basis, I have received and installed updates.
    ”Because it sounds like the problem is that their database does not say your device is entitled to an update.”
    - No - that’s not the problem, as I have explained just now. I was offered the update - but am not being offered it at present.
    The problem: Garmin's buggy software.

    @alanb
    "I think you are right ... add-on lifetime map subscriptions for regions not pre-installed on a device are a thing of the past."
    - Well, if this is true, it is really new. After all, I have 2019.10 from just months ago. I don't think that that applies here.

    I will be doing the work tomorrow, and will report back. Thanks for your help so far.
  • alanb 429 Points
    Since you already have a legitimate lifetime subscription purchased when the DVD was still available, you should be able to get the lifetime updates.

    My statement about "a thing of the past" was about customers who do not currently have a valid lifetime subscription and want to purchase it for a region that is not pre-installed. I believe that option is no longer available.
  • Boyd 1955 Points
    edited August 15
    IMO Garmin simply doesn't care. If they did, they would help with this problem.

    But the fact you mention MapInstall does raise a red flag however. Garmin broke the most recent version of Basecamp/MapInstall (which was released in May) and it cannot actually install a map on your GPS. They don't seem to be in any hurry to fix this problem either. Now the Windows version definitely has this major bug, but I'm not clear on whether the same bug exists in the Mac version.

    The solution is to downgrade to an earlier version of Basecamp/MapInstall. You will find these here:

    http://www.gawisp.com/perry/macintosh/

    If you are currently using Basecamp 4.7 then I suggest you try downgrading.
  • Ramaprem 111 Points
    "The solution is to downgrade to an earlier version of Basecamp/MapInstall."
    I will do that. But I was initially using the previous versions of those two apps - not the current versions. The last attempt at a solution was to update Basecamp/MapInstall, but that accomplished nothing.

    In the moment, however, it's a moot point - since I don't have a map update to install. Express isn't showing one. Express isn't allowing me to download an update. Express thinks that 2019.10 is the current map - that the NA map on the device is up-to-date.

    Catch-23ish.

    MacMapUpdate will be tried tomorrow.
  • Ramaprem 111 Points
    My first step this morning was to search my computer for files.
    I found the file: CN NA NT 2019.20 (abbreviations mine) here:
    my Home Folder>Library>Application Support>Garmin>Maps

    There are many other - and older - files present:

    image

    Great: the updated map had been downloaded and was on my computer. But I didn't really know what I was supposed to do with this file; how was I supposed to install it? Express wasn’t helping; MapInstall failed.

    So I launched Map Update, and it totally ignored the download already present - and went ahead with downloading the update (again). And it did the job. According to it. Your update has completed; your maps are up-to-date; is there anything else that we can do for you at this time, sir?
    Only one hitch: my device still says this map:
    CN NA NT 2019.10
    is installed.

    So, back to MapInstall. I used the previous version: 4.1.1. It offered me the opportunity to install the map update on my device or my sd-card. I can't choose the device itself, because (obviously) it hasn't the internal memory for that. So I chose to install on the card. The entire update is less than 4GB. I have more than 5GB free on the card. But MapInstall tells me that I don't have enough room on the card, and it also tells me that it can't transfer more than 4GB.
    So I chose a subset of the NA map (not to my liking) - but no matter how I limited the maps (like only the lower 48 and Hawaii), it said that the maps would not fit.

    This is endless. This is nasty.

    Am I to leave all those old files in the folder? Even the present update there wasn’t of any help in accomplishing anything.
  • Boyd 1955 Points
    edited August 16
    If you double-click a .gmap file, Map Manager should open on the Mac and ask if you want to install the map in Basecamp. Does that work for you? Can you see the map in Basecamp? Does it appear to be OK?

    [edit] Looking at your post again, it appears the map is already installed in the correct location for Basecamp on your computer. So does it work in Basecamp?

    If not, maybe something is corrupted in the file?

    If it appears to be OK, do you have access to a Windows computer? If so, you can install that map by copying the .gmap file to this location

    C:\ProgramData\Garmin\Maps

    Note that on Windows, it will appear as a folder and not a file. The Mac hides this from the user (if you have installed Garmin's software). Anyway, after you copy the file to that location on a Windows machine it should be available in both Basecamp and Mapsource. And I would use Mapsource to install whatever part of the map that you want, it's really much more reliable than MapInstall IMO. Unfortunately, there isn't anything comparable on the Mac.

    This will all work fine with "normal" maps, however City Navigator is copy protected, so I'm not sure if the map will work on your Nuvi when installed this way. Mapsource has a feature to import unlock codes, but I never understood how that worked.

    Now you are going to say that it's outrageous to jump through all these hoops just to install a map you have paid for. I agree. So - if Garmin really won't help you - ask yourself if this is the kind of company you want to do business with. ;)
  • Ramaprem 111 Points
    edited August 16
    For the moment, I'd like to not deal with another OS (Windows). I don't have a Windows machine - and won't install stuff (apps) on a friend's machine to do that.

    Regarding, therefore, your first paragraph only:
    "Does that work for you?"
    - Yes.
    "Can you see the map in Basecamp? Does it appear to be OK?"
    - Yes, BUT - MapManager now shows 2 maps installed: .10 and .20. So which one am I seeing in Basecamp? I have no idea.

    EDIT: the map lacks much detail - so it doesn't appear to be okay.

    Should I delete .10 - or at least move it from its present location? So that I know at what I am looking?

    I was on to Garmin earlier by phone. First thing was to delete all files on my sd-card. This did allow a re-installation via MapInstall to successfully install 2019.01 - not .20. But Express still claims that my map is up-to-date.
  • Ramaprem 111 Points
    Garmin has promised to get back to me - but I highly value the assistance that I'm getting here.
    So...keep it coming, if anyone has the patience. Mine is wearing quite thin.
  • Boyd 1955 Points
    Sounds like you’ve made progress, if it were me I’d just use 2019.10 and call it quits, LOL. :D Glad to hear that Garmin was helpful.

    You can use MapManager to delete maps, so just get rid of one or the other and see what happens. IIRC, it does not actually “delete” anything, it just adds the word “disabled” to the .gmap filename. But don’t quote me on that. ;)

    Otherwise, just manually move the unwanted .gmap file to a different location. Your screenshot above shows the standard location on the Mac. Removing a file from that folder will remove it from the Basecamp menu.
  • Ramaprem 111 Points
    It has all been remarkably frustrating, but the thing that really gets me right now is that I have the map!! It's sitting right there on my computer. But I can't get any of Garmin's software to install it!
  • alanb 429 Points
    edited August 16
    Another thing you could try is to use cloning with a new SD card. See if you can get the 2019.20 CN NA map only installed on the new SD. If that works, then try to re-install the Europe map on the new SD, again with cloning. If it appears both current maps are installed on the clone (SD card), replace the current SD card in your device with the newly created one and see what maps are shown. If that doesn't work, you can always go back to the original SD card.

    The other thing you could do that might help us figure out what is going on is post a directory (file list with names sizes and dates) of all .img, .gma and .unl files found in the following folders of your device (both internal memory and SD card):
    \.system
    \garmin
    \Map
  • Ramaprem 111 Points
    edited August 16
    "Sorry" alanb, but before reading this last post:

    I DID IT! I (BLEEPING: pardon my French) DID IT.

    I moved the .10 file out of the folder, and copied the .20 file to the MapInstall folder in the Garmin folder under application support. I then ran the newer version of MapInstall; that failed again.
    Then I ran the older version, and I DID IT!

    That left me with 2 maps on the sd-card. I trashed the older one: gmapsupp.img. The newer one was: gmapsupp.img_tmp
    I simply removed the _tmp in the file name! And: VOILA (pardon my French). It worked!

    I put the device in s(t)imulation mode, and took a drive around Brooklyn.

    I’m already planning to compete in hoop-thrujumping in Tokyo in 2020.

    image

    Wish me luck, and thanks for the support.
  • alanb 429 Points
    Glad you got it sorted out!
  • Ramaprem 111 Points
    Follow-up:

    I've had some continued and good support from Garmin here.
    They have made it clear that the NA map - which, in my case, was not pre-installed - will always get the message that it cannot be installed directly to the device. This is just their way of doing things.
    But my EU map should install directly to the device - which it is doing (EU 2019.20) at this moment.

    And I told them just today that the latest version of MapInstall is useless for installing maps! Let's see where that goes.
Sign In or Register to comment.
↑ Top