This site uses cookies to offer you a better browsing experience. Find out more about how to manage cookies, or dismiss this message and continue to use cookies.

Repeating message: "Serial accessories require external connection"

My Nuvi 1450 has been flipping this message up about every couple of minutes:

"Serial accessories require external connection"

I have no idea what this message is trying to tell me. I have no "accessories" or anything connected to the device so I don't understand why this message would be coming up.

Can someone tell me how to make this stop?

Comments

  • Is the USB socket clean? I'd make sure there's nothing bridging any of the terminals. Plug something in a couple of times in case there is.
  • sussamb 764 Points
    Agreed. I had something similar with my phone suggesting it was docked. Turned out to be a bit of dirt in the charging port.
  • As to plugging it in a couple of times, I do this fairly often.
    Dirt - Just looked and no dirt or corrosion.

    Anybody else?
  • Boyd 1953 Points
    edited December 2017
    "Serial accessories require external connection"

    That message makes absolutely no sense. The Nuvi doesn't support "serial accessories", and even if it did, how would it know you had one if it wasn't connected? When you say nothing is connected to the Nuvi, does that mean it is running on battery power without an external power connection?

    I don't think the 1450 has bluetooth, does it? If so, turn that off. Aside from that, I'd say it's probably time for a new GPS. My guess would be that the error message itself is part of some old legacy code in the firmware, from the days when Garmin used serial interfaces. Those days are long gone. ;)
  • Boyd said:

    "Serial accessories require external connection"

    That message makes absolutely no sense. The Nuvi doesn't support "serial accessories", and even if it did, how would it know you had one if it wasn't connected? When you say nothing is connected to the Nuvi, does that mean it is running on battery power without an external power connection?

    I don't think the 1450 has bluetooth, does it? If so, turn that off. Aside from that, I'd say it's probably time for a new GPS. My guess would be that the error message itself is part of some old legacy code in the firmware, from the days when Garmin used serial interfaces. Those days are long gone. ;)

    You're right, it doesn't make any sense.

    The only thing connected to my 1450 is the power cord, so no, it's not running off of the battery.

    The only thing that comes to mind after reading these messages is that something has gone wrong with either the power cord plug or the unit's power socket.

    As to buying another GPS, I bought this particular 1450 off ebay recently after loosing my original one. I want the 1450 specifically because it will fit into a custom cradle on my motorcycle. I used the 1450 on both my motorcycle and car for years and never had one single problem. I now have a 2589 that I use in my car but since they don't make cradles for it, I can't mount it on my MC.
  • Boyd 1953 Points
    In that case, I think the next step would be to run the unit on battery power with nothing attached to it, then see if you still get the same warnings. If so, then it probably has a serious internal problem. If not then a new power cord should fix it.

    If you're really married to the 1450, I'd pick up a few spares while you still can. ;)
  • Just tried a different power cord. The 1450 is doing the same thing.

    Either the power socket is bad or there is an internal problem. Time to get another one.
Sign In or Register to comment.
↑ Top