This site uses cookies to offer you a better browsing experience. Find out more about how to manage cookies, or dismiss this message and continue to use cookies.

Garmin Montana 680 - power on issues

Hi All,

Wondered if anyone has faced the same:

My garmin Montana is mounted in the Jeep using the Garmin windshield mount, the power supply connectors no longer work so I use a direct charge cable through the 12v supply. It will sit happily on charge mode and display the battery %, however I cannot wake it from this mode, if I press the power key once, twice, long or short, it switches off! The only way I can get it to 'work' is by disconnecting the power, turning it on, waiting for it to boot up completely and then reconnect the power, with fingers crossed as it either decides to switch on or go to USB option! Firm ware etc is all upto date, this issue started sometime last year I think with a previous update in Jan or Feb and this recent one hasn't helped! I have tried everything I can in settings on the unit to correct this and theres nothing. I have checked through the base camp app and theres nothing there to effect this set up. The battery life lasts 2 hours max.

Any clues?

Comments

  • Boyd 1853 Points
    Just some random thoughts.... What setting are you using under System > Interface Mode? That could make a difference, Garmin Spanner is probably the one you want.

    Why do the power supply connections "no longer work"? The brass contacts on the edge of the Montana look really rugged to me so I suspect the problem could be in the cradle (I also have one of these but havent used it for a long time). I would carefully inspect the fingers on the cradle and make sure they are clean and actually make contact with the pads on the Montana. Perhaps a new mount would fix this? Using a USB cable may damage that socket eventually, that's why Garmin has provided the other system.

    If it's really a firmware issue, then it's easy to roll back to whatever version works. Old versions are available here: http://gawisp.com/perry/montana/
  • Hi Boyd,

    I dont have a system option in the settings on the Garmin, I have gone through all the options and dont recall seeing it and theres no way to change the settings of the unit through basecamp either. I have no clue what a garmin spanner is, I only know of the ones that remove bolts, drop forged type?

    The unit receives power using the usb connector direct to the 12v socket. either the connections on the unit or the mount dont work. the only way to verify this is to buy a new mount, and if they are on the unit then thats a waste of money!

    the firmware is upto date. if I roll back the firmware I then lose all the updates of the newer versions - which eventually means my unit will be compromised....so not sure thats a good idea.
  • Chris_Sav 116 Points
    From main menu / up arrow / setup / system / interface / Garmin Spanner

    On powering 680 then asks you if you want to go into mass storage mode, answering no allows Montana to run normally under power.
  • Chris_Sav 116 Points
    edited January 11
    Having said that I've tried garmin spanner in your scenario on mine and still cannot get it out of the battery charge screen.

    I've also tried configuring 'double tap' on the power button options to route planner, but the damn thing switches off when you select map!!

    Do you possess a car plug-in battery charger with a USB socket on it? If so use that and your normal USB lead via Garmin spanner.
  • Thanks for the suggestions Chris. I tried the spanner option - hasnt made any difference unfortunately.
  • Chris_Sav 116 Points
    Reading through this again I'm wondering if your battery is OK, It should last more than 2 hours.

    Tried mine with a flat battery and a 12v charging lead direct to the USB socket and can only get the charging icon same as you. However using a standard data USB lead off my 12v AA battery charger the Montana goes operates normally via spanner mode
  • Chris_Sav 116 Points
    Of course another way around this is to use AA batteries in the unit when you want to use the power cord in the wagon, the 680 won't try to charge those.
  • truckinguy 115 Points
    edited January 17
    I clean my contacts with WD 40..make sure they push down..they might be stuck,etc. Also clean the GPS side. I used Fine steel wool lightly.. no eraser.
    In the 680 settings there is a Mount profile options.. make sure you have that set up right. All else fails ...hard reset should be done.
    Your battery may not be fully charged..with that said If your screen is on high and doesn't shut off then it will drain down.. Mine will go 12hrs and still have plenty of charge left while hiking.. on my snow machine it is set to stay on. With proper settings in Mount Profile menu for snowmachine use.
Sign In or Register to comment.
↑ Top