This site uses cookies to offer you a better browsing experience. Find out more about how to manage cookies, or dismiss this message and continue to use cookies.

Garmin RV 770 LMT-S crashing

My Garmin RV 770 LMT-S was today while driving always (absolutely always) crashing and then automatically restarting when I chose to see "Up Ahead" information on the right side of the screen. All other options for the right side of the screen worked fine. Right now, while I'm not driving anymore, it does not crash when choosing this option.

Does anybody have an idea how this can be fixed? Thanks

Comments

  • sussamb 780 Points
    First ensure you do a full shutdown rather than simply putting your device to sleep. That generally corrects any weird behaviour. If that doesn't work next step is a master reset.
  • truckinguy 115 Points
    Make sure your battery and unit is getting good steady current.. that'll crash it when the battery is getting low.
    Also try to re load the software...at Garmin Express
  • Boyd 1954 Points
    You can try simulating the same route you drove and see if it also crashes. On most current models you would press Settings > Navigation > GPS Simulator (you will need to scroll down to the bottom of the menu to see this option). Drag the map around and choose a location near where this happened, tap the map and use the "set location" button. Now you can enter a destination and choose the option to simulate driving the route.

    If this keeps happening, most likely you will need to do a hard reset, which is easy. But if you have any saved locations, back them up to you computer because the reset will erase them. This can be done with Garmin Express or Basecamp. The reset will also set all menu options to their default and clear your list of recent searches.

    To do a reset, go to the volume screen and press/hold your finger at the top right corner of the screen for about 10 seconds. Choose the option to "Clear all user data".

  • desertman 4 Points
    edited April 18
    Thanks, guys. Shutting off and on again and then simulating a route brought the same result. Resetting and starting fresh seems - at least in simulation mode, at least right now - to have fixed it. If this holds, I will be happy during today's trip.
  • desertman 4 Points
    edited April 18
    I apologize for the use of the term “guys.” It should, of course, have been “lady and gentlemen.”
  • alanb 425 Points
    edited April 18
    desertman said:

    I apologize for the use of the term “guys.” It should, of course, have been “lady and gentlemen.”

    www.chicagonow.com/listing-beyond-forty/2017/05/40-gender-neutral-alternatives-to-saying-you-guys/
    :)
  • desertman 4 Points
    Unfortunately it did work only for a few miles and then crashed again.

    I don't see a possibility to reload the software through Garmin Express, as was suggested to me. How exactly would I have to do this?

    For other suggestions I would be grateful, too.
  • desertman 4 Points
    edited April 18
    Well, now it works again in simulation mode. Will be interesting when I continue to drive. When it started not to work anymore before I had the feeling that the device tried to find the next rest area, could not find it - and decided to crash.

    Good is that the device is only 8 months old. Still time to contact Garmin and let them figure it out if this continues to not work properly.
  • desertman 4 Points
    Same, same after about 10 minutes. When wanting to have "Up Ahead" on the right side of the screen the device crashes immediately.
  • Boyd 1954 Points
    edited April 18
    So is this something that just started to happen recently? When was the last time you updated your software? It could be a new bug in the most recent software update. You can revert to older versions by downloading here: http://www.gawisp.com/perry/rv/

    It looks like there has been a software update within the past week. Is this the version you are running, and did the problem start after updating?

    RV_Camper770_520.gcd 2018-04-11 17:01 37M

    The previous update was in January. Did your device work properly then? If so, download this version.

    RV_Camper770_510.gcd 2018-01-19 06:31 37M

    after downloading, change the filename to gupdate.gcd and copy the file to the hidden .System folder on your device. There will probably already be a file named gupdate.gcd in the hidden .System folder. That is the installer for your current software, you might want to copy that to your computer. If you want to go back to the newer software, the process is the same. The device always checks the gupdate.gcd file at startup to see if it matches your current version. If not, it will ask if you want to install.

    Of course, if you aren't comfotable with this sort of tinkering, you should just call Garmin support and let them figure it out.
  • desertman 4 Points
    I chatted with Garmin's support.They have an open case regarding this issue. I sent them my crash logs.

    I had this happen before and after this week's update.
Sign In or Register to comment.
↑ Top