This site uses cookies to offer you a better browsing experience. Find out more about how to manage cookies, or dismiss this message and continue to use cookies.

Problems with new version of Basecamp/MapInstall?

There have been several reports at GPSFileDepot that the current version of MapInstall is broken. One user said everything has always worked fine for him, but after upgrading Basecamp (version 4.70?) he can no longer send maps to his GPS.

Anyone else notice this? If so, you can try downgrading to an older version from here: http://www.gawisp.com/perry/mapsource/

Alternately, you can use Garmin's older Mapsource software. https://www8.garmin.com/support/download_details.jsp?id=209

Comments

  • sussamb 798 Points
    Yes, numerous reports on that too on the Garmin forums. Link with Google Express is also broken. If you haven't upgraded BaseCamp I strongly suggest you don't. It's not an upgrade anyway, it's just Garmin removing some features!
  • Boyd 1980 Points
    edited May 17
    So, here we are with the one-year anniversary of this broken version of Basecamp/MapInstall coming next week. Garmin still has not fixed this, and in spite of some earlier mixed signals, it appears that they never will. See this Garmin support chat transcript that a GPSFileDepot user posted yesterday...

    https://forums.gpsfiledepot.com/index.php?topic=4539.msg25139#msg25139
    __________________
    beiley:
    BaseCamp 4.7 will not install 3rd party maps. This is a huge headache I spent hours struggling with. Can you fix it? I've had to go back to an earlier version of BaseCamp. See: https://forums.gpsfiledepot.com/index.php?topic=4539.0
    Chris :
    GPS File Depot isn't updating their software, so it is becoming less compatible with Garmin products
    beiley:
    They still offer lots of maps, that your older Basecamp can utilize. Why is it the new Basecamp can't use them, but the old Basecamp can?
    Chris :
    The new BaseCamp was upgraded to 64-bit architecture. It is likely that GPS File Depot software is 8 or 16-bit, which is not compatible with 64-bit programs
    beiley:
    That is not a very satisfying answer. I go back to the old Basecamp works, and the new one doesn't.
    Chris :
    The old BaseCamp was 32-bit software, the new one is 64-bit. many new computer operating systems are only compatible with 64 or higher software programs.

    __________________

    This is, of course, total BS. The issue has nothing to do with "8 or 16 bit GPSFileDepot software". But it's enough to convince me that Garmin is using this as an excuse for not supporting free third party maps (or even their own older products). Who knows? Maybe it was really just a bug originally? But they seem to have embraced it and developed a company line that GPSFileDepot "software" is not compatible with "new computer operating systems".

    IMO, this is arrogant and insulting. If they really want to stop you from using these maps, just say so. MapInstall or Basecamp could put up an alert box that says the map isn't compatible. Instead, when you send a map to the GPS, everything appears to go properly. But the map doesn't work on the GPS - frustrating and confusing the user.

    Based on what I now know, this is the real problem. The May 2018 Basecamp/MapInstall update does not support the old Windows registry-based maps. Garmin no longer makes maps in this format, but the vast majority of third party maps still use it, because that's what is supported by the (reverse-engineered) tools available to individual map-makers.

    When Garmin started supporting the Macintosh, they needed a new map format because the Mac doesn't have a registry like Windows. So they developed gmap, which is superior because it's based solely on files and folders. This makes map installation as easy as copying the files to the correct place (registry-based maps have to go through additional gymnastics). Shortly after that, Garmin switched all their maps to this new format because it works on both Macs and PC's.

    Since maps for the Macintosh don't use the registry, the Mac versions of Basecamp and MapInstall don't have the same problem as the Windows versions. And if you have a third party gmap-based map, then it should work properly in the Windows version. All of my own maps are in the gmap format, but I'm the exception to the rule. I have been urging other mapmakers at GPSFileDepot to move to the new format ever since 2011 with very little luck. So, I suppose there's a grain of truth that GPSFileDepot maps are out of date since the majority use the registry-based format. But that's no excuse for Garmin breaking something and then refusing to fix it.

    Anyway - end of rant - but I think it's shameful that Garmin hasn't fixed this problem and apparently has no intention to do so. The least they could do is document the issue if they aren't going to fix it.
  • Zemartelo 207 Points
    mapinstall is broken. I had to reinstall the previous version of it to be able to install maps.
  • Boyd 1980 Points
    edited May 19
    Yes, as I said they broke it on May 22, 2018 and apparently won't ever fix it. However, I think there's another fix without downgrading to an older version. Convert your maps with Garmin MapConverter. This will turn them into gmap files, which I *think* will work with MapInstall. If anyone tries this, let us know if it works.

    https://www8.garmin.com/support/download_details.jsp?id=3897
  • deserteagle56 87 Points
    edited May 19
    It's not just gpsfiledepot maps that the newer versions of Mapinstall won't work with.

    Years ago I bought the DVD versions of the Garmin 24k West, Southwest, and North Central states, and the Garmin 100k map of the United States. But I ended up not using the Garmin 100k since the data was so similar to the 24k maps so I never installed it on any of my GPS units. Boyd will remember this - I had mentioned not long ago in another post that I was having problems with my RV760 GPS "choking" when running the gpsfiledepot or Garmin 24k maps - parts of the screen, as it scrolled down, would just randomly appear as a gray blank area and I would have to zoom out to clear the problem. Thinking that perhaps the 100k maps would have less data for the GPS to process, I dug out my 100k DVD and loaded the mapset (only the western half of the United States) onto my RV760. And found that a lot of the data was completely missing. Driving only 80 miles south of my house I was surprised to see all data (topo lines, roads, etc.) disappear off the screen. After reading that the newer versions of Basecamp and Mapinstall were the problem, I found and downloaded the previous version. It did not help! Still missing data in sections of the mapset. I tried several other options but untimately ended up finding a copy of the old Mapsource program and used it to load the maps. Worked perfectly!

    Oh, and by the way...the RV760 does handle the 100k maps much better than the 24k ones. Just completed a 1,400 mile trip. Only very rarely do the blank gray areas appear now. I'm hoping that either the Drivetrack71 or the new Overlander will have enough processing power to totally eliminate the problem.
  • Boyd 1980 Points
    edited May 20
    As I wrote above,, all registry-based maps are going to have a problem with the current version of MapInstall. This is Garmin's old format, not exactly sure when they made the change to their topo maps, I'd guess it was somewhere around 2008.

    Try converting your old maps with Garmin MapConverter (link above). If it says the maps are have already been converted, then you might have a different problem.
Sign In or Register to comment.
↑ Top